summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-04-07 00:35:42 -0400
committerAnthony G. Basile <blueness@gentoo.org>2012-04-07 00:35:42 -0400
commit29afcf6d7baae950770d3468961da30b8d453913 (patch)
tree0cca8f0f367d6d1683b8cec9c0dc1a610adcd584
parentnet-libs/axTLS: moved to tree (diff)
downloadblueness-29afcf6d.tar.gz
blueness-29afcf6d.tar.bz2
blueness-29afcf6d.zip
net-misc/curl: add axTLS and polarssl backends
-rw-r--r--net-misc/curl/Manifest2
-rw-r--r--net-misc/curl/curl-7.25.0-r1.ebuild38
2 files changed, 28 insertions, 12 deletions
diff --git a/net-misc/curl/Manifest b/net-misc/curl/Manifest
index e329458..e859ec2 100644
--- a/net-misc/curl/Manifest
+++ b/net-misc/curl/Manifest
@@ -3,6 +3,6 @@ AUX curl-7.19.7-test241.patch 483 RMD160 3b9262cbde57b12ca89dcc358fa1be2a1cc6c47
AUX curl-fix-gnutls-nettle.patch 1186 RMD160 548495bb07bf24031bb3309509dc80c10d67e129 SHA1 e0ebd17ba1c1f1e1d32724cfb50fdac7b8122465 SHA256 d7a0f1ae6dcd50adddc9d7cd6dfcdb6b5ba648c8b7f9f067a8bf56f4136f3679
AUX curl-respect-cflags-3.patch 406 RMD160 4c569104bf7025676275f8df4b4c0337435145ef SHA1 569295c4a7ed58c790dea64fc3412f814924cee5 SHA256 b87bf2c491b057bc5af5258fffcf72d7c5e86b03218f497f097eeca845c0bc0d
DIST curl-7.25.0.tar.bz2 2418060 RMD160 e35b46a17fc2fc2a23fd12ed9488cc753bd941c5 SHA1 f6016a24051d98806ca3ddf754592701cb66e00c SHA256 cfb29139dfeb2449bf8a89963c3aed7d87f034013f05564cc0330b435c90b491
-EBUILD curl-7.25.0-r1.ebuild 5230 RMD160 cb76b95ac71283a37b57800869494b50e1d02bbf SHA1 43163c3d6070f3216068a924e521522270dbe293 SHA256 ab27c592a429f9a9474611b44e4b8fd863ed877b6d26a24ad833f37c57617761
+EBUILD curl-7.25.0-r1.ebuild 5993 RMD160 8484eb46cc08f00a9ab484ebf0ab85c0a1fab4dd SHA1 5f69f5bee1432085010bba3f5148328dc1d93717 SHA256 3545c99f7b64b82f33f1f130bac195d72115cef4c3f1cc7b6a2c630a5637f8eb
MISC ChangeLog 430 RMD160 bebe3ad7fc9cb42001caa8f431532e7a4ed13b5c SHA1 4916227f3470a17cf929e7eb64ea01d57c7f8531 SHA256 9d51430449fed031e0402eee618f1be9e01aeb894e7378e89c2182f0b6b2e148
MISC metadata.xml 488 RMD160 5b3487cf3f62c93923b0ba919fa22be6b7b1c1d3 SHA1 8d45b1b5f04c4c4f7cc146acf4a6770cd8fc9222 SHA256 e7f92e874709df69db561e06a461d6ac107222399b02367d8c2ba59f549de8c7
diff --git a/net-misc/curl/curl-7.25.0-r1.ebuild b/net-misc/curl/curl-7.25.0-r1.ebuild
index d6985b9..f958f6f 100644
--- a/net-misc/curl/curl-7.25.0-r1.ebuild
+++ b/net-misc/curl/curl-7.25.0-r1.ebuild
@@ -14,10 +14,11 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="ares idn ipv6 kerberos ldap ssh ssl static-libs test threads"
-IUSE="${IUSE} curl_ssl_gnutls curl_ssl_nss curl_ssl_openssl"
+IUSE="${IUSE} curl_ssl_axtls curl_ssl_gnutls curl_ssl_nss curl_ssl_openssl curl_ssl_polarssl"
RDEPEND="ldap? ( net-nds/openldap )
ssl? (
+ curl_ssl_axtls? ( net-libs/axTLS app-misc/ca-certificates )
curl_ssl_gnutls? (
|| (
( <=net-libs/gnutls-2.10.5 dev-libs/libgcrypt app-misc/ca-certificates )
@@ -27,6 +28,7 @@ RDEPEND="ldap? ( net-nds/openldap )
)
curl_ssl_openssl? ( dev-libs/openssl )
curl_ssl_nss? ( dev-libs/nss app-misc/ca-certificates )
+ curl_ssl_polarssl? ( net-libs/polarssl app-misc/ca-certificates )
)
idn? ( net-dns/libidn )
ares? ( net-dns/c-ares )
@@ -35,10 +37,8 @@ RDEPEND="ldap? ( net-nds/openldap )
sys-libs/zlib"
# ssl providers to be added:
-# axtls $(use_with axtls)
# cyassl $(use_with cyassl)
# fbopenssl $(use_with spnego)
-# polarssl $(use_with polarssl)
# rtmpdump ( media-video/rtmpdump ) / --with-librtmp
# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
@@ -55,7 +55,15 @@ DEPEND="${RDEPEND}
# ares must be disabled for threads
# only one ssl provider can be enabled
REQUIRED_USE="threads? ( !ares )
- ssl? ( ^^ ( curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss ) )"
+ ssl? (
+ ^^ (
+ curl_ssl_axtls
+ curl_ssl_gnutls
+ curl_ssl_openssl
+ curl_ssl_nss
+ curl_ssl_polarssl
+ )
+ )"
DOCS=( CHANGES README docs/FEATURES docs/INTERNALS \
docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE)
@@ -77,31 +85,41 @@ src_configure() {
einfo "\033[1;32m**************************************************\033[00m"
if use ssl ; then
+ if use curl_ssl_axtls; then
+ einfo "SSL provided by axTLS"
+ myconf+=( --with-axtls --without-ssl --without-gnutls --without-nss --without-polarssl )
+ myconf+=( --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
+ fi
if use curl_ssl_gnutls; then
einfo "SSL provided by gnutls"
if has_version net-libs/gnutls[nettle] ; then
einfo "gnutls compiled with dev-libs/nettle"
- myconf+=( --without-ssl --with-gnutls --with-nettle --without-nss )
+ myconf+=( --without-axtls --without-ssl --with-gnutls --with-nettle --without-nss --without-polarssl )
myconf+=( --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
else
einfo "gnutls compiled with dev-libs/libgcrypt"
- myconf+=( --without-ssl --with-gnutls --without-nettle --without-nss )
+ myconf+=( --without-axtls --without-ssl --with-gnutls --without-nettle --without-nss --without-polarssl )
myconf+=( --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
fi
fi
if use curl_ssl_nss; then
einfo "SSL provided by nss"
- myconf+=( --without-ssl --without-gnutls --with-nss )
+ myconf+=( --without-axtls --without-ssl --without-gnutls --with-nss --without-polarssl )
myconf+=( --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
fi
if use curl_ssl_openssl; then
einfo "SSL provided by openssl"
- myconf+=( --with-ssl --without-gnutls --without-nss )
+ myconf+=( --without-axtls --with-ssl --without-gnutls --without-nss --without-polarssl )
myconf+=( --without-ca-bundle --with-ca-path="${EPREFIX}"/etc/ssl/certs )
fi
+ if use curl_ssl_polarssl; then
+ einfo "SSL provided by polarssl"
+ myconf+=( --with-axtls --without-ssl --without-gnutls --without-nss --with-polarssl )
+ myconf+=( --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
+ fi
else
einfo "SSL disabled"
- myconf+=( --without-ssl --without-gnutls --without-nss )
+ myconf+=( --without-axtls --without-ssl --without-gnutls --without-nss --without-polarssl )
fi
einfo "\033[1;32m**************************************************\033[00m"
@@ -143,12 +161,10 @@ src_configure() {
$(use_enable static-libs static) \
$(use_enable threads threaded-resolver) \
--disable-versioned-symbols \
- --without-axtls \
--without-cyassl \
$(use_with idn libidn) \
$(use_with kerberos gssapi "${EPREFIX}"/usr) \
--without-krb4 \
- --without-polarssl \
--without-spnego \
--with-zlib \
"${myconf[@]}"