summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2013-05-13 13:20:42 -0400
committerDane Smith <c1pher@gentoo.org>2013-05-13 13:20:42 -0400
commitc0db74b6c381d80d0a0cf1dc82dbcc250ca4cc29 (patch)
tree69db4120bcb9c3d334368a5a66c78b9d890c3bd8
parentRevbump (diff)
downloadc1pher-c0db74b6c381d80d0a0cf1dc82dbcc250ca4cc29.tar.gz
c1pher-c0db74b6c381d80d0a0cf1dc82dbcc250ca4cc29.tar.bz2
c1pher-c0db74b6c381d80d0a0cf1dc82dbcc250ca4cc29.zip
Add file.
-rw-r--r--sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0-r1.ebuild b/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0-r1.ebuild
new file mode 100644
index 0000000..6a6a31a
--- /dev/null
+++ b/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils pam toolchain-funcs
+
+DESCRIPTION="Google Authentiator PAM plugin"
+HOMEPAGE="http://code.google.com/p/google-authenticator/"
+SRC_URI="http://google-authenticator.googlecode.com/files/${P}-source.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/allow_time_config.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ insinto $(getpam_mod_dir)
+ doins pam_google_authenticator.so
+ dobin google-authenticator
+
+ dodoc README
+}
+
+pkg_postinst() {
+ elog "For setup information check the installed README"
+}