summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-05-02 13:30:18 -0400
committerDane Smith <c1pher@gentoo.org>2011-05-02 13:30:18 -0400
commit68d4b940d0f87d48fb148666abb0ed9c637e2792 (patch)
tree631d96f184cba0edd34cf3e8736d16081d3c8078 /dev-libs/botan
parentRemove testing (diff)
downloadc1pher-68d4b940d0f87d48fb148666abb0ed9c637e2792.tar.gz
c1pher-68d4b940d0f87d48fb148666abb0ed9c637e2792.tar.bz2
c1pher-68d4b940d0f87d48fb148666abb0ed9c637e2792.zip
Version bump for botan.
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/ChangeLog7
-rw-r--r--dev-libs/botan/Manifest4
-rw-r--r--dev-libs/botan/botan-1.9.17.ebuild103
3 files changed, 112 insertions, 2 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index 3411969..17c431b 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for dev-libs/botan
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*botan-1.9.17 (02 May 2011)
+
+ 02 May 2011; Dane Smith <c1pher@gentoo.org> +botan-1.9.17.ebuild:
+ Bump to new version.
+
*botan-1.9.11-r2 (01 Dec 2010)
01 Dec 2010; Dane Smith <c1pher@gentoo.org> -botan-1.9.11-r1.ebuild,
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index 45b42bf..524d399 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,3 +1,5 @@
DIST Botan-1.9.12.tbz 3103452 RMD160 1e25e56b88d152440933b7bc3f450dbf20941204 SHA1 c72ecf935644188277e5e6fac1c2bfc9bf0042c7 SHA256 f863f9d89fa4354dd8434abc01058fbacfbca94e992e8be8a59d632b9caa78b1
+DIST Botan-1.9.17.tbz 2338028 RMD160 5bf5ac5f4c7c4bab229cb72a6f0c0ce752092615 SHA1 f85c7ed87b3004e788ff462bc3a838a4fca17c7d SHA256 e28b2daedd4dc827f3779f08fc7025bd283b1c9ea9dc97bf104a2404f5ebaa31
EBUILD botan-1.9.12.ebuild 2830 RMD160 70c5c2daa298323a59a55d60b02d888b61cbda23 SHA1 bf35e5c9c68c3508d1b5fc877e662c5bcbe81dd9 SHA256 fa4d51d9db4d8613265c86dc484e1fd4b625cc2cc5791d74a578b76b9f56164b
-MISC ChangeLog 977 RMD160 978bf37be03316920cca834fef79ab569ef48b85 SHA1 127a03568289302cbc8e81ad510c0e93413b122d SHA256 62624530da3e8eeda7dabcb5166d0a9f83f0570c0c1e3f2633e9b7f60a80f609
+EBUILD botan-1.9.17.ebuild 2748 RMD160 854afa5297e003009b8b637e735730c090daad93 SHA1 5d31eb75546a14f4ffb62c31f9eb168fd3dfac1f SHA256 b0015447479180d6ab4ed1ff8ca77292f9aa86f63d20cbabe8455936769a6724
+MISC ChangeLog 1098 RMD160 35a2ac20d8d5e916780de9cb8c57a2f8f17cbcd4 SHA1 84378671246a920a47969446c4b74ff8362d83b8 SHA256 70da67959f1d3084f9ffe5085ea30d225081893f595232f3ed1473f1e3b9ae15
diff --git a/dev-libs/botan/botan-1.9.17.ebuild b/dev-libs/botan/botan-1.9.17.ebuild
new file mode 100644
index 0000000..6d0690b
--- /dev/null
+++ b/dev-libs/botan/botan-1.9.17.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+RESTRICT_PYTHON_ABIS="3.*"
+inherit eutils multilib python toolchain-funcs
+
+MY_PN="Botan"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://botan.randombit.net/files/${MY_P}.tbz"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~ppc-macos"
+SLOT="0"
+LICENSE="BSD"
+IUSE="aesni altivec bzip2 doc gmp python sse2 ssse3 openssl zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="python? ( dev-libs/boost[python] )
+ bzip2? ( >=app-arch/bzip2-1.0.5 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )
+ gmp? ( >=dev-libs/gmp-4.2.2 )
+ openssl? ( >=dev-libs/openssl-0.9.8g )"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.7 >=app-doc/doxygen-1.7.3 )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ local disable_modules="proc_walk,unix_procs"
+
+ # Enable v9 instructions for sparc64
+ if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
+ CHOSTARCH="sparc32-v9"
+ else
+ CHOSTARCH="${CHOST%%-*}"
+ fi
+
+ cd "${S}"
+ elog "Disabling modules: ${disable_modules}"
+
+ local myos=
+ case ${CHOST} in
+ *-darwin*) myos=darwin ;;
+ *) myos=linux ;;
+ esac
+
+ # foobared buildsystem, --prefix translates into DESTDIR, see also make
+ # install in src_install, we need the correct live-system prefix here on
+ # Darwin for a shared lib with correct install_name
+ ./configure.py \
+ --prefix="${EPREFIX}/usr" \
+ --libdir=$(get_libdir) \
+ --docdir=share/doc/ \
+ --cc=gcc \
+ --os=${myos} \
+ --cpu=${CHOSTARCH} \
+ --with-endian="$(tc-endian)" \
+ --with-tr1=system \
+ --distribution-info="Gentoo ${PVR}" \
+ $(use_with doc sphinx) \
+ $(use_with doc doxygen) \
+ $(use_with python boost-python) \
+ $(use_with bzip2) \
+ $(use_with gmp gnump) \
+ $(use_with openssl) \
+ $(use_with zlib) \
+ $(use_enable sse2) \
+ $(use_enable ssse3) \
+ $(use_enable aesni aes-ni) \
+ $(use_enable altivec) \
+ --disable-modules=${disable_modules} \
+ || die "configure.py failed"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" LIB_OPT="${CXXFLAGS}" \
+ MACH_OPT="" LDFLAGS="${LDFLAGS}" || die "emake failed"
+
+ if useq python; then
+ emake CXX="$(tc-getCXX)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" -f Makefile.python || die "emake failed"
+ fi
+}
+
+src_test() {
+ chmod -R ugo+rX "${S}"
+ emake CXX="$(tc-getCXX)" CHECK_OPT="${CXXFLAGS}" check || die "emake check failed"
+ LD_LIBRARY_PATH="${S}" ./check --validate || die "Validation tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${ED}usr" install || die "emake install failed"
+
+ if useq python; then
+ emake install PYTHON_SITE_PACKAGE_DIR="${D}/usr/lib/python2.6/site-packages" -f Makefile.python || die "emake install failed"
+ fi
+}