summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <smithdanea@gmail.com>2010-11-17 08:08:55 -0500
committerDane Smith <smithdanea@gmail.com>2010-11-17 08:08:55 -0500
commit7c35e36bfe4ee330f7f9744d674caeacfa1c6655 (patch)
tree3a2ab33fd8f42cadbcc39f7ae8e59fb1248fb4f9 /dev-libs/botan
parentMask truecrypt test version. Remove old test ebuilds. (diff)
downloadc1pher-7c35e36bfe4ee330f7f9744d674caeacfa1c6655.tar.gz
c1pher-7c35e36bfe4ee330f7f9744d674caeacfa1c6655.tar.bz2
c1pher-7c35e36bfe4ee330f7f9744d674caeacfa1c6655.zip
New botan version
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/ChangeLog9
-rw-r--r--dev-libs/botan/Manifest3
-rw-r--r--dev-libs/botan/botan-1.9.10.ebuild102
3 files changed, 114 insertions, 0 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
new file mode 100644
index 0000000..127cd8f
--- /dev/null
+++ b/dev-libs/botan/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-libs/botan
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*botan-1.9.10 (17 Nov 2010)
+
+ 17 Nov 2010; Dane Smith <c1pher@gentoo.org> +botan-1.9.10.ebuild:
+ Initial version of botan-1.9
+
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
new file mode 100644
index 0000000..c586dab
--- /dev/null
+++ b/dev-libs/botan/Manifest
@@ -0,0 +1,3 @@
+DIST Botan-1.9.10.tbz 2977027 RMD160 b50f499cf3771582aa92333a73b8423f5e5a73f0 SHA1 600ea40b1ff563e806e7d85369870c0e04b2ae61 SHA256 a54cb37d171808e727be2835d09a924feb49d68e982f1ed95c95e8393d1f2a07
+EBUILD botan-1.9.10.ebuild 2585 RMD160 bbb2baa4ebc4baa8542b9d4ddd1074c31e50ebbc SHA1 eedfa841305320a2423edc7ca40df91a986bfdc3 SHA256 e93bca4f0701ead75b69dc3c8b18772b00962221e6ad579e9d1e28c81979852a
+MISC ChangeLog 244 RMD160 c44fa197754ec86b43e62c58b89ce84e8a8d0b69 SHA1 e264abe5b88223e0ba19ecccff4b431f6ce7ff69 SHA256 af37042fb3f9c2ff4d1b4cd1d4dd3ec174ecee0479e3f9c1b88448a3511a2ad6
diff --git a/dev-libs/botan/botan-1.9.10.ebuild b/dev-libs/botan/botan-1.9.10.ebuild
new file mode 100644
index 0000000..3df1af0
--- /dev/null
+++ b/dev-libs/botan/botan-1.9.10.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS="3.*"
+inherit eutils multilib python toolchain-funcs
+
+MY_PN="Botan"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://botan.randombit.net/files/${MY_P}.tbz"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~ppc-macos"
+SLOT="0"
+LICENSE="BSD"
+IUSE="altivec bzip2 gmp python sse2 ssse3 ssl threads zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="python? ( dev-libs/boost[python] )
+ bzip2? ( >=app-arch/bzip2-1.0.5 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )
+ gmp? ( >=dev-libs/gmp-4.2.2 )
+ ssl? ( >=dev-libs/openssl-0.9.8g )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ local disable_modules="proc_walk,unix_procs"
+
+ if ! useq threads; then
+ disable_modules="${disable_modules},pthreads"
+ fi
+
+ # Enable v9 instructions for sparc64
+ if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
+ CHOSTARCH="sparc32-v9"
+ else
+ CHOSTARCH="${CHOST%%-*}"
+ fi
+
+ cd "${S}"
+ elog "Disabling modules: ${disable_modules}"
+
+ local myos=
+ case ${CHOST} in
+ *-darwin*) myos=darwin ;;
+ *) myos=linux ;;
+ esac
+
+ # foobared buildsystem, --prefix translates into DESTDIR, see also make
+ # install in src_install, we need the correct live-system prefix here on
+ # Darwin for a shared lib with correct install_name
+ ./configure.py \
+ --prefix="${EPREFIX}/usr" \
+ --libdir=$(get_libdir) \
+ --docdir=share/doc/ \
+ --cc=gcc \
+ --os=${myos} \
+ --cpu=${CHOSTARCH} \
+ --with-endian="$(tc-endian)" \
+ --with-tr1=system \
+ $(use_with python boost-python) \
+ $(use_with bzip2) \
+ $(use_with gmp gnump) \
+ $(use_with ssl openssl) \
+ $(use_with zlib) \
+ $(use_enable sse2) \
+ $(use_enable ssse3) \
+ $(use_enable altivec) \
+ --disable-modules=${disable_modules} \
+ || die "configure.py failed"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" LIB_OPT="${CXXFLAGS}" MACH_OPT="" || die "emake failed"
+
+ if useq python; then
+ emake CXX="$(tc-getCXX)" -f Makefile.python || die "emake failed"
+ fi
+}
+
+src_test() {
+ chmod -R ugo+rX "${S}"
+ emake CXX="$(tc-getCXX)" CHECK_OPT="${CXXFLAGS}" check || die "emake check failed"
+ LD_LIBRARY_PATH="${S}" ./check --validate || die "Validation tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${ED}usr" install || die "emake install failed"
+
+ if useq python; then
+ emake install PYTHON_SITE_PACKAGE_DIR="${D}/usr/lib/python2.6/site-packages" -f Makefile.python || die "emake install failed"
+ fi
+}