summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <smithdanea@gmail.com>2010-12-01 13:46:34 -0500
committerDane Smith <smithdanea@gmail.com>2010-12-01 13:46:34 -0500
commita50502d7e01382b864bc515e95763c3a283675b6 (patch)
tree5641f0d544eb4b011e6ab2f474302997f45a7dd9 /dev-libs
parentRemove testing ebuild (diff)
downloadc1pher-a50502d7e01382b864bc515e95763c3a283675b6.tar.gz
c1pher-a50502d7e01382b864bc515e95763c3a283675b6.tar.bz2
c1pher-a50502d7e01382b864bc515e95763c3a283675b6.zip
Version bump for botan.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/botan/ChangeLog6
-rw-r--r--dev-libs/botan/Manifest5
-rw-r--r--dev-libs/botan/botan-1.9.11.ebuild106
-rw-r--r--dev-libs/botan/files/botan-1.9.11-python_wrapper_fixes.patch82
4 files changed, 198 insertions, 1 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index 127cd8f..3aeef22 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*botan-1.9.11 (01 Dec 2010)
+
+ 01 Dec 2010; Dane Smith <c1pher@gentoo.org> +botan-1.9.11.ebuild,
+ +files/botan-1.9.11-python_wrapper_fixes.patch:
+ Version bump and new patch.
+
*botan-1.9.10 (17 Nov 2010)
17 Nov 2010; Dane Smith <c1pher@gentoo.org> +botan-1.9.10.ebuild:
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index c586dab..850ee5a 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,3 +1,6 @@
+AUX botan-1.9.11-python_wrapper_fixes.patch 3186 RMD160 3be956306ed8460be3342f329acadc15a8d2aacc SHA1 4792a22b07a73351fe7441b64062d377ba4710c3 SHA256 5dfa21e23bbf235e837df187c422af0d5be09472898b78aa8689fd2820609d59
DIST Botan-1.9.10.tbz 2977027 RMD160 b50f499cf3771582aa92333a73b8423f5e5a73f0 SHA1 600ea40b1ff563e806e7d85369870c0e04b2ae61 SHA256 a54cb37d171808e727be2835d09a924feb49d68e982f1ed95c95e8393d1f2a07
+DIST Botan-1.9.11.tbz 2968277 RMD160 2f6da620c4ed37de11ac5d3f27b290b2d113da16 SHA1 f74da0e5421e14bb6d878a0a30b342062d5dfdd5 SHA256 483f4e63d9ff69d4fa4854066543b9487a8e6ff976a14931a132571525a424c9
EBUILD botan-1.9.10.ebuild 2585 RMD160 bbb2baa4ebc4baa8542b9d4ddd1074c31e50ebbc SHA1 eedfa841305320a2423edc7ca40df91a986bfdc3 SHA256 e93bca4f0701ead75b69dc3c8b18772b00962221e6ad579e9d1e28c81979852a
-MISC ChangeLog 244 RMD160 c44fa197754ec86b43e62c58b89ce84e8a8d0b69 SHA1 e264abe5b88223e0ba19ecccff4b431f6ce7ff69 SHA256 af37042fb3f9c2ff4d1b4cd1d4dd3ec174ecee0479e3f9c1b88448a3511a2ad6
+EBUILD botan-1.9.11.ebuild 2657 RMD160 fd2f3be8f700438405c1ac0407b363390d681505 SHA1 6c16b8201d67586594502965385090d5fcf431a5 SHA256 ab33fb2cf3be6e71ee679154107ccfd1d1278dd0f06bb38574dc563936c31aad
+MISC ChangeLog 422 RMD160 fd4b5ca717c29e99d3c61fe903a08f82433abe91 SHA1 9678cdcac4fe0ce5f7bb9602d06070021e54a916 SHA256 6d7e110f8366f7a31e2a4d52a55d3791f5d5d54a0b30dd26ce19f7b9197a9904
diff --git a/dev-libs/botan/botan-1.9.11.ebuild b/dev-libs/botan/botan-1.9.11.ebuild
new file mode 100644
index 0000000..8d12f93
--- /dev/null
+++ b/dev-libs/botan/botan-1.9.11.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS="3.*"
+inherit eutils multilib python toolchain-funcs
+
+MY_PN="Botan"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://botan.randombit.net/files/${MY_P}.tbz"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~ppc-macos"
+SLOT="0"
+LICENSE="BSD"
+IUSE="altivec bzip2 gmp python sse2 ssse3 ssl threads zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="python? ( dev-libs/boost[python] )
+ bzip2? ( >=app-arch/bzip2-1.0.5 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )
+ gmp? ( >=dev-libs/gmp-4.2.2 )
+ ssl? ( >=dev-libs/openssl-0.9.8g )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-python_wrapper_fixes.patch
+}
+
+src_configure() {
+ local disable_modules="proc_walk,unix_procs"
+
+ if ! useq threads; then
+ disable_modules="${disable_modules},pthreads"
+ fi
+
+ # Enable v9 instructions for sparc64
+ if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
+ CHOSTARCH="sparc32-v9"
+ else
+ CHOSTARCH="${CHOST%%-*}"
+ fi
+
+ cd "${S}"
+ elog "Disabling modules: ${disable_modules}"
+
+ local myos=
+ case ${CHOST} in
+ *-darwin*) myos=darwin ;;
+ *) myos=linux ;;
+ esac
+
+ # foobared buildsystem, --prefix translates into DESTDIR, see also make
+ # install in src_install, we need the correct live-system prefix here on
+ # Darwin for a shared lib with correct install_name
+ ./configure.py \
+ --prefix="${EPREFIX}/usr" \
+ --libdir=$(get_libdir) \
+ --docdir=share/doc/ \
+ --cc=gcc \
+ --os=${myos} \
+ --cpu=${CHOSTARCH} \
+ --with-endian="$(tc-endian)" \
+ --with-tr1=system \
+ $(use_with python boost-python) \
+ $(use_with bzip2) \
+ $(use_with gmp gnump) \
+ $(use_with ssl openssl) \
+ $(use_with zlib) \
+ $(use_enable sse2) \
+ $(use_enable ssse3) \
+ $(use_enable altivec) \
+ --disable-modules=${disable_modules} \
+ || die "configure.py failed"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" LIB_OPT="${CXXFLAGS}" MACH_OPT="" || die "emake failed"
+
+ if useq python; then
+ emake CXX="$(tc-getCXX)" -f Makefile.python || die "emake failed"
+ fi
+}
+
+src_test() {
+ chmod -R ugo+rX "${S}"
+ emake CXX="$(tc-getCXX)" CHECK_OPT="${CXXFLAGS}" check || die "emake check failed"
+ LD_LIBRARY_PATH="${S}" ./check --validate || die "Validation tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${ED}usr" install || die "emake install failed"
+
+ if useq python; then
+ emake install PYTHON_SITE_PACKAGE_DIR="${D}/usr/lib/python2.6/site-packages" -f Makefile.python || die "emake install failed"
+ fi
+}
diff --git a/dev-libs/botan/files/botan-1.9.11-python_wrapper_fixes.patch b/dev-libs/botan/files/botan-1.9.11-python_wrapper_fixes.patch
new file mode 100644
index 0000000..b7cd31b
--- /dev/null
+++ b/dev-libs/botan/files/botan-1.9.11-python_wrapper_fixes.patch
@@ -0,0 +1,82 @@
+#
+# old_revision [fe7f0ad489656afee72254e9c90a80b45b3a64b1]
+#
+# patch "src/build-data/makefile/python.in"
+# from [9a54ecabca6cb72ba7cf670e7426aacc28161d8a]
+# to [ea02068348f95c5be9cf878f8ea33880e5156fcf]
+#
+# patch "src/wrap/python/filter.cpp"
+# from [7cc91ffa5889e7483eb9a9e314ec42f5ace06273]
+# to [c855b9d7c7f458080b4844074d97f10c82daac0f]
+#
+# patch "src/wrap/python/x509.cpp"
+# from [7ae9bd324943cc782008e8322e542c58eb70d14d]
+# to [a603dfce3827f4569c5ef059b50b369662612cf2]
+#
+============================================================
+--- src/wrap/python/filter.cpp 7cc91ffa5889e7483eb9a9e314ec42f5ace06273
++++ src/wrap/python/filter.cpp c855b9d7c7f458080b4844074d97f10c82daac0f
+@@ -19,7 +19,7 @@ class Py_Filter : public Filter
+
+ std::string name() const { return "Py_Filter_FIXME"; }
+
+- void write(const byte data[], u32bit length)
++ void write(const byte data[], size_t length)
+ {
+ write_str(std::string((const char*)data, length));
+ }
+============================================================
+--- src/wrap/python/x509.cpp 7ae9bd324943cc782008e8322e542c58eb70d14d
++++ src/wrap/python/x509.cpp a603dfce3827f4569c5ef059b50b369662612cf2
+@@ -56,16 +56,6 @@ class memvec_to_hexstr
+ }
+ };
+
+-class X509_Store_Search_Wrap : public X509_Store::Search_Func,
+- public python::wrapper<X509_Store::Search_Func>
+- {
+- public:
+- bool match(const X509_Certificate& cert) const
+- {
+- return this->get_override("match")(cert);
+- }
+- };
+-
+ BOOST_PYTHON_MEMBER_FUNCTION_OVERLOADS(add_cert_ols, add_cert, 1, 2)
+ BOOST_PYTHON_MEMBER_FUNCTION_OVERLOADS(validate_cert_ols, validate_cert, 1, 2)
+
+@@ -132,11 +122,6 @@ void export_x509()
+ python::class_<X509_Store>("X509_Store")
+ .def("add_cert", &X509_Store::add_cert, add_cert_ols())
+ .def("validate", &X509_Store::validate_cert, validate_cert_ols())
+- .def("get_certs", &X509_Store::get_certs)
+ .def("add_crl", &X509_Store::add_crl);
+-
+- python::class_<X509_Store_Search_Wrap, boost::noncopyable>
+- ("Search_Func")
+- .def("match", python::pure_virtual(&X509_Store::Search_Func::match));
+ }
+ }
+============================================================
+--- src/build-data/makefile/python.in 9a54ecabca6cb72ba7cf670e7426aacc28161d8a
++++ src/build-data/makefile/python.in ea02068348f95c5be9cf878f8ea33880e5156fcf
+@@ -1,4 +1,5 @@ CXX = %{cc}
+ CXX = %{cc}
++LDFLAGS =
+ WARN_FLAGS = %{warn_flags}
+
+ PYTHON_ROOT = /usr/lib/python%{python_version}/config
+@@ -17,10 +18,11 @@ $(BOTAN_PYTHON_MODDIR)/_botan.so: $(PYTH
+
+ $(BOTAN_PYTHON_MODDIR)/_botan.so: $(PYTHON_OBJS)
+ cp src/wrap/python/*.py $(BOTAN_PYTHON_MODDIR)
+- $(CXX) -shared -o $@ $(PYTHON_OBJS) -L. -L$(PYTHON_ROOT) -lbotan -lboost_python -Wl,-rpath-link,. -Wl,-soname,$@
++ $(CXX) -shared -Wl,-soname,$@ $(PYTHON_OBJS) -L. -L$(PYTHON_ROOT) $(LDFLAGS) -lbotan -lboost_python -o $@
+
+ clean:
+- rm -f $(PYTHON_OBJS) $(BOTAN_PYTHON_MODDIR)
++ rm -rf $(BOTAN_PYTHON_MODDIR)/*
++ rm -f $(PYTHON_OBJS)
+
+ install:
+ mkdir -p $(PYTHON_SITE_PACKAGE_DIR)/botan