summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-05-25 13:09:49 -0400
committerDane Smith <c1pher@gentoo.org>2011-05-25 13:09:49 -0400
commiteb8d3d9826a86f709579dd0ee6a470632abef964 (patch)
treebacb98f763fbd0dc94fffe6a26da82da3b4f5943 /net-nntp/sabnzbd
parentWorking 2.6.36 version. (diff)
downloadc1pher-eb8d3d9826a86f709579dd0ee6a470632abef964.tar.gz
c1pher-eb8d3d9826a86f709579dd0ee6a470632abef964.tar.bz2
c1pher-eb8d3d9826a86f709579dd0ee6a470632abef964.zip
Add sabnzbd and mask it.
Diffstat (limited to 'net-nntp/sabnzbd')
-rw-r--r--net-nntp/sabnzbd/ChangeLog10
-rw-r--r--net-nntp/sabnzbd/Manifest4
-rw-r--r--net-nntp/sabnzbd/metadata.xml10
-rw-r--r--net-nntp/sabnzbd/sabnzbd-0.6.1.ebuild126
4 files changed, 150 insertions, 0 deletions
diff --git a/net-nntp/sabnzbd/ChangeLog b/net-nntp/sabnzbd/ChangeLog
new file mode 100644
index 0000000..fc01771
--- /dev/null
+++ b/net-nntp/sabnzbd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-nntp/sabnzbd
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*sabnzbd-0.6.1 (25 May 2011)
+
+ 25 May 2011; Dane Smith <c1pher@gentoo.org> +sabnzbd-0.6.1.ebuild,
+ +metadata.xml:
+ initial version
+
diff --git a/net-nntp/sabnzbd/Manifest b/net-nntp/sabnzbd/Manifest
new file mode 100644
index 0000000..d18f5fa
--- /dev/null
+++ b/net-nntp/sabnzbd/Manifest
@@ -0,0 +1,4 @@
+DIST SABnzbd-0.6.1-src.tar.gz 1888233 RMD160 0ac6823c2b850d4184b94f6a206241bcab04af1e SHA1 6e009f210235bb6b8278c59634bf2db1b5fb32f4 SHA256 b9b7e15c3e774aae42e248f19bc97bdbc17afe6bf27e236a7d565ddf5e11ae58
+EBUILD sabnzbd-0.6.1.ebuild 3624 RMD160 57dd59c268e7904b8a412cfd9b865e0373d4141c SHA1 6753fbaf7d99635157e78bb86d8f80700427c8a3 SHA256 be356808b7aac364e323615f861a4a9013c232abfa074bf3daad3fee0c9ec6ab
+MISC ChangeLog 252 RMD160 37a18861a1739a133fa07f2cf89be3bf067c88d3 SHA1 1d39f9e535afcdc498cfe06da872bf37d67a134b SHA256 ee66b4dfcec39dc60c0ac5f155b2d2be1b5f268209c5f78407488f8c798e52ec
+MISC metadata.xml 252 RMD160 0d6b4d4e9e2fc0a9fc73289b6f3234195a3a1405 SHA1 6d719654a220ceff01851fa059936c79ca6bf9be SHA256 50fba57de1e11a48fbf58020c096095ebf9ec5defa2b5bcda9ed44e5be159d3f
diff --git a/net-nntp/sabnzbd/metadata.xml b/net-nntp/sabnzbd/metadata.xml
new file mode 100644
index 0000000..2ba872d
--- /dev/null
+++ b/net-nntp/sabnzbd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>c1pher@gentoo.org</email>
+ <name>Dane Smith</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/net-nntp/sabnzbd/sabnzbd-0.6.1.ebuild b/net-nntp/sabnzbd/sabnzbd-0.6.1.ebuild
new file mode 100644
index 0000000..4cff54a
--- /dev/null
+++ b/net-nntp/sabnzbd/sabnzbd-0.6.1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils multilib python
+
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="3.*"
+EAPI="4"
+
+MY_P="$P"
+MY_P="${MY_P/sab/SAB}"
+MY_P="${MY_P/_beta/Beta}"
+MY_P="${MY_P/_rc/RC}"
+
+DESCRIPTION="Binary Newsgrabber written in Python"
+HOMEPAGE="http://www.sabnzbd.org/"
+SRC_URI="mirror://sourceforge/sabnzbdplus/${MY_P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+rar unzip rss +yenc ssl"
+
+RDEPEND="
+ >=dev-python/celementtree-1.0.5
+ >=dev-python/cheetah-2.0.1
+ >=app-arch/par2cmdline-0.4
+ >=dev-python/cherrypy-3.2
+ rar? ( >=app-arch/unrar-3.9.0 )
+ unzip? ( >=app-arch/unzip-5.5.2 )
+ yenc? ( >=dev-python/yenc-0.3 )
+ ssl? ( >=dev-python/pyopenssl-0.7
+ dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ app-text/dos2unix"
+
+S="${WORKDIR}/${MY_P}"
+
+HOMEDIR="${ROOT}var/lib/${PN}"
+DHOMEDIR="/var/lib/${PN}"
+
+pkg_setup() {
+ enewgroup "${PN}"
+ enewuser "${PN}" -1 -1 "${HOMEDIR}" "${PN}"
+}
+
+src_install() {
+
+ cp "${FILESDIR}/${PN}.ini" "${S}" || die "copying sample ${PN}.ini"
+
+ dodoc CHANGELOG.txt ISSUES.txt INSTALL.txt README.txt Sample-PostProc.sh Sample-PostProc.cmd
+
+ insopts -m0660 -o root -g ${PN}
+ newconfd "${FILESDIR}/${PN}.conf" "${PN}"
+
+ newinitd "${FILESDIR}/${PN}.init" "${PN}"
+
+ #SABnzbd >=0.6.0 write temp files when editing config from the web GUI, so directory needs to be writable by the SABnzbd process
+ diropts -m0770 -o root -g ${PN}
+ dodir /etc/${PN}
+
+ insinto /etc/${PN}/
+ insopts -m0660 -o root -g ${PN}
+ doins "${PN}.ini" || die "newins ${PN}.ini"
+
+ #Create all default dirs & mark with .keep so portage will not remove them
+ keepdir ${DHOMEDIR}
+ for i in admin cache complete download dirscan incomplete nzb_backup scripts; do
+ keepdir ${DHOMEDIR}/${i}
+ done
+
+ #Create & assign ownership of SABnzbd default directories
+ fowners -R root:${PN} ${DHOMEDIR}
+ fperms -R 770 ${DHOMEDIR}
+
+ #Create & assign ownership of SABnzbd log directory
+ keepdir /var/log/${PN}
+ fowners -R root:${PN} /var/log/${PN}
+ fperms -R 770 /var/log/${PN}
+
+ #Create & assign ownership of SABnzbd PID directory
+ keepdir /var/run/${PN}
+ fowners -R root:${PN} /var/run/${PN}
+ fperms -R 770 /var/run/${PN}
+
+ #Add themes & code into /usr/share
+ dodir /usr/share/${P}
+ insinto /usr/share/${P}
+ for i in interfaces sabnzbd email locale po tools util;do
+ doins -r $i
+ done
+
+ doins SABnzbd.py
+
+ #create symlink to /usr/share/sabnzbd (minus version #)
+ dosym /usr/share/${P} /usr/share/${PN}
+
+ #Adjust permissions in python source directory for root:sabnzbd
+ fowners -R root:${PN} /usr/share/${P}
+ fperms -R 770 /usr/share/${P}
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${P}/sabnzbd
+
+ einfo "SABnzbd has been installed with default directories in ${HOMEDIR}"
+ einfo "Email templates can be found in: ${ROOT}usr/share/${P}/email"
+ einfo ""
+ einfo "By default, SABnzbd runs as the unprivileged user \"sabnzbd\""
+ einfo "on port 8081 with no API key."
+ einfo ""
+ einfo "Be sure to that the \"sabnzbd\" user has the appropriate"
+ einfo "permissions to read/write to any non-default directories"
+ einfo "if changed in ${PN}.ini"
+ einfo ""
+ einfo "Configuration files are accessible only to users in the \"sabnzbd\" group"
+ einfo "Run 'gpasswd -a <user> sabnzbd' to add a user to the sabnzbd group"
+ einfo "so it can edit the appropriate configuration files"
+ einfo ""
+ ewarn "Please configure /etc/conf.d/${PN} before starting!"
+ ewarn ""
+ ewarn "Start with ${ROOT}etc/init.d/${PN} start"
+ ewarn "Visit http://<host ip>:8081 to configure SABnzbd"
+ ewarn "Default web username/password : sabnzbd/secret"
+}