summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/cryptlib/cryptlib-3.4.0.ebuild')
-rw-r--r--dev-libs/cryptlib/cryptlib-3.4.0.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/dev-libs/cryptlib/cryptlib-3.4.0.ebuild b/dev-libs/cryptlib/cryptlib-3.4.0.ebuild
index ff83774..bb985a3 100644
--- a/dev-libs/cryptlib/cryptlib-3.4.0.ebuild
+++ b/dev-libs/cryptlib/cryptlib-3.4.0.ebuild
@@ -30,7 +30,7 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}
app-arch/unzip"
-#DISTUTILS_SETUP_FILES="bindings/setup.py"
+DISTUTILS_SETUP_FILES="bindings/setup.py"
RESTRICT_PYTHON_ABIS="3.*"
src_unpack() {
@@ -59,16 +59,14 @@ src_prepare() {
# Fix version number of shared library.
sed -i -e 's/PLV="2"/PLV="3"/' tools/buildall.sh || die "sed tools/buildall.sh failed"
- #Fix where python will look for libraries
-# sed -i -e 's/\.\./\./g' bindings/setup.py \
-# || die "sed setup.py failed"
- sed -i -e 's:bindings/::g' bindings/setup.py || die "sed setup.py failed"
-
# Respect LDFLAGS and fix soname and strip issues.
epatch "${FILESDIR}/${PN}-3.3.2-ld.patch"
# Use external zlib.
epatch "${FILESDIR}/${PN}-3.4.0-external-zlib.patch"
+
+ #Fix setup.py
+ epatch "${FILESDIR}"/${P}-python.patch
}
src_compile() {
@@ -108,9 +106,7 @@ src_compile() {
# Python bindings don't work with -O2 and higher.
replace-flags -O* -O1
- pushd bindings > /dev/null
distutils_src_compile
- popd > /dev/null
fi
}
@@ -123,9 +119,7 @@ src_install() {
doins cryptlib.h || die
if use python; then
- pushd bindings > /dev/null
distutils_src_install
- popd > /dev/null
fi
dodoc README || die