summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCHTEKK <CHTEKK@localhost>2006-09-18 20:58:58 +0000
committerCHTEKK <CHTEKK@localhost>2006-09-18 20:58:58 +0000
commit7ed8bf03a8ddc09e18c142b39f96cdedd8048ac2 (patch)
tree19bf6b025a581426ebff9caeda8e23ea34623da4
parentnet2ftp updated in Portage now. (diff)
downloadchtekk-7ed8bf03a8ddc09e18c142b39f96cdedd8048ac2.tar.gz
chtekk-7ed8bf03a8ddc09e18c142b39f96cdedd8048ac2.tar.bz2
chtekk-7ed8bf03a8ddc09e18c142b39f96cdedd8048ac2.zip
Add Enigmail 0.94.1, as I need it myself. :)
svn path=/; revision=10
-rw-r--r--apps/x11-plugins/enigmail/Manifest10
-rw-r--r--apps/x11-plugins/enigmail/enigmail-0.94.1.ebuild137
-rw-r--r--apps/x11-plugins/enigmail/files/digest-enigmail-0.94.19
3 files changed, 156 insertions, 0 deletions
diff --git a/apps/x11-plugins/enigmail/Manifest b/apps/x11-plugins/enigmail/Manifest
new file mode 100644
index 0000000..a43eebf
--- /dev/null
+++ b/apps/x11-plugins/enigmail/Manifest
@@ -0,0 +1,10 @@
+DIST enigmail-0.94.1.tar.gz 513084 RMD160 1b8719c7669449f706bd3ff6964565e6ba9f8902 SHA1 d507757c065b607edecd193406ad60fcb7a67ace SHA256 3584329e4f51e43fbb9028cf47101de8c74651e7607de80cb1f61349424133c1
+DIST mozilla-thunderbird-1.5.0.7-patches-0.1.tar.bz2 30715 RMD160 a86a745963ad911da7c4e30eb9a673f1b657c5af SHA1 8e6f9fff11d06ee5f9f441527d466e6e1862263b SHA256 1f7af196a2342a27ebd37c1deed0ec6fb2e028d4b55faa9e3c5e761716b3352d
+DIST thunderbird-1.5.0.7-source.tar.bz2 35994957 RMD160 b8948723e4a96e22409e6a2cb3cd1b6512bef189 SHA1 9e5acff9bd098979dd798c0111805dc8d67479ad SHA256 99f67c50a94af48bc738c19cda390561ec518b5fec4bc4f1f43e65337b645fc9
+EBUILD enigmail-0.94.1.ebuild 4223 RMD160 72f76d1ff48f18d7b3e81ffe6bee258489933ae2 SHA1 d7447869ba7031606a1ae591f5eaaee89f3808dc SHA256 d0172d3046ef04af3425e96dfb700b63653783df8465a7230bf7712bccf5b6aa
+MD5 0f4699e4aed65c8dcaec04dc7d951b27 enigmail-0.94.1.ebuild 4223
+RMD160 72f76d1ff48f18d7b3e81ffe6bee258489933ae2 enigmail-0.94.1.ebuild 4223
+SHA256 d0172d3046ef04af3425e96dfb700b63653783df8465a7230bf7712bccf5b6aa enigmail-0.94.1.ebuild 4223
+MD5 df59ed8c7e36aa270f8a86aec77e2bd4 files/digest-enigmail-0.94.1 855
+RMD160 85d44863c8d206d354a10a9f756fff44e0ef6f17 files/digest-enigmail-0.94.1 855
+SHA256 076f4fa9f6817e6a7b93a8a9443eea9b319a13ce9049b0d3354273ceb6354775 files/digest-enigmail-0.94.1 855
diff --git a/apps/x11-plugins/enigmail/enigmail-0.94.1.ebuild b/apps/x11-plugins/enigmail/enigmail-0.94.1.ebuild
new file mode 100644
index 0000000..23ec8bb
--- /dev/null
+++ b/apps/x11-plugins/enigmail/enigmail-0.94.1.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/enigmail-0.94.0-r5.ebuild,v 1.2 2006/08/12 03:06:12 kumba Exp $
+
+unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
+inherit flag-o-matic toolchain-funcs eutils nsplugins mozcoreconf makeedit multilib autotools
+
+EMVER=${PV}
+TBVER="1.5.0.7"
+TBPVER="0.1"
+
+DESCRIPTION="Gnupg encryption plugin for thunderbird."
+HOMEPAGE="http://www.enigmail.mozdev.org"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${TBVER}/source/thunderbird-${TBVER}-source.tar.bz2
+ mirror://gentoo/mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2
+ http://www.mozilla-enigmail.org/downloads/src/enigmail-${EMVER}.tar.gz"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE=""
+
+DEPEND=">=mail-client/mozilla-thunderbird-${TBVER}"
+RDEPEND="${DEPEND}
+ >=app-crypt/gnupg-1.4.5
+ >=www-client/mozilla-launcher-1.37"
+
+S=${WORKDIR}/mozilla
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export MOZ_CO_PROJECT=mail
+
+src_unpack() {
+ unpack thunderbird-${TBVER}-source.tar.bz2 mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2 || die "unpack failed"
+ cd ${S} || die "cd failed"
+
+ # Apply our patches
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch ${WORKDIR}/patch
+
+ # Unpack the enigmail plugin
+ cd ${S}/mailnews/extensions || die
+ unpack enigmail-${EMVER}.tar.gz
+ cd ${S}/mailnews/extensions/enigmail || die "cd failed"
+ makemake2
+
+ cd ${S}
+
+ # Use the right theme for thunderbird #45609
+ sed -i -ne '/^enigmail-skin.jar:$/ { :x; n; /^\t/bx; }; p' mailnews/extensions/enigmail/ui/jar.mn
+
+ # Don't allow upgrades via the browser
+ epatch ${FILESDIR}/50_enigmail_no_upgrade-1.patch
+
+ # Fix installation of enigmail.js
+ epatch ${FILESDIR}/70_enigmail-fix.patch
+
+ eautoreconf || die "failed running autoreconf"
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+
+ # tb-specific settings
+ mozconfig_annotate '' \
+ --with-system-nspr \
+ --with-system-nss \
+ --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME} \
+ --with-user-appdir=.thunderbird
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, and this breaks
+ # thunderbird
+ gcc-specs-ssp && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ ####################################
+ #
+ # Configure and build Thunderbird
+ #
+ ####################################
+
+ econf || die "econf failed"
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ # Only build the parts necessary to support building enigmail
+ emake -j1 export || die "make export failed"
+ emake -C modules/libreg || die "make modules/libreg failed"
+ emake -C xpcom/string || die "make xpcom/string failed"
+ emake -C xpcom || die "make xpcom failed"
+ emake -C xpcom/obsolete || die "make xpcom/obsolete failed"
+
+ # Build the enigmail plugin
+ einfo "Building Enigmail plugin..."
+ emake -C ${S}/mailnews/extensions/enigmail || die "make enigmail failed"
+
+ # Package the enigmail plugin; this may be the easiest way to collect the
+ # necessary files
+ emake -j1 -C ${S}/mailnews/extensions/enigmail xpi || die "make xpi failed"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+ declare emid
+
+ cd ${T}
+ unzip ${S}/dist/bin/*.xpi install.rdf
+ emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' install.rdf)
+
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
+ cd ${D}${MOZILLA_FIVE_HOME}/extensions/${emid}
+ unzip ${S}/dist/bin/*.xpi
+
+ # these files will be picked up by mozilla-launcher -register
+ dodir ${MOZILLA_FIVE_HOME}/{chrome,extensions}.d
+ insinto ${MOZILLA_FIVE_HOME}/chrome.d
+ newins ${S}/dist/bin/chrome/installed-chrome.txt ${PN}
+ echo "extension,${emid}" > ${D}${MOZILLA_FIVE_HOME}/extensions.d/${PN}
+}
diff --git a/apps/x11-plugins/enigmail/files/digest-enigmail-0.94.1 b/apps/x11-plugins/enigmail/files/digest-enigmail-0.94.1
new file mode 100644
index 0000000..056946f
--- /dev/null
+++ b/apps/x11-plugins/enigmail/files/digest-enigmail-0.94.1
@@ -0,0 +1,9 @@
+MD5 b255e7a77ecea435934bfa1872e99f6a enigmail-0.94.1.tar.gz 513084
+RMD160 1b8719c7669449f706bd3ff6964565e6ba9f8902 enigmail-0.94.1.tar.gz 513084
+SHA256 3584329e4f51e43fbb9028cf47101de8c74651e7607de80cb1f61349424133c1 enigmail-0.94.1.tar.gz 513084
+MD5 02c06f7c12807daf4d990db5519696e6 mozilla-thunderbird-1.5.0.7-patches-0.1.tar.bz2 30715
+RMD160 a86a745963ad911da7c4e30eb9a673f1b657c5af mozilla-thunderbird-1.5.0.7-patches-0.1.tar.bz2 30715
+SHA256 1f7af196a2342a27ebd37c1deed0ec6fb2e028d4b55faa9e3c5e761716b3352d mozilla-thunderbird-1.5.0.7-patches-0.1.tar.bz2 30715
+MD5 c3933149147567471000e53dbeac7429 thunderbird-1.5.0.7-source.tar.bz2 35994957
+RMD160 b8948723e4a96e22409e6a2cb3cd1b6512bef189 thunderbird-1.5.0.7-source.tar.bz2 35994957
+SHA256 99f67c50a94af48bc738c19cda390561ec518b5fec4bc4f1f43e65337b645fc9 thunderbird-1.5.0.7-source.tar.bz2 35994957