summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-08-20 18:40:36 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-08-20 18:40:36 +0000
commita9ea7a817acc4718e497f0ef05051caec81574fe (patch)
tree7a340093fcf08f4671bb178831c189ec545772b8 /media-video/elisa
parentBump to pigment-python-0.3.5 (diff)
downloadmaintainer-a9ea7a817acc4718e497f0ef05051caec81574fe.tar.gz
maintainer-a9ea7a817acc4718e497f0ef05051caec81574fe.tar.bz2
maintainer-a9ea7a817acc4718e497f0ef05051caec81574fe.zip
Elisa bump
svn path=/maintainer/; revision=100
Diffstat (limited to 'media-video/elisa')
-rw-r--r--media-video/elisa/Manifest2
-rw-r--r--media-video/elisa/elisa-0.5.6.ebuild126
2 files changed, 128 insertions, 0 deletions
diff --git a/media-video/elisa/Manifest b/media-video/elisa/Manifest
index 6517416..2d355b6 100644
--- a/media-video/elisa/Manifest
+++ b/media-video/elisa/Manifest
@@ -1,5 +1,7 @@
DIST elisa-0.3.3.tar.gz 22564562 RMD160 1042cda8033dec4e8ce91aefb58822426e9d551d SHA1 6dd78be630d0ac128972f5f2ee9a4033f623876b SHA256 98c28abcc4dfcdd41b559d6b214b671fa7d31782bd0bc5411e2b47de5ed017e3
DIST elisa-0.3.5.tar.gz 1034087 RMD160 49d2255e31c9ac324d38a3c7184f551c510480a5 SHA1 a8e2ce46077e425f5a59748af2ade1c6204ce476 SHA256 0bf6d9f19a96d343b37a3d3e388925e61145988c7af487df679804b34a19fc56
+DIST elisa-0.5.6.tar.gz 469430 RMD160 02c58b0c1761e43b2c80af689ae4c0e009647472 SHA1 5413ad7ef657db33c227df56e75e4121a6600275 SHA256 2d2ed14a40ba1a2c32ba084a46def47fb49de53782961588f12d85c2e1f3a9af
EBUILD elisa-0.3.3.ebuild 2962 RMD160 c76dcea2fcdb668ac6a07280a9e594ec1eb83db9 SHA1 545ce4882a29fa4d1468b44d344493a11580df93 SHA256 a32fc088c35ed2094ce394ba7e6968addf51b8965f4a9bfccd6fc4c0817753f5
EBUILD elisa-0.3.5.ebuild 3211 RMD160 29051bbe7659a1c3c1a5a8753fca1118132a4f37 SHA1 40a8e6be2b68feaa828c5d3c078df10deb76b95f SHA256 9fbbc0cd41f0d001cfdf8bb76713d5d458e3e89072a64ffc43e098fac3273074
+EBUILD elisa-0.5.6.ebuild 3307 RMD160 246408c1677df338faa72bbf75cdd2cadb7f0841 SHA1 a72e329d85cc38cdaba34b785d617edfddd568f4 SHA256 f953cce4d9df177109fca889bc8fa2432b2de21581b1260c41322da2ae4418d3
MISC ChangeLog 18767 RMD160 14598a4e0c8d6d5576bb933dc26d730fff074ac8 SHA1 9510daaaaffc8d87efbf690e16f311e8e2eaf22f SHA256 c4e8bfd41d28d82f8b1b8d16c751a939bbbb06c1ba3282d758b644e184ccee3d
diff --git a/media-video/elisa/elisa-0.5.6.ebuild b/media-video/elisa/elisa-0.5.6.ebuild
new file mode 100644
index 0000000..450f485
--- /dev/null
+++ b/media-video/elisa/elisa-0.5.6.ebuild
@@ -0,0 +1,126 @@
+# Copyright 2006-2007 BreakMyGentoo.org
+# Copyright 2008 Daniel Gryniewcz
+# Distributed under the terms of the GNU General Public License v2
+
+inherit distutils python
+
+DESCRIPTION="Elisa is an open source, cross platform media center solution for Linux, MacOSX and Windows on top of GStreamer."
+HOMEPAGE="http://elisa.fluendo.com/"
+SRC_URI="http://elisa.fluendo.com/static/download/${PN}/${P}.tar.gz"
+
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ppc ~x86"
+IUSE="daap doc dvd hal ipod flash lirc upnp weather"
+
+MAKEOPTS="-j1"
+
+RDEPEND=">=dev-lang/python-2.5
+ dev-python/setuptools
+ >=dev-python/imaging-1
+ >=dev-python/twisted-2.2
+ dev-python/twisted-web
+ dev-python/pyopenssl
+ dev-python/pygtk
+ dev-python/gnome-python-extras
+ >=dev-python/pigment-python-0.3.5
+ >=media-libs/gstreamer-0.10.4
+ >=dev-python/gst-python-0.10
+ >=media-plugins/gst-plugins-ogg-0.10
+ >=media-plugins/gst-plugins-vorbis-0.10
+ >=media-plugins/gst-plugins-theora-0.10
+ media-plugins/libvisual-plugins:0.4
+ media-fonts/liberation-fonts-ttf
+ x11-misc/xdg-user-dirs
+ dev-python/pyxdg
+ dvd? (
+ media-libs/libdvdcss
+ >=media-plugins/gst-plugins-ffmpeg-0.10
+ >=media-libs/gst-plugins-bad-0.10
+ >=media-libs/gst-plugins-ugly-0.10
+ dev-python/tagpy
+ )
+ flash? (
+ >=media-plugins/gst-plugins-ffmpeg-0.10
+ >=media-libs/gst-plugins-bad-0.10
+ dev-python/gdata
+ )
+ lirc? (
+ app-misc/lirc
+ dev-python/pylirc
+ )
+ daap? (
+ dev-python/PythonDaap
+ >=sys-apps/dbus-1
+ >=dev-python/dbus-python-0.71
+ >=net-dns/avahi-0.6
+ )
+ hal? (
+ >=sys-apps/hal-0.5
+ >=dev-python/dbus-python-0.71
+ )
+ ipod? (
+ media-libs/libgpod
+ )
+ upnp? (
+ dev-python/coherence
+ )
+ weather? (
+ dev-python/pymetar
+ )"
+
+
+DEPEND="${DEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+PDEPEND=">=media-plugins/elisa-plugins-good-${PV}
+ >=media-plugins/elisa-plugins-bad-${PV}
+ >=media-plugins/elisa-plugins-ugly-${PV}"
+
+DOCS="AUTHORS ChangeLog COPYING NEWS FIRST_RUN"
+
+pkg_setup() {
+ if use daap ; then
+ if built_with_use net-dns/avahi python ; then
+ einfo "Avahi Python bindings found ..."
+ else
+ eerror "Please rebuild net-dns/avahi with python support enabled!"
+ eerror "Try USE=\"python\" emerge net-dns/avahi,"
+ eerror "or add \"python\" to your USE string in /etc/make.conf and"
+ eerror "emerge net-dns/avahi."
+ die "USE flag \"python\" must be enabled in net-dns/avahi"
+ fi
+ fi
+
+
+ if use ipod ; then
+ if built_with_use media-libs/libgpod python ; then
+ einfo "libgpod Python bindings found ..."
+ else
+ eerror "Please rebuild media-libs/libgpod with python support enabled!"
+ eerror "Try USE=\"python\" emerge media-libs/libgpod,"
+ eerror "or add \"python\" to your USE string in /etc/make.conf and"
+ eerror "emerge media-libs/libgpod."
+ die "USE flag \"python\" must be enabled in media-libs/libgpod"
+ fi
+ fi
+
+ addpredict "/root/.gstreamer-0.10"
+}
+
+pkg_postinst() {
+
+ einfo "After first run of the box, edit elisa.conf and add some media"
+ einfo "locations in [xmlmenu:locaions_builder]"
+ einfo "e.g."
+ einfo "locations = ['file://./sample_data/pictures', 'file:///media/videos']"
+ einfo ""
+ einfo "If you get failures loading plugins, delete ~/.elisa"
+ einfo ""
+ einfo "Please replace gstreamer:gst_metadata_client with"
+ einfo "gstreamer:gst_metadata in your ~/.elisa/elisa.conf to get song"
+ einfo "metadata scanning"
+
+}