summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/x264-svn/x264-svn-20061122.ebuild')
-rw-r--r--media-libs/x264-svn/x264-svn-20061122.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/media-libs/x264-svn/x264-svn-20061122.ebuild b/media-libs/x264-svn/x264-svn-20061122.ebuild
deleted file mode 100644
index bf31443..0000000
--- a/media-libs/x264-svn/x264-svn-20061122.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264-svn/x264-svn-20061014.ebuild,v 1.1 2006/10/14 21:35:35 lu_zero Exp $
-
-inherit multilib eutils toolchain-funcs
-
-IUSE="debug gtk mp4 threads"
-
-MY_P=${P/svn/snapshot}-2245
-
-DESCRIPTION="A free library for encoding X264/AVC streams."
-HOMEPAGE="http://developers.videolan.org/x264.html"
-SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND="mp4? ( >=media-video/gpac-0.4.1_pre20060122 )"
-
-DEPEND="${RDEPEND}
- amd64? ( dev-lang/yasm )
- x86? ( dev-lang/nasm )
- x86-fbsd? ( dev-lang/nasm )
- gtk? ( >=x11-libs/gtk+-2.0 )"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
-# sed -i -e '/$CFLAGS -s/d' -e '/$LDFLAGS -s/d' configure || die
- epatch "${FILESDIR}"/${P}-nostrip.patch
-}
-
-src_compile() {
- local myconf=""
- use debug && myconf=--enable-debug
-
- ./configure --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- --enable-pic --enable-shared \
- "--extra-cflags=${CFLAGS}" \
- "--extra-ldflags=${LDFLAGS}" \
- "--extra-asflags=${ASFLAGS}" \
- $(use_enable threads pthread) \
- $(use_enable mp4 mp4-output) \
- $(use_enable gtk) \
- $myconf \
- || die "configure failed"
-
- emake CC="$(tc-getCC)" || die "make failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS
-}