summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/paludis/files/paludis-0.12.0-getfsize.patch')
-rw-r--r--sys-apps/paludis/files/paludis-0.12.0-getfsize.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/paludis/files/paludis-0.12.0-getfsize.patch b/sys-apps/paludis/files/paludis-0.12.0-getfsize.patch
new file mode 100644
index 0000000..d6e0858
--- /dev/null
+++ b/sys-apps/paludis/files/paludis-0.12.0-getfsize.patch
@@ -0,0 +1,48 @@
+Index: ebuild/builtin_fetch_bin.bash
+===================================================================
+--- ebuild/builtin_fetch_bin.bash (revision 1970)
++++ ebuild/builtin_fetch_bin.bash (working copy)
+@@ -26,7 +26,7 @@
+ local aa=${a##*/}
+ hasq "${aa}" ${unique_aa} || unique_aa="${unique_aa} ${aa}"
+
+- if [[ -f "${PKGDIR}/${aa}" ]] && [[ "0" != $(stat -c '%s' "${PKGDIR}/${aa}" ) ]] ; then
++ if [[ -f "${PKGDIR}/${aa}" ]] && [[ "0" != $(getfsize "${PKGDIR}/${aa}") ]] ; then
+ if [[ "${old_aa}" != "${aa}" ]] ; then
+ ebuild_section "Already have ${aa}"
+ old_aa="${aa}"
+Index: ebuild/builtin_fetch.bash
+===================================================================
+--- ebuild/builtin_fetch.bash (revision 1970)
++++ ebuild/builtin_fetch.bash (working copy)
+@@ -26,7 +26,7 @@
+ local aa=${a##*/}
+ hasq "${aa}" ${unique_aa} || unique_aa="${unique_aa} ${aa}"
+
+- if [[ -f "${DISTDIR}/${aa}" ]] && [[ "0" != $(stat -c '%s' "${DISTDIR}/${aa}" ) ]] ; then
++ if [[ -f "${DISTDIR}/${aa}" ]] && [[ "0" != $(getfsize "${DISTDIR}/${aa}") ]] ; then
+ if [[ "${old_aa}" != "${aa}" ]] ; then
+ ebuild_section "Already have ${aa}"
+ old_aa="${aa}"
+Index: ebuild/utils/getfsize
+===================================================================
+--- ebuild/utils/getfsize (revision 0)
++++ ebuild/utils/getfsize (revision 0)
+@@ -0,0 +1,5 @@
++#!/bin/bash
++case $(uname -s) in
++ FreeBSD) stat -f '%z' $@ ;;
++ *) stat -c '%s' $@ ;;
++esac
+Index: ebuild/utils/Makefile.am
+===================================================================
+--- ebuild/utils/Makefile.am (revision 1970)
++++ ebuild/utils/Makefile.am (working copy)
+@@ -33,6 +33,7 @@
+ fowners \
+ fperms \
+ getmtime \
++ getfsize \
+ newbin \
+ newconfd \
+ newdoc \ \ No newline at end of file