summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/unladen-swallow/files/install-version2.patch')
-rw-r--r--dev-lang/unladen-swallow/files/install-version2.patch72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-lang/unladen-swallow/files/install-version2.patch b/dev-lang/unladen-swallow/files/install-version2.patch
new file mode 100644
index 0000000..b0b457d
--- /dev/null
+++ b/dev-lang/unladen-swallow/files/install-version2.patch
@@ -0,0 +1,72 @@
+diff -urN Lib/distutils/command/build.py Lib/distutils/command/build.py
+--- Lib/distutils/command/build.py 2010-02-04 21:32:01.000000000 -0800
++++ Lib/distutils/command/build.py 2010-02-04 22:49:25.000000000 -0800
+@@ -83,7 +83,7 @@
+ "--plat-name only supported on Windows (try "
+ "using './configure --help' on your platform)")
+
+- plat_specifier = ".%s-%s" % (self.plat_name, sys.version[0:3])
++ plat_specifier = ".%s-%s" % (self.plat_name, sys.version[0:3] + "-unladen")
+
+ # Make it so Python 2.x and Python 2.x with --with-pydebug don't
+ # share the same build directories. Doing so confuses the build
+diff -urN Lib/distutils/command/build_ext.py Lib/distutils/command/build_ext.py
+--- Lib/distutils/command/build_ext.py 2010-02-04 21:32:01.000000000 -0800
++++ Lib/distutils/command/build_ext.py 2010-02-04 22:49:25.000000000 -0800
+@@ -758,9 +758,9 @@
+ else:
+ from distutils import sysconfig
+ if sysconfig.get_config_var('Py_ENABLE_SHARED'):
+- template = "python%d.%d"
++ template = "python%s"
+ pythonlib = (template %
+- (sys.hexversion >> 24, (sys.hexversion >> 16) & 0xff))
++ (sys.version[0:3] + "-unladen",))
+ return ext.libraries + [pythonlib]
+ else:
+ return ext.libraries
+diff -urN Lib/distutils/sysconfig.py Lib/distutils/sysconfig.py
+--- Lib/distutils/sysconfig.py 2010-02-04 21:32:01.000000000 -0800
++++ Lib/distutils/sysconfig.py 2010-02-04 22:49:26.000000000 -0800
+@@ -52,7 +52,7 @@
+ leaving off the patchlevel. Sample return values could be '1.5'
+ or '2.2'.
+ """
+- return sys.version[:3]
++ return sys.version[:3] + "-unladen"
+
+
+ def get_python_inc(plat_specific=0, prefix=None):
+diff -urN Lib/site.py Lib/site.py
+--- Lib/site.py 2010-02-04 21:31:58.000000000 -0800
++++ Lib/site.py 2010-02-04 22:49:32.000000000 -0800
+@@ -252,7 +252,7 @@
+ else:
+ USER_BASE = env_base if env_base else joinuser("~", ".local")
+ USER_SITE = os.path.join(USER_BASE, "lib",
+- "python" + sys.version[:3],
++ "python" + sys.version[:3] + "-unladen",
+ "site-packages")
+
+ if ENABLE_USER_SITE and os.path.isdir(USER_SITE):
+@@ -274,7 +274,7 @@
+ sitedirs.append(os.path.join(prefix, "Lib", "site-packages"))
+ elif os.sep == '/':
+ sitedirs.append(os.path.join(prefix, "lib",
+- "python" + sys.version[:3],
++ "python" + sys.version[:3] + "-unladen",
+ "site-packages"))
+ sitedirs.append(os.path.join(prefix, "lib", "site-python"))
+ else:
+diff -urN setup.py setup.py
+--- setup.py 2010-01-15 01:09:04.000000000 -0800
++++ setup.py 2010-02-05 01:19:44.656255205 -0800
+@@ -22,7 +22,7 @@
+
+ def record_build_dir():
+ """Record the relative path to the build diretory for site.py."""
+- build_dir = "build/lib.%s-%.3s" % (get_platform(), sys.version)
++ build_dir = "build/lib.%s-%.3s-unladen" % (get_platform(), sys.version)
+
+ build_dir_file = os.path.join(os.path.dirname(sys.executable), "build_dir")
+ f = open(build_dir_file, "w")