summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-12-14 17:10:59 +0100
committerPeter Alfredsen <loki_val@gentoo.org>2008-12-14 17:10:59 +0100
commit4618e8b17714dc1761c2c7cfac4afcef61e92785 (patch)
tree4195bc1030232c5f313bd0c86b803ae448bf1fa4 /net-dialup/wvdial/wvdial-1.60.ebuild
parentRepo_name update (diff)
downloadloki_val-4618e8b17714dc1761c2c7cfac4afcef61e92785.tar.gz
loki_val-4618e8b17714dc1761c2c7cfac4afcef61e92785.tar.bz2
loki_val-4618e8b17714dc1761c2c7cfac4afcef61e92785.zip
Import wvdial
Diffstat (limited to 'net-dialup/wvdial/wvdial-1.60.ebuild')
-rw-r--r--net-dialup/wvdial/wvdial-1.60.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-dialup/wvdial/wvdial-1.60.ebuild b/net-dialup/wvdial/wvdial-1.60.ebuild
new file mode 100644
index 0000000..b1090e0
--- /dev/null
+++ b/net-dialup/wvdial/wvdial-1.60.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/wvdial-1.60.ebuild,v 1.7 2008/01/12 21:29:54 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="Excellent program to automatically configure PPP sessions"
+HOMEPAGE="http://alumnit.ca/wiki/?WvDial"
+SRC_URI="http://alumnit.ca/download/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86"
+IUSE=""
+
+COMMON_DEPEND=">=net-libs/wvstreams-4.4"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ net-dialup/ppp"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}-destdir.patch"
+}
+
+src_install() {
+ make "DESTDIR=${D}" install || die "make install failed"
+
+ dodoc CHANGES FAQ MENUS README TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "Use wvdialconf to automagically generate a configuration file."
+ elog
+ elog "Users have to be member of the dialout AND the uucp group"
+ elog "to use wvdial!"
+ elog
+}