summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2009-02-04 15:09:56 +0100
committerThomas Raschbacher <lordvan@gentoo.org>2009-02-04 15:09:56 +0100
commit972f9772a3513422b6e8e7dda749bff4625bffa6 (patch)
tree0ac40b31ad7047fcd2a78947b830b77d99389bd1 /sci-misc/varicad
parentremoved backup changelog file (diff)
downloadlordvan-972f9772a3513422b6e8e7dda749bff4625bffa6.tar.gz
lordvan-972f9772a3513422b6e8e7dda749bff4625bffa6.tar.bz2
lordvan-972f9772a3513422b6e8e7dda749bff4625bffa6.zip
added varicad 3.04 and varicad-de 3.04
Diffstat (limited to 'sci-misc/varicad')
-rw-r--r--sci-misc/varicad/ChangeLog8
-rw-r--r--sci-misc/varicad/Manifest4
-rw-r--r--sci-misc/varicad/varicad-3.04.ebuild77
3 files changed, 89 insertions, 0 deletions
diff --git a/sci-misc/varicad/ChangeLog b/sci-misc/varicad/ChangeLog
new file mode 100644
index 0000000..7737d4d
--- /dev/null
+++ b/sci-misc/varicad/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sci-misc/varicad
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*varicad-3.04 (04 Feb 2009)
+ varicad-3.04.ebuild
+ Added ebuild for VariCAD (both amd64 and x86)
+
diff --git a/sci-misc/varicad/Manifest b/sci-misc/varicad/Manifest
new file mode 100644
index 0000000..eb1160e
--- /dev/null
+++ b/sci-misc/varicad/Manifest
@@ -0,0 +1,4 @@
+DIST varicad2008-en_3.04_amd64.deb 64778172 RMD160 594a2e1091b1676e5798cc54dea2555448631946 SHA1 600c9c8ce61cef03450c07cdf8f650d134d6b0c9 SHA256 cd7eafe84fd3872af71589653b9a407cd836da72a9bad2f475c17fba694a7fd6
+DIST varicad2008-en_3.04_i386.deb 64772152 RMD160 e579aa266880fda20e66b5dbff737f95753bb2c9 SHA1 cdd0e9b916d5f59d75b926bc42088cdf10ccb956 SHA256 fba863e2c3f5fcf90c7438295370c8cb11ff6208fa83c2463021993bb68967cd
+EBUILD varicad-3.04.ebuild 1919 RMD160 6b3e4d432efdd2af7fe2b25a96412d2ab723f9db SHA1 6faa4a58317a02f074a9092be6f9b6012df0b576 SHA256 56780cf9ebeadd42b1b09a8bc4607b276f1a07697b32f69279e4e8ca028dda00
+MISC ChangeLog 218 RMD160 529ef4eeee8cd81379c939e8a9995268ab002c39 SHA1 c87fc46f762d9c9ba248a62a00d609b3483eb983 SHA256 53ac9e0259473899ecd28b6ec70649943cedba044bd90e14778a714fd7034a04
diff --git a/sci-misc/varicad/varicad-3.04.ebuild b/sci-misc/varicad/varicad-3.04.ebuild
new file mode 100644
index 0000000..df506f4
--- /dev/null
+++ b/sci-misc/varicad/varicad-3.04.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="VeriCAD"
+HOMEPAGE="http://www.vericad.com/"
+SRC_URI="x86? ( varicad2008-en_${PV}_i386.deb )
+ amd64? ( varicad2008-en_${PV}_amd64.deb )"
+
+LICENSE=""
+SLOT="0"
+
+# NOTE: varicad binaries are supplied just pre-stripped.
+RESTRICT="fetch strip"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="!sci-misc/varicad-de
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ virtual/opengl"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ echo
+ eerror "Please go to: http://www.varicad.com/"
+ eerror
+ eerror "and download the VariCAD for Linux 2008 ${PV}"
+ eerror " Debian package for your platform"
+ eerror "After downloading it, put the .deb into:"
+ eerror " ${DISTDIR}"
+ echo
+}
+
+src_unpack() {
+ unpack ${A}
+ unpack ./data.tar.gz
+ cd "${S}"
+
+ # removing not necessary content
+ rm control.tar.gz data.tar.gz debian-binary \
+ opt/VariCAD/desktop/*.sh \
+ usr/share/menu/varicad2008-en \
+ opt/VariCAD/desktop/varicad.mdkmenu \
+ opt/VariCAD/desktop/varicad.wmconfig
+
+ # NOTE: we need to strip some (useless) quotes
+ sed -i \
+ -e "s:\"::g" opt/VariCAD/desktop/varicad.desktop \
+ || die "seding varicad.desktop failed"
+}
+
+src_install() {
+ # creating the desktop menu
+ domenu opt/VariCAD/desktop/varicad.desktop || die "domenu failed."
+ domenu opt/VariCAD/desktop/x-varicad.desktop || die "domenu mime-type failed."
+ doicon opt/VariCAD/desktop/{varicad_*.png,varicad.xpm} || die "doicon failed."
+ rm opt/VariCAD/desktop/*.desktop \
+ opt/VariCAD/desktop/varicad_*.png
+ rm -r opt/VariCAD/desktop
+
+ # installing the docs
+ dodoc usr/share/doc/varicad2008-en/{README-en.txt,README.Debian,copyright,changelog.gz}
+ rm usr/share/doc/varicad2008-en/*
+
+ # installing VariCAD
+ cp -pPR * "${D}"/ || die "installing data failed"
+}