summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2011-05-03 20:30:17 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2011-05-03 20:30:17 +0000
commit54aa42907b1a5a2a349e00c5e827d9d186b00b82 (patch)
tree4ddc7ffa57e4ae79f99cbf4b0a15445b23345fe9
parentAdd pam_google_authenticator from Matsuu's overlay. But patch it to return be... (diff)
downloadpauldv-54aa42907b1a5a2a349e00c5e827d9d186b00b82.tar.gz
pauldv-54aa42907b1a5a2a349e00c5e827d9d186b00b82.tar.bz2
pauldv-54aa42907b1a5a2a349e00c5e827d9d186b00b82.zip
Add brother drivers
svn path=/trunk/overlay/; revision=129
-rw-r--r--net-print/brother-colorlaser2/Manifest2
-rw-r--r--net-print/brother-colorlaser2/brother-colorlaser2-1.0.3.ebuild107
-rw-r--r--net-print/hl4040cnlpr/Manifest2
-rw-r--r--net-print/hl4040cnlpr/hl4040cnlpr-1.0.3.ebuild64
4 files changed, 175 insertions, 0 deletions
diff --git a/net-print/brother-colorlaser2/Manifest b/net-print/brother-colorlaser2/Manifest
new file mode 100644
index 0000000..694ca59
--- /dev/null
+++ b/net-print/brother-colorlaser2/Manifest
@@ -0,0 +1,2 @@
+DIST brother-colorlaser2-gpl-src-1.0.3-1.tar.gz 232787 RMD160 e827b234bc80f5903384cd3ce90cf2e16a3549c1 SHA1 cdc7969fa14316a0626e5007a71e1ac98bdbbced SHA256 cbfd5044fd26a797d344e816aeaf65a81457164683b6db743d5fcdb7e9d56580
+EBUILD brother-colorlaser2-1.0.3.ebuild 2844 RMD160 74db5e6aea405cc90200fe29abaf200a229b5485 SHA1 43317a55d83f6dba0aa45104b0af25d0d99188f6 SHA256 58dc66d824105487cb4805ee045538388ade17e3a37b46e768550a5da980676c
diff --git a/net-print/brother-colorlaser2/brother-colorlaser2-1.0.3.ebuild b/net-print/brother-colorlaser2/brother-colorlaser2-1.0.3.ebuild
new file mode 100644
index 0000000..9e163a8
--- /dev/null
+++ b/net-print/brother-colorlaser2/brother-colorlaser2-1.0.3.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+DESCRIPTION="Cupswrapper driver for Brother HL4040CN"
+
+HOMEPAGE="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+SRC_URI="http://www.brother.com/pub/bsc/linux/dlf/${PN}-gpl-src-${PV}-1.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+# Build-time dependencies, such as
+# ssl? ( >=dev-libs/openssl-0.9.6b )
+# >=dev-lang/perl-5.6.1-r1
+# It is advisable to use the >= syntax show above, to reflect what you
+# had installed on your system when you tested the package. Then
+# other users hopefully won't be caught without the right version of
+# a dependency.
+DEPEND=""
+
+# Run-time dependencies. Must be defined to whatever this depends on to run.
+# The below is valid if the same run-time depends are required to compile.
+RDEPEND="net-print/cups"
+
+PDEPEND=">=net-print/hl4040cnlpr-1.0.3
+ app-text/a2ps
+ app-text/psutils"
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P}
+# If you don't need to change it, leave the S= line out of the ebuild
+# to keep it tidy.
+S="${WORKDIR}/${PN}-gpl-src-${PV}-1"
+
+#AVAILABLE_MODELS="dcp9040cn dcp9042cdn dcp9045cdn hl4040cdn hl4040cn hl4040cnj hl4050cdn hl4070cdw mfc9440cn mfc9450cdn mfc9640cw mfc9840cdw"
+AVAILABLE_MODELS="hl4040cn"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ for f in ${AVAILABLE_MODELS}
+ do
+ tar xfz ${f}cupswrapper-${PV}-1.tar.gz
+ done
+ echo ${AVAILABLE_MODELS}| ( read d
+ mv ${d}cupswrapper-${PV}-1/brcupsconfig . || die "cupswrapper not found" )
+ mkdir ${WORKDIR}/tmp
+}
+
+src_configure() {
+# Don't do anything
+ :
+}
+
+src_compile() {
+ #Compile the config app
+ gcc ${CFLAGS} -o brcupsconfig2 brcupsconfig/brcupsconfig.c || die "Compilation failed"
+
+
+ #Create the filters
+ for m in ${AVAILABLE_MODELS}
+ do
+ SETUP=${m}cupswrapper-${PV}-1/cupswrapper/cupswrapperSetup_${m}
+ ppd_file_name=/usr/share/cups/model/br${m}.ppd
+
+ SETUP2=brlpdwrapper${m}
+ SETUP3=brlpdwrapper${m}.tmp
+
+ echo "cat <<MYEOF >$SETUP2" > $SETUP3
+ grep -n ENDOFWFILTER $SETUP |cut -d ":" -f 1 | (
+ read begin
+ read end
+ let end=end-1
+ let begin=begin+1
+ head -n $end $SETUP | tail -n +$begin \
+ | sed -e "s,\${printer_model},$m,g" \
+ -e "s,/usr/local/Brother,/usr/lib/Brother," >>$SETUP3 \
+ || die "Creating filter failed"
+ ) || die "Creating filter failed"
+ echo "MYEOF" >>$SETUP3
+ . $SETUP3
+
+ chmod a+x ${SETUP2}
+
+ done
+}
+
+src_install() {
+ dobin brcupsconfig2 || die "Install failed"
+
+ for m in ${AVAILABLE_MODELS}
+ do
+ insinto /usr/share/cups/model/
+ doins ${m}cupswrapper-${PV}-1/PPD/br${m}.ppd || die "Install failed"
+
+ exeinto /usr/libexec/cups/filter/
+ doexe brlpdwrapper${m} || die "Install failed"
+ done
+}
diff --git a/net-print/hl4040cnlpr/Manifest b/net-print/hl4040cnlpr/Manifest
new file mode 100644
index 0000000..554d2bb
--- /dev/null
+++ b/net-print/hl4040cnlpr/Manifest
@@ -0,0 +1,2 @@
+DIST hl4040cnlpr-1.0.3-1.i386.rpm 341331 RMD160 9c42f3c6d8cbe517f4d7bf45452508a5b51f02e7 SHA1 e91e67e4b1691f2663c7513dc336d967a7f064ac SHA256 f39350eb1002e2c65e7302adaf627af99c644fd58b8a8daa70aaf28f9672d67a
+EBUILD hl4040cnlpr-1.0.3.ebuild 2124 RMD160 6b2c4ae63e3768a272fb3b6f4dec90b67457ec3e SHA1 fe224f2e3da16495a6038ca8d642d4927b70f3ee SHA256 1fe63ea2c6cdafdd07e2852f1808aa284ca0db93050437722cdee495fb826275
diff --git a/net-print/hl4040cnlpr/hl4040cnlpr-1.0.3.ebuild b/net-print/hl4040cnlpr/hl4040cnlpr-1.0.3.ebuild
new file mode 100644
index 0000000..6c152f0
--- /dev/null
+++ b/net-print/hl4040cnlpr/hl4040cnlpr-1.0.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit rpm
+
+DESCRIPTION="Cupswrapper driver for Brother HL4040CN"
+
+HOMEPAGE="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+SRC_URI="http://www.brother.com/pub/bsc/linux/dlf/${P}-1.i386.rpm"
+
+LICENSE="as-is"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+# Build-time dependencies, such as
+# ssl? ( >=dev-libs/openssl-0.9.6b )
+# >=dev-lang/perl-5.6.1-r1
+# It is advisable to use the >= syntax show above, to reflect what you
+# had installed on your system when you tested the package. Then
+# other users hopefully won't be caught without the right version of
+# a dependency.
+
+# Run-time dependencies. Must be defined to whatever this depends on to run.
+# The below is valid if the same run-time depends are required to compile.
+RDEPEND="net-print/cups"
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P}
+# If you don't need to change it, leave the S= line out of the ebuild
+# to keep it tidy.
+S="${WORKDIR}/${P}-1"
+
+#AVAILABLE_MODELS="dcp9040cn dcp9042cdn dcp9045cdn hl4040cdn hl4040cn hl4040cnj
+#hl4050cdn hl4070cdw mfc9440cn mfc9450cdn mfc9640cw mfc9840cdw"
+
+src_configure() {
+# Don't do anything
+ sed -i -b -e "s,/usr/local/\(Brother[^\x00]*\),/usr/lib/\1\x00\x00,g" \
+ usr/bin/brprintconf_hl4040cn ||die "Relocate resource dir"
+ sed -i -b -e "s,/usr/local/Brother,/usr/lib/Brother,g" usr/local/Brother/Printer/hl4040cn/inf/setupPrintcapij
+ sed -i -b -e "s,/usr/local/Brother,/usr/lib/Brother,g" usr/local/Brother/Printer/hl4040cn/lpd/filterhl4040cn
+}
+
+src_compile() {
+ #Compile the config app
+ :
+}
+
+src_install() {
+ dobin usr/bin/brprintconf_hl4040cn ||die "Binary not found"
+
+ insinto /usr/lib/Brother/Printer/hl4040cn
+ doins -r usr/local/Brother/Printer/hl4040cn/inf ||die "data not found"
+
+ exeinto /usr/lib/Brother/Printer/hl4040cn/lpd
+ doexe usr/local/Brother/Printer/hl4040cn/lpd/{brhl4040cnfilter,psconvertij2,filterhl4040cn} ||die "Executables not found"
+}