summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2014-05-15 12:22:40 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2014-05-15 12:22:40 +0000
commitfd9556a99fe4327d54172f4f52fb8d385214aff4 (patch)
tree3a1a3f12e8bb1d51c6ea23457e54bb7f55cd0790
parentNew inkscape snapshot (diff)
downloadpauldv-fd9556a99fe4327d54172f4f52fb8d385214aff4.tar.gz
pauldv-fd9556a99fe4327d54172f4f52fb8d385214aff4.tar.bz2
pauldv-fd9556a99fe4327d54172f4f52fb8d385214aff4.zip
New upstream version
svn path=/trunk/overlay/; revision=167
-rw-r--r--sys-auth/pam_google_authenticator/Manifest6
-rw-r--r--sys-auth/pam_google_authenticator/pam_google_authenticator-1.0.ebuild36
2 files changed, 39 insertions, 3 deletions
diff --git a/sys-auth/pam_google_authenticator/Manifest b/sys-auth/pam_google_authenticator/Manifest
index 15d8d79..3481e79 100644
--- a/sys-auth/pam_google_authenticator/Manifest
+++ b/sys-auth/pam_google_authenticator/Manifest
@@ -1,3 +1,3 @@
-AUX exit_codes.patch 585 RMD160 cc80a8b35e1dfe7d6b7f88c3b577dafddfd99d0d SHA1 1a375a77c8e40d01502f8efd4c9cb8b9152fc2d7 SHA256 61d990c48f77757c668dc12b6c3131001151210c1061d1a2664c1f2f49d5e756
-AUX pam_google_authenticator-9999-as-needed.patch 687 RMD160 50ab6fa5a99f5eaa6ecf7a644d65006e76eded55 SHA1 e71b2ea78db3b6d5d0e03595f3af90cbc9c020f1 SHA256 7c0967ad9102b916e4f260dc72fd9a9caa8b4464cd5fc8f1d082453ca5b163d4
-EBUILD pam_google_authenticator-9999.ebuild 911 RMD160 ce98bc94c42eb24022cae6e7246a1daccd34ee76 SHA1 bbc26986b7d0d8cb54842a9ddd7f71d654940125 SHA256 80fda768aa3ce438b18c677af7f0a344be9a4f232b68cbcbf6bd83bb8d465217
+AUX exit_codes.patch 585 SHA256 61d990c48f77757c668dc12b6c3131001151210c1061d1a2664c1f2f49d5e756 SHA512 03d1c8233281b693424d977391e0a1cf1a32a58a7cbd637431c53b7c5fe6201b9f5332ca3510211ece31bf30408ad0b86938ac3527dae3c233dadc6ee9c0cafa WHIRLPOOL a6827ed2f72001c787f38b67b4b16d9fff9150090f0f466e5d431125ccf15e2c292ba5c308a386ee10528d4a403180a9ec7944b147c8ae8d9339a580d602361c
+DIST libpam-google-authenticator-1.0-source.tar.bz2 32708 SHA256 80426045d13ce7a2bf56c692ccfb1751cef3c7484752ad40738facf729264d4b SHA512 92ec473b07e2e46f969cd0a1a6f5707892800418442ad7d046ebc1195bbd1654e396f53245056c7eee38decaeb1997102f9aa988b7da1d734dcd2b104402ef8c WHIRLPOOL fff94006035d0751ff690f81d827a33c5d304f86a48809fa889138bb29ae1f9c47315fb0c3548d29dae545cac63db9f35a9bb6e439f49cd4a6571241a43e4c6a
+EBUILD pam_google_authenticator-1.0.ebuild 819 SHA256 ec1fe9e8ee583207cff6e9afdec0efc5be811910f2f3dee4cf0128eebddf437d SHA512 2508c3fe4c9eccec6213b5638937c5df8565ce254006cbf6def1e1e7fd10c2d7602e9a0995f9125faa2def672b2f1e14a5c2501fcb29ac903f563dc0d6d61778 WHIRLPOOL 5a7bdbcf6c73a4943eec8617d4249f6bec06c81153ada74f702c266bd0e7d96d0310dfab463c644c9ea11fc318a6613159e8f8a7abb58bddfebcaf86ec97f499
diff --git a/sys-auth/pam_google_authenticator/pam_google_authenticator-1.0.ebuild b/sys-auth/pam_google_authenticator/pam_google_authenticator-1.0.ebuild
new file mode 100644
index 0000000..eb84552
--- /dev/null
+++ b/sys-auth/pam_google_authenticator/pam_google_authenticator-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+inherit eutils base pam toolchain-funcs
+
+DESCRIPTION="Example PAM module demonstrating two-factor authentication"
+HOMEPAGE="http://code.google.com/p/google-authenticator/"
+SRC_URI="https://google-authenticator.googlecode.com/files/libpam-google-authenticator-1.0-source.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test nomirror"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}
+ media-gfx/qrencode"
+#PATCHES="${FILESDIR}/exit_codes.patch"
+
+S="${WORKDIR}/lib${PN//_/-}-${PV}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dopammod pam_google_authenticator.so || die
+
+ dobin google-authenticator || die
+
+ dodoc README FILEFORMAT || die
+}