summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPanagiotis Christopoulos (pchrist) <pchrist@gentoo.org>2015-01-15 22:12:28 +0200
committerPanagiotis Christopoulos (pchrist) <pchrist@gentoo.org>2015-01-15 22:12:28 +0200
commita6b075ce67f7170143764c8720e554d0cc892a95 (patch)
treee83a4fe0fda6a1e273247a79b6e216925bf5f81a
parentContinuing the work on 3.2.5 (diff)
downloadpchrist-a6b075ce67f7170143764c8720e554d0cc892a95.tar.gz
pchrist-a6b075ce67f7170143764c8720e554d0cc892a95.tar.bz2
pchrist-a6b075ce67f7170143764c8720e554d0cc892a95.zip
adding freetalk ebuild (work in progress
Package-Manager: portage-2.2.15 Manifest-Sign-Key: 3AC579B91BC03656
-rw-r--r--net-im/freetalk/Manifest2
-rw-r--r--net-im/freetalk/freetalk-9999.ebuild36
-rw-r--r--net-im/freetalk/metadata.xml15
3 files changed, 53 insertions, 0 deletions
diff --git a/net-im/freetalk/Manifest b/net-im/freetalk/Manifest
new file mode 100644
index 0000000..fb464b0
--- /dev/null
+++ b/net-im/freetalk/Manifest
@@ -0,0 +1,2 @@
+EBUILD freetalk-9999.ebuild 813 SHA256 6e980bf1e8dc187f7327a29c7d49d10d8629ceb6feade597364a9171413238f1 SHA512 cf138337e29a3ba9953ef82d21bd72da7c2907cb20195e41b4b38a742a7c4cc060983a47589e26e9d935c58a50f2d5fbe0eb58ff6b41ff1cda02538f1b5424f7 WHIRLPOOL 636ee2e83609bfa77ed86ddf58af1d197c4ce57cfdf3d8978e06a161aa098227a50746b68164efaf542b874b4c580af3c52d70b100fcbecfe0c4ab23f2848170
+MISC metadata.xml 568 SHA256 55dad111061eba321674c817eef70546b87dae680887aad04511ca06493ef072 SHA512 c79e6f9964f143d5b9bc493ff2198d2c018988487c971118a0c1f11a732fe9cbe184e3bfe558b8469275e56673e5e6bd638204b503c05476ecc678bb92bb5baf WHIRLPOOL 5349313c0660528dd32a490752d6b5ee42f56b8dfd5647e5481f14f42d7eb6c56618a0fc93f1f23f0ea204f0696c4edf89f46124a8d1b45f6ad0a93efca7e8d0
diff --git a/net-im/freetalk/freetalk-9999.ebuild b/net-im/freetalk/freetalk-9999.ebuild
new file mode 100644
index 0000000..995b730
--- /dev/null
+++ b/net-im/freetalk/freetalk-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils git-r3
+
+DESCRIPTION="Freetalk is a console based chat client for Google Hangout and other XMPP servers"
+HOMEPAGE="http://gnufreetalk.github.io/"
+EGIT_REPO_URI="https://github.com/GNUFreetalk/freetalk.git"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+DEPEND=">=dev-scheme/guile-2.0.0
+ net-libs/loudmouth"
+RDEPEND="${DEPEND}"
+IUSE="examples"
+
+src_prepare() {
+ ./autogen.sh || die "Autogen script failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc NEWS README TODO ChangeLog
+ local baddoc="${D}/usr/share/doc/${PN}"
+ if use examples; then
+ for f in $(find "${baddoc}/examples" -type f);
+ do
+ docinto examples;
+ dodoc "${f}"
+ done
+ fi
+ rm -Rv "${baddoc}"
+}
diff --git a/net-im/freetalk/metadata.xml b/net-im/freetalk/metadata.xml
new file mode 100644
index 0000000..e7f2dbf
--- /dev/null
+++ b/net-im/freetalk/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>scheme</herd>
+<maintainer>
+ <email>pchrist@gentoo.org</email>
+ <name>Panagiotis Christopoulos</name>
+</maintainer>
+<longdescription>
+Freetalk is a console based chat client for Google Hangout and other XMPP servers.
+It has context sensitive auto-completion for buddy names, commands, and even ordinary
+English words. Similar to GNU Emacs, You can customize and extend Freetalk with
+Scheme language.
+</longdescription>
+</pkgmetadata>