summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPanagiotis Christopoulos (pchrist) <pchrist@gentoo.org>2013-03-03 13:56:27 +0200
committerPanagiotis Christopoulos (pchrist) <pchrist@gentoo.org>2013-03-03 13:56:27 +0200
commit973594a96001f08ce8e420de8d8362b89df9809f (patch)
tree04881ef0dc1cf9fcd70f8fd2442c966aed07e6f0 /sci-geosciences/geographiclib/geographiclib-1.11-r1.ebuild
parentPorting geographiclib to gentoo (diff)
downloadpchrist-973594a96001f08ce8e420de8d8362b89df9809f.tar.gz
pchrist-973594a96001f08ce8e420de8d8362b89df9809f.tar.bz2
pchrist-973594a96001f08ce8e420de8d8362b89df9809f.zip
test for signed manifests
Package-Manager: portage-2.1.11.52 Manifest-Sign-Key: 3AC579B91BC03656
Diffstat (limited to 'sci-geosciences/geographiclib/geographiclib-1.11-r1.ebuild')
-rw-r--r--sci-geosciences/geographiclib/geographiclib-1.11-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-geosciences/geographiclib/geographiclib-1.11-r1.ebuild b/sci-geosciences/geographiclib/geographiclib-1.11-r1.ebuild
new file mode 100644
index 0000000..5bf93b5
--- /dev/null
+++ b/sci-geosciences/geographiclib/geographiclib-1.11-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-2.0.4.ebuild,v 1.1 2011/05/28 15:40:26 pchrist Exp $
+
+EAPI="3"
+
+MY_P="GeographicLib-${PV}"
+DESCRIPTION="A small C++ library for geodetic calculations"
+HOMEPAGE="http://geographiclib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+#src_configure() {
+# econf
+#}
+#
+
+# test for signed manifest, pchrist 03Mar13
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS 00README.txt INSTALL || die "dodoc failed"
+}