summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-06-19 08:41:06 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-06-19 08:41:06 -0700
commitced651e390b3ffba81059cb67a4ba946bc7a6a0d (patch)
tree176c9e63c8edc0f8781c8ec1321d3f539d3b05f5 /app-admin/euca2ools/euca2ools-2.1.3.ebuild
parentupdate local stuff in my repo. (diff)
parentAdd my local stuff again. (diff)
downloadrobbat2-ced651e390b3ffba81059cb67a4ba946bc7a6a0d.tar.gz
robbat2-ced651e390b3ffba81059cb67a4ba946bc7a6a0d.tar.bz2
robbat2-ced651e390b3ffba81059cb67a4ba946bc7a6a0d.zip
Merge remote-tracking branch 'bohr/master'
With conflict fixes Conflicts: metadata/layout.conf profiles/repo_name x11-plugins/pidgin-extended_blist_sort/Manifest x11-plugins/pidgin-toobars/Manifest
Diffstat (limited to 'app-admin/euca2ools/euca2ools-2.1.3.ebuild')
-rw-r--r--app-admin/euca2ools/euca2ools-2.1.3.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/app-admin/euca2ools/euca2ools-2.1.3.ebuild b/app-admin/euca2ools/euca2ools-2.1.3.ebuild
new file mode 100644
index 0000000..15116ff
--- /dev/null
+++ b/app-admin/euca2ools/euca2ools-2.1.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI="4"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Command-line tools for interacting with Amazon EC2 and S3 API-compatible Web services using the REST/Query API"
+HOMEPAGE="http://open.eucalyptus.com"
+SRC_URI="https://github.com/eucalyptus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc64"
+IUSE=""
+DEPEND=">=dev-python/boto-1.9d
+ >=dev-lang/python-2.5
+ >=dev-python/m2crypto-0.19.1"
+
+RDEPEND="${DEPEND}"
+
+DOCS="${S}/COPYING
+ ${S}/CHANGELOG
+ ${S}/README
+ ${S}/INSTALL"
+
+src_compile() {
+ distutils_src_compile
+ #emake build || die "emake failed"
+}
+
+src_install() {
+ distutils_src_install
+ cd "${S}/bin"
+ for tool in *; do
+ newbin ${tool} ${tool}
+ done
+
+ # Install the manpages
+ if [[ -d ${S}/man ]]; then
+ doman ${S}/man/* || die "doman"
+ fi
+}
+
+pkg_postinst(){
+ einfo ""
+ einfo " Euca2ools use cryptographic credentials for authentication. Two
+ types of credentials are issued by EC2- and S3-compatible services: x509
+ certificates and keys. While some commands only require the latter, it is
+ best to always specify both types of credentials."
+
+ einfo ""
+ einfo " Furthermore, unless the front end Web services reside on
+ 'localhost', the URLs of the EC2- and S3-compatible service endpoints must
+ also be specified."
+ einfo ""
+ einfo "If you are running Euca2ools against Eucalyptus, sourcing the
+ \"eucarc\" file that is included as part of the credentials zip-file that
+ you downloaded from the Eucalyptus Web interface should be enough to set up
+ all of the above variables correctly."
+ einfo ""
+ einfo "For more information please refer to the:"
+ einfo " * --help option of the individual commands,"
+ einfo " * check the man pages for each command,"
+ einfo " * consult the local documentation at /usr/share/doc/$P,"
+ einfo " *consult http://open.eucalyptus.com/wiki/Documentation."
+ einfo ""
+}