summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/librelp/librelp-1.0.0.ebuild')
-rw-r--r--dev-libs/librelp/librelp-1.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/librelp/librelp-1.0.0.ebuild b/dev-libs/librelp/librelp-1.0.0.ebuild
new file mode 100644
index 0000000..127a48a
--- /dev/null
+++ b/dev-libs/librelp/librelp-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+DESCRIPTION="An easy to use library for the RELP protocol."
+HOMEPAGE="http://www.librelp.com/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+LICENSE="GPL-3 doc? ( FDL-1.3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~sparc ~x86"
+IUSE="debug doc"
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ econf \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog
+ use doc && dohtml doc/relp.html
+}