summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-svn/django-svn-0.1.ebuild')
-rw-r--r--dev-python/django-svn/django-svn-0.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-svn/django-svn-0.1.ebuild b/dev-python/django-svn/django-svn-0.1.ebuild
new file mode 100644
index 0000000..96d9375
--- /dev/null
+++ b/dev-python/django-svn/django-svn-0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-0.95.ebuild,v 1.2 2006/08/13 15:40:12 lucass Exp $
+
+inherit subversion distutils
+
+MY_P="${PN/d/D}-${PV}"
+DESCRIPTION="high-level python web framework"
+HOMEPAGE="http://www.djangoproject.com/"
+
+ESVN_REPO_URI="http://code.djangoproject.com/svn/django/trunk"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="sqlite postgres mysql"
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/setuptools-0.6_rc1"
+
+RDEPEND=">=dev-lang/python-2.3
+ sqlite? ( >=dev-python/pysqlite-2.0.3 )
+ postgres? ( <dev-python/psycopg-1.99 )
+ mysql? ( dev-python/mysql-python )
+ dev-python/imaging"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="docs/* AUTHORS INSTALL LICENSE"
+
+src_install()
+{
+ distutils_python_version
+
+ site_pkgs="/usr/$(get_libdir)/python${PYVER}/site-packages/"
+ export PYTHONPATH="${PYTHONPATH}:${D}/${site_pkgs}"
+ dodir ${site_pkgs}
+
+ find ${S} -name '.svn' | xargs rm -r
+
+ distutils_src_install
+
+ cp -r examples "${D}/usr/share/doc/${PF}"
+}