aboutsummaryrefslogtreecommitdiff
path: root/slave
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek.chauhan@gmail.com>2008-09-18 00:11:33 +0530
committerNirbheek Chauhan <nirbheek.chauhan@gmail.com>2008-09-18 00:11:33 +0530
commit76686fd50c078bfd267dca12d3f5303eccd97495 (patch)
tree9e60f65f31783157aec4ea6eaa0be82a05df0c00 /slave
parentSlave is licensed under GPL-3 (diff)
downloadautotua-76686fd50c078bfd267dca12d3f5303eccd97495.tar.gz
autotua-76686fd50c078bfd267dca12d3f5303eccd97495.tar.bz2
autotua-76686fd50c078bfd267dca12d3f5303eccd97495.zip
Errr. Use hard links for README-AUTOTUA.
Diffstat (limited to 'slave')
-rw-r--r--[l---------]slave/README-AUTOTUA52
1 files changed, 51 insertions, 1 deletions
diff --git a/slave/README-AUTOTUA b/slave/README-AUTOTUA
index 59a23c4..d32c41f 120000..100644
--- a/slave/README-AUTOTUA
+++ b/slave/README-AUTOTUA
@@ -1 +1,51 @@
-../README \ No newline at end of file
+---- DESCRIPTION ----
+- This code is currently in alpha-mode. Doing anything useful with the code
+ requires a certain level of knowledge of the underlying code. However, this
+ file aims to allow a person unacquainted with the project to test it for
+ purposes of arch testing etc without understanding the purpose of the project
+ [see ./PURPOSE] ;)
+
+---- STRUCTURE ----
+The project consists of two parts; a master server and a slave which runs jobs.
+The master-server will be put up on a centralized server and will manage jobs by
+distributing them to slaves.
+
+The master server is written in django and the slave in python. Currently, the
+project has only been tested on Linux, but it *should* work on UNIX-like systems
+as well.
+
+The deps of each component are as follows:
+- Master:
+ * Django-1.0 with sqlite3 support
+- Slave:
+ * Python 2.5 with inbuilt sqlite support
+
+---- SETUP ----
+The master has a runtime dependency on the modules in the slave, and the slave
+itself requires the master to do any real work. If you wish, you can install the
+slave using the standard `python setup.py`. However, that is not required for
+testing.
+
+The master can be setup by executing `python setup-master.py` and following the
+instructions. However, you will need to point the PYTHONPATH env variable to the
+"autotua/slave/" directory while running the setup if you chose not to install
+the slave modules. The same will have to be done while executing manage.py after
+setup.
+
+---- CONFIG ----
+If you did not use the defaults, you might want to edit autotua/slave/config.py (or
+/etc/autotua/slave.cfg if you installed the slave modules) and point it to the
+URL where you setup the master.
+
+
+---- TESTING ----
+The master-server and the slave are both tested by running the tests in the
+slave. The whole system can be tested in one go by executing
+`su -c 'PYTHONPATH=<abs path>/autotua/slave python autotua/slave/autotua/__init__.py'`
+
+Yes. The slave needs to be run as root :p
+This is because all the work done by a jobuild is done inside a disposable chroot
+
+---- BUGS ----
+If you find something wrong, feel free to file a bug report at
+http://soc.gentooexperimental.org/projects/autotua/issues