aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Thibodeau <kyron@neuralbs.com>2008-08-18 01:24:04 -0400
committerEric Thibodeau <kyron@neuralbs.com>2008-08-18 01:24:04 -0400
commit11f730f49ef407d5c370f45fc1cea4d9f59d76ea (patch)
treeb0fd78fb24da3fa4b53d37fe1a3688514596af45 /catalyst
parentAdded support for CPUSET (diff)
downloadclustering-livecd-11f730f49ef407d5c370f45fc1cea4d9f59d76ea.tar.gz
clustering-livecd-11f730f49ef407d5c370f45fc1cea4d9f59d76ea.tar.bz2
clustering-livecd-11f730f49ef407d5c370f45fc1cea4d9f59d76ea.zip
Multiple addition and cleanups
- added passwordless SSH for root to nodes - added some FAQs and documentation - quick update of the HOWTOs - switch to snapshot 20080816 - added torque (PBS) and underlying support modules - added a few config variables to scripts to ease future changes - created openrc-0.2.5-r1 to ease the NFSROOT howto procedure + (don't have to unpack and repack the snapshot for running ebuild * digest) * corrected invalide use of non existant functions.sh in nfsroot_setup.sh beowulf-head-0.1.ebuild: * Added the modules infrastructure to be called by dnsmasq's script callback interface * provided examples are for torque and c3. -- C3's configuration file is valid but doesn't seem to work (might be a python issue) -- torque is _still_ work in progress: + some of the setup seems to be incomplete (in the ebuild) + the profile switch was to get a better chance at a working installation (2.3.3) - Science overlay was added to pull in the modularized version of openmpi Since USE=pbs in the specs, openmpi requires Torque but Torque also require kernel (stage2). Torque is currently being built twise, once minimal for openmpi, then with kernel features in the stage2. Commenting out pbs and torque in stage2 reverts the build to a simple cluster without the whole PBS infrastructure...but it works ;)
Diffstat (limited to 'catalyst')
-rwxr-xr-xcatalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup93
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/livecd-stage1-minimal.spec10
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec10
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/livecd-stage2-minimal.spec14
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/livecd-stage2.spec15
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/stage1.spec2
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/stage2-desktop.spec2
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/stage3-desktop.spec2
-rw-r--r--catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh31
-rw-r--r--catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec12
-rw-r--r--catalyst/nfsroot/2008.0/specs/amd64/stage1.spec2
-rw-r--r--catalyst/nfsroot/2008.0/specs/amd64/stage2.spec2
-rw-r--r--catalyst/nfsroot/2008.0/specs/amd64/stage3.spec2
13 files changed, 139 insertions, 58 deletions
diff --git a/catalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup b/catalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup
index 9675ad8..8d95ca8 100755
--- a/catalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup
+++ b/catalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup
@@ -4,9 +4,9 @@
# This script is written so parts can be reused for liveCD mounting...eventually ;)
. /mnt/livecd/sbin/functions.sh
-CDROOT=/mnt/livecd/
-MKDIR=${CDROOT}/bin/mkdir
-MODPROBE=${CDROOT}/sbin/modprobe
+CONFDIR="/etc/gentoo"
+CLUSTER_CONF="$CONFDIR/cluster.conf"
+LDAP_CONF="$CONFDIR/ldap_auth.conf"
conf_error() {
eerror "CONFIG_OK is not set to 'yes' in $1"
@@ -19,6 +19,10 @@ conf_error() {
}
aufs_mount() {
+ CDROOT=/mnt/livecd/
+ MKDIR=${CDROOT}/bin/mkdir
+ MODPROBE=${CDROOT}/sbin/modprobe
+
$MODPROBE aufs || eerror "Got $? while probing for aufs module!"
# Looping this simply because it should replace the current tmpfs mounting of the liveCD :P
for I in tftproot
@@ -43,19 +47,56 @@ do_conf() {
}
# This could have been inlined into do_conf but we would rather check configs _before_
-# we do anything...we could be a little mode selective than /etc/gentoo/* though
+# we do anything...we could be a little mode selective than $CONFDIR/* though
check_conf() {
einfo "Checking config files.."
- for I in /etc/gentoo/*
+ for I in $CONFDIR/*.conf
do
. $I
[[ $CONFIG_OK == "yes" ]] || conf_error $I
done
}
+# This function has to be called after the $CLUSTER_CONF file has been sourced
+# Required external vars:
+# CLUSTER_CONF:NFSROOT
+config_ssh(){
+ KEY_NAME="node_dsa"
+ NETADDR="$(sipcalc ${CLUSTER_ETH} | egrep 'Network address' | cut -d- -f2)"
+ # The following is needed because $HOME is set to / on the livecd console for some reason
+ HDIR="/root"
+
+ pushd $PWD
+
+ einfo "Setting up passwordless ssh for root between master and the nodes"
+ mkdir -p $HDIR/.ssh/ $NFSROOT/root/.ssh/
+ cd $HDIR/.ssh/
+ ssh-keygen -t dsa -b 1024 -f $KEY_NAME -N ""
+ cat $KEY_NAME.pub >> $NFSROOT/root/.ssh/authorized_keys
+ cat >> $HDIR/.ssh/config <<-EOF
+ # Auto-generated by $0 to ease the use of passwordless logins for all users
+ # Although this approach is questionnable, it's also one of the only way
+ # to automate some of the master-node configuration/discovery process
+ # until an Avahi-style approach is implemented.
+ Host *.gentoo.local ${NETADDR%.[09]*}.* node*
+ IdentityFile $HDIR/.ssh/$KEY_NAME
+ StrictHostKeyChecking no
+ UserKnownHostsFile /dev/null
+ CheckHostIP no
+ Compression no
+ EOF
+
+ echo "# we don't use IPV6, the following setting removes undue delays that would be added" >> /etc/ssh/ssh_config
+ echo "AddressFamily inet" >> /etc/ssh/ssh_config
+
+ chmod 600 $HDIR/.ssh/* $NFSROOT/root/.ssh/*
+ chmod 700 $HDIR/.ssh $NFSROOT/root/.ssh
+ popd
+}
+
####### Main #########
-# speed up the dev cycle by automating some tasks:
+# Speed up the dev cycle by automating some tasks:
if [[ "$1" == "--test" ]]; then
ewarn
ewarn "Yeah...you know what you're doing right?"
@@ -70,17 +111,14 @@ if [[ "$1" == "--test" ]]; then
/etc/init.d/net.eth1 restart
echo root:test | chpasswd
/etc/init.d/sshd start
- sed -i -e's:CONFIG_OK="no":CONFIG_OK="yes":' /etc/gentoo/*
+ sed -i -e's:CONFIG_OK="no":CONFIG_OK="yes":' $CONFDIR/*.conf
fi
check_conf
-aufs_mount
-# After this, all paths should be ok (no need to use relative paths with ${CDROOT}
-
-do_conf /etc/gentoo/ldap_auth.conf "emerge --config =net-nds/ldap-auth-0.1"
-/etc/init.d/slapd start || ewarn "Slapd did not start! See above for error messages...continuing"
+grep -q /mnt/aufs/tftproot /proc/mounts
+[ $? ] && aufs_mount
-. /etc/gentoo/cluster.conf
+. $CLUSTER_CONF
einfo "Making sure $CLUSTER_ETH is configured correctly.."
if [[ "$CLUSTER_ETH" =~ eth.* && $1 != "--test" ]]; then
echo "The cluster's NIC is set as $CLUSTER_ETH with the following config:"
@@ -99,20 +137,37 @@ if [[ "$CLUSTER_ETH" =~ eth.* && $1 != "--test" ]]; then
fi
[[ $ANS == "n" ]] && einfo "You know what you're doing..."
else
- einfo "CLUSTER_ETH is not set to an eth? device: $CLUSTER_ETH"
+ [[ $1 != "--test" ]] && einfo "CLUSTER_ETH is not set to an eth? device: $CLUSTER_ETH"
einfo "Hope you know what you're doing."
fi
-do_conf /etc/gentoo/cluster.conf "emerge --config =sys-cluster/beowulf-head-0.1"
+do_conf $CLUSTER_CONF "emerge --config =sys-cluster/beowulf-head-0.1"
+config_ssh
-# we need to set master and master.$DOMAINNAME to a real IP address for everything to work:
+# we need to set master and master.$DOMAINNAME to a real IP address (not 127.0.0.1) for everything to work:
echo "$(LC_ALL=C ifconfig "eth1" | sed -n -e 's#.*\(inet addr:\|inet \)\([^ ]*\).*#\2#p') $(hostname).$LOCALDOMAINNAME $(hostname)" >> /etc/hosts
-einfo "Setting up auth on the $NFSROOT"
-USE=-authmaster ROOT="$NFSROOT" emerge --config =net-nds/ldap-auth-0.1
-
einfo "We need to refresh resolv.conf and dnsmasq."
einfo "Restarting both $PUBETH and dnsmasq..."
/etc/init.d/net.$PUBETH restart
/etc/init.d/dnsmasq restart
+# This also has to be done with the $CLUSTER_CONF information sourced
+
+# Setting up Torque
+# Checking for pbs USE flag
+portageq envvar USE | grep -q pbs
+
+if [[ $? == 0 ]]; then
+ einfo "Setting up torque on $HOSTNAME and in $NFSROOT"
+ emerge --config =sys-cluster/torque-2.3.3
+ USE=-server ROOT=$NFSROOT emerge --config =sys-cluster/torque-2.3.3
+fi
+
+# we want to do this last, otherwise some name resolution problems might haunt you
+do_conf $LDAP_CONF "emerge --config =net-nds/ldap-auth-0.1"
+/etc/init.d/slapd start || ewarn "Slapd did not start! See above for error messages...continuing"
+einfo "Setting up auth on the $NFSROOT"
+USE=-authmaster ROOT="$NFSROOT" emerge --config =net-nds/ldap-auth-0.1
+
+[[ $? == 0 ]] && einfo "Once you have nodes going, restart Torque (pbs_server)"
diff --git a/catalyst/livecd/2008.0/specs/amd64/livecd-stage1-minimal.spec b/catalyst/livecd/2008.0/specs/amd64/livecd-stage1-minimal.spec
index f55e05f..8b97eeb 100644
--- a/catalyst/livecd/2008.0/specs/amd64/livecd-stage1-minimal.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/livecd-stage1-minimal.spec
@@ -3,13 +3,13 @@ version_stamp: minimal-installer-2008.0
target: livecd-stage1
rel_type: default
profile: default/linux/amd64/2008.0/desktop
-snapshot: 20080806
+snapshot: 20080816
source_subpath: default/stage3-amd64-desktop-2008.0
# Kyron:
portage_confdir: /var/git/clustering-livecd/profiles/hpc-clustering/
pkgcache_path: /var/tmp/catalyst/packages/amd64_minimal
-portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools
+portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools /usr/local/portage/layman/sunrise /usr/local/portage/layman/science
### end
# Kyron: added
@@ -19,6 +19,7 @@ portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools
# -minimal (for openldap to be used as auth server)
# -fam to fix circular dependancy preventing the build
# nfsexport, nfs, hinotify are for aufs (in stage2)
+# pbs, server, cpusets for torque
livecd/use:
-*
deprecated
@@ -53,6 +54,9 @@ livecd/use:
hinotify
nfs
nonfs4
+ beep
+ resolvconf
+ pbs
livecd/packages:
app-accessibility/brltty
@@ -168,3 +172,5 @@ livecd/packages:
app-admin/eselect-lapack
net-misc/wol
sys-apps/dstat
+ dev-util/strace
+ dev-util/ltrace
diff --git a/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec b/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec
index 3f4a1c9..17ab415 100644
--- a/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec
@@ -3,13 +3,13 @@ version_stamp: installer-2008.0
target: livecd-stage1
rel_type: default
profile: default/linux/amd64/2008.0/desktop
-snapshot: 20080806
+snapshot: 20080816
source_subpath: default/stage3-amd64-desktop-2008.0
# Kyron:
portage_confdir: /var/git/clustering-livecd/profiles/hpc-clustering/
pkgcache_path: /var/tmp/catalyst/packages/amd64_desktop
-portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools
+portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools /usr/local/portage/layman/sunrise /usr/local/portage/layman/science
### end
# Kyron: added
@@ -19,6 +19,7 @@ portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools
# -minimal (for openldap to be used as auth server)
# -fam to fix circular dependancy preventing the build
# nfsexport, nfs, hinotify are for aufs (in stage2)
+# tk, server, cpusets for torque
livecd/use:
branding
livecd
@@ -34,6 +35,9 @@ livecd/use:
hinotify
nfs
nonfs4
+ beep
+ resolvconf
+ tk
livecd/packages:
app-accessibility/brltty
@@ -215,4 +219,6 @@ livecd/packages:
dev-util/strace
sys-process/lsof
sys-apps/dstat
+ dev-util/strace
+ dev-util/ltrace
diff --git a/catalyst/livecd/2008.0/specs/amd64/livecd-stage2-minimal.spec b/catalyst/livecd/2008.0/specs/amd64/livecd-stage2-minimal.spec
index 604fe02..0f811a1 100644
--- a/catalyst/livecd/2008.0/specs/amd64/livecd-stage2-minimal.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/livecd-stage2-minimal.spec
@@ -3,13 +3,13 @@ version_stamp: minimal-installer-2008.0
target: livecd-stage2
rel_type: default
profile: default/linux/amd64/2008.0/desktop
-snapshot: 20080806
+snapshot: 20080816
source_subpath: default/livecd-stage1-amd64-minimal-installer-2008.0
# Kyron:
portage_confdir: /var/git/clustering-livecd/profiles/hpc-clustering/
pkgcache_path: /var/tmp/catalyst/packages/amd64_minimal
-portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools /usr/local/portage/layman/sunrise
+portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools /usr/local/portage/layman/sunrise /usr/local/portage/layman/science
livecd/iso: /tmp/livecd-amd64-minimal-2008.0.iso
livecd/volid: x86_64 Gentoo Clustering LiveCD
@@ -33,8 +33,7 @@ livecd/root_overlay: /var/git/clustering-livecd/catalyst/livecd/2008.0/overlay/
boot/kernel: gentoo
boot/kernel/gentoo/sources: gentoo-sources
-boot/kernel/gentoo/config: /var/git/clustering-livecd/catalyst/livecd/2008.0/kconfig/livecd-2.6.24.config
-#boot/kernel/gentoo/config: /var/svnroot/releng/trunk/releases/2008.0/kconfig/amd64/installcd-2.6.24.config
+boot/kernel/gentoo/config: /var/git/clustering-livecd/catalyst/livecd/2008.0/kconfig/livecd-2.6.25.config
boot/kernel/gentoo/use:
-*
atm
@@ -63,6 +62,12 @@ boot/kernel/gentoo/use:
nfs
hinotify
nonfs4
+ beep
+ resolvconf
+ pbs
+ server
+# Kernel support is built in but this feature is quite experimental in Torque
+# cpusets
boot/kernel/gentoo/packages:
net-dialup/globespan-adsl
@@ -72,6 +77,7 @@ boot/kernel/gentoo/packages:
sys-fs/ntfs3g
## kyron: let the fun begin, we need a unionfs-ish FS to be able to configure the clustering stuff on the liveCD
sys-fs/aufs
+ sys-cluster/torque
livecd/rcadd:
ntpd|default
diff --git a/catalyst/livecd/2008.0/specs/amd64/livecd-stage2.spec b/catalyst/livecd/2008.0/specs/amd64/livecd-stage2.spec
index 0bd5f95..2e0097f 100644
--- a/catalyst/livecd/2008.0/specs/amd64/livecd-stage2.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/livecd-stage2.spec
@@ -3,13 +3,13 @@ version_stamp: 2008.0
target: livecd-stage2
rel_type: default
profile: default/linux/amd64/2008.0/desktop
-snapshot: 20080806
+snapshot: 20080816
source_subpath: default/livecd-stage1-amd64-installer-2008.0
# Kyron:
portage_confdir: /var/git/clustering-livecd/profiles/hpc-clustering/
pkgcache_path: /var/tmp/catalyst/packages/amd64_desktop
-portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools /usr/local/portage/layman/sunrise
+portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools /usr/local/portage/layman/sunrise /usr/local/portage/layman/science
livecd/iso: /tmp/livecd-amd64-installer-2008.0.iso
livecd/volid: x86_64 Gentoo Clustering LiveCD
@@ -33,7 +33,7 @@ livecd/root_overlay: /var/git/clustering-livecd/catalyst/livecd/2008.0/overlay/
boot/kernel: gentoo
boot/kernel/gentoo/sources: gentoo-sources
-boot/kernel/gentoo/config: /var/git/clustering-livecd/catalyst/livecd/2008.0/kconfig/livecd-2.6.24.config
+boot/kernel/gentoo/config: /var/git/clustering-livecd/catalyst/livecd/2008.0/kconfig/livecd-2.6.25.config
boot/kernel/gentoo/use:
atm
fbcondecor
@@ -45,6 +45,13 @@ boot/kernel/gentoo/use:
nfs
hinotify
nonfs4
+ beep
+ resolvconf
+ pbs
+ tk
+ server
+# Kernel support is built in but this feature is quite experimental in Torque
+# cpusets
boot/kernel/gentoo/packages:
media-libs/alsa-oss
@@ -56,7 +63,7 @@ boot/kernel/gentoo/packages:
sys-fs/ntfs3g
## kyron: let the fun begin, we need a unionfs-ish FS to be able to configure the clustering stuff on the liveCD
sys-fs/aufs
-# sys-block/nbd
+ sys-cluster/torque
livecd/empty:
/var/tmp
diff --git a/catalyst/livecd/2008.0/specs/amd64/stage1.spec b/catalyst/livecd/2008.0/specs/amd64/stage1.spec
index a5c35e2..a182d44 100644
--- a/catalyst/livecd/2008.0/specs/amd64/stage1.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/stage1.spec
@@ -3,7 +3,7 @@ target: stage1
version_stamp: 2008.0
rel_type: default
profile: default/linux/amd64/2008.0
-snapshot: 20080806
+snapshot: 20080816
source_subpath: drobbins/stage3-amd64-2008.06.27
# Kyron:
diff --git a/catalyst/livecd/2008.0/specs/amd64/stage2-desktop.spec b/catalyst/livecd/2008.0/specs/amd64/stage2-desktop.spec
index 168beaa..13a8e6e 100644
--- a/catalyst/livecd/2008.0/specs/amd64/stage2-desktop.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/stage2-desktop.spec
@@ -3,7 +3,7 @@ target: stage2
version_stamp: desktop-2008.0
rel_type: default
profile: default/linux/amd64/2008.0/desktop
-snapshot: 20080806
+snapshot: 20080816
source_subpath: default/stage1-amd64-2008.0
# Kyron:
diff --git a/catalyst/livecd/2008.0/specs/amd64/stage3-desktop.spec b/catalyst/livecd/2008.0/specs/amd64/stage3-desktop.spec
index 5a37872..b424eff 100644
--- a/catalyst/livecd/2008.0/specs/amd64/stage3-desktop.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/stage3-desktop.spec
@@ -3,7 +3,7 @@ target: stage3
version_stamp: desktop-2008.0
rel_type: default
profile: default/linux/amd64/2008.0/desktop
-snapshot: 20080806
+snapshot: 20080816
source_subpath: default/stage2-amd64-desktop-2008.0
# Kyron:
diff --git a/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh b/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh
index 569e721..4f9b7c9 100644
--- a/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh
+++ b/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh
@@ -1,18 +1,15 @@
#!/bin/bash
-
# (C) Eric Thibodeau GPL v2
-. /sbin/functions.sh
-
-eeinfo(){
- einfo "====================================="
- einfo "$*"
- einfo "====================================="
+eecho(){
+ echo "====================================="
+ echo "$*"
+ echo "====================================="
}
kernel_links()
{
- eeinfo "Correcting kernel and initramfs links"
+ eecho "Correcting kernel and initramfs links"
cd /boot
ln -s kernel-* vmlinuz
ln -s initramfs-* initramfs
@@ -21,7 +18,7 @@ kernel_links()
unionfs_prep()
{
- eeinfo "=adding unionfs required dirs========"
+ eecho "=adding unionfs required dirs========"
# for I in etc var tmp
# do
mkdir -p /mnt/rw_mounts/
@@ -54,7 +51,7 @@ change_opt() {
}
openrc_diskless_setup() {
- eeinfo "=Setting up default RC configs======="
+ eecho "=Setting up default RC configs======="
# /etc/rc.conf
for I in 'rc_parallel="yes"' 'rc_depend_strict="NO"' 'rc_tty_number=2'
@@ -75,39 +72,39 @@ openrc_diskless_setup() {
# We don't do this anymore since it puts files into /lib64/rc/init.d/
# and that causes error messages on reboot:
- #einfo "Pre-generating dependencies..."
+ #echo "Pre-generating dependencies..."
#/lib/rc/bin/rc-depend -u
# Instead, we actually clean out that folder:
rm -Rf /lib64/rc/init.d/*
# The following is only useful if some freak grabs the livecd and is in a TZ
# making the /etc files dated in the future (my system is UTC-5
- einfo "Moving dates to the past so the Cache isn't always regenerated"
+ echo "Moving dates to the past so the Cache isn't always regenerated"
find /etc/ -exec touch --date=yesterday {} \;
}
setup_services() {
# Pre-generating sshd keys can be the source of philosophical debates:
- eeinfo "=Pre-generating sshd keys============"
+ eecho "=Pre-generating sshd keys============"
. /etc/init.d/sshd
gen_keys
# ln -s /etc/runlevels/default /etc/runlevels/unionfs
}
dash_is_sh() {
- eeinfo "=Replacing sh with dash=============="
+ eecho "=Replacing sh with dash=============="
rm /bin/sh
ln -s /bin/dash /bin/sh
}
clear_resolv.conf(){
# we don't want the buildhost's resolv.conf to lie around and confuse things
- eeinfo "=Clearing our resolv.conf============"
+ eecho "=Clearing our resolv.conf============"
echo "" > /etc/resolv.conf
}
setup_ntp-client(){
- eeinfo "=Configuring ntp-client=============="
+ eecho "=Configuring ntp-client=============="
sed -ie 's:NTPCLIENT_OPTS=.*:NTPCLIENT_OPTS="-s -b -u master.gentoo.local":' /etc/conf.d/ntp-client
}
@@ -120,7 +117,7 @@ openrc_diskless_setup
setup_services
# TEMPORARY for testing:
-eeinfo "=Changing root password=============="
+eecho "=Changing root password=============="
echo root:test | chpasswd
exit 0
diff --git a/catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec b/catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec
index 9998844..7567b8d 100644
--- a/catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec
+++ b/catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec
@@ -12,7 +12,7 @@ subarch: amd64
# example:
# version_stamp: 2006.1
#version_stamp: nfsroot-20080629
-version_stamp: nfsroot-20080806
+version_stamp: nfsroot-20080816
# The target specifies what target we want catalyst to do. For building a CD,
# we start with stage4 as our target.
@@ -34,7 +34,7 @@ profile: default/linux/amd64/2008.0/
# This specifies which snapshot to use for building this target.
# example:
-snapshot: 20080806
+snapshot: 20080816
# This specifies where the seed stage comes from for this target, The path is
# relative to $clst_sharedir/builds. The rel_type is also used as a path prefix# for the seed.
@@ -60,7 +60,7 @@ portage_confdir: /var/git/clustering-livecd/profiles/hpc-clustering/
# have used when building this target.
# example:
# portage_overlay: /usr/local/portage
-portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools /usr/local/portage/layman/sunrise
+portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools /usr/local/portage/layman/sunrise /usr/local/portage/layman/science
# This allows the optional directory containing the output packages for
# catalyst. Mainly used as a way for different spec files to access the same
@@ -84,11 +84,14 @@ pkgcache_path: /var/tmp/catalyst/packages/amd64
# Leaving this blank will default to the system use flags
# example:
# stage4/use: ipv6 socks5 fbcon ncurses readline ssl
+# -tk, -server for torque
stage4/use:
minimal
openmp
mpi
-
+ pbs
+ -tk
+ -server
# This is the set of packages that we will merge into the stage4 tarball. They
# will be built with the USE flags configured above. These packages must not
@@ -114,6 +117,7 @@ stage4/packages:
app-admin/eselect-cblas
app-admin/eselect-blas
app-admin/eselect-lapack
+
# A fsscript is simply a shell script that is copied into the chroot of the stage4
diff --git a/catalyst/nfsroot/2008.0/specs/amd64/stage1.spec b/catalyst/nfsroot/2008.0/specs/amd64/stage1.spec
index a5c35e2..a182d44 100644
--- a/catalyst/nfsroot/2008.0/specs/amd64/stage1.spec
+++ b/catalyst/nfsroot/2008.0/specs/amd64/stage1.spec
@@ -3,7 +3,7 @@ target: stage1
version_stamp: 2008.0
rel_type: default
profile: default/linux/amd64/2008.0
-snapshot: 20080806
+snapshot: 20080816
source_subpath: drobbins/stage3-amd64-2008.06.27
# Kyron:
diff --git a/catalyst/nfsroot/2008.0/specs/amd64/stage2.spec b/catalyst/nfsroot/2008.0/specs/amd64/stage2.spec
index 9612e94..9aa22b0 100644
--- a/catalyst/nfsroot/2008.0/specs/amd64/stage2.spec
+++ b/catalyst/nfsroot/2008.0/specs/amd64/stage2.spec
@@ -3,7 +3,7 @@ target: stage2
version_stamp: 2008.0
rel_type: default
profile: default/linux/amd64/2008.0
-snapshot: 20080806
+snapshot: 20080816
source_subpath: default/stage1-amd64-2008.0
# Kyron:
diff --git a/catalyst/nfsroot/2008.0/specs/amd64/stage3.spec b/catalyst/nfsroot/2008.0/specs/amd64/stage3.spec
index 4b86af8..f736964 100644
--- a/catalyst/nfsroot/2008.0/specs/amd64/stage3.spec
+++ b/catalyst/nfsroot/2008.0/specs/amd64/stage3.spec
@@ -3,7 +3,7 @@ target: stage3
version_stamp: 2008.0
rel_type: default
profile: default/linux/amd64/2008.0/
-snapshot: 20080806
+snapshot: 20080816
source_subpath: default/stage2-amd64-2008.0
# Kyron: