aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Thibodeau <kyron@neuralbs.com>2008-08-18 14:56:47 -0400
committerEric Thibodeau <kyron@neuralbs.com>2008-08-18 14:56:47 -0400
commit3e30b75e9e3b8e02cdb3a92be258e7ee009c4302 (patch)
tree385fee70fdbbf589118ac7edf6612f54c2411521 /catalyst
parentAdded compensation for missing DNSMASQ_USER_CLASSn under certain circumbstanc... (diff)
downloadclustering-livecd-3e30b75e9e3b8e02cdb3a92be258e7ee009c4302.tar.gz
clustering-livecd-3e30b75e9e3b8e02cdb3a92be258e7ee009c4302.tar.bz2
clustering-livecd-3e30b75e9e3b8e02cdb3a92be258e7ee009c4302.zip
Final commit before deadline...see diffs ;)
Diffstat (limited to 'catalyst')
-rwxr-xr-xcatalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup13
-rw-r--r--catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec2
-rw-r--r--catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh5
3 files changed, 17 insertions, 3 deletions
diff --git a/catalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup b/catalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup
index 8d95ca8..233b89e 100755
--- a/catalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup
+++ b/catalyst/livecd/2008.0/overlay/usr/sbin/cluster-setup
@@ -160,7 +160,11 @@ portageq envvar USE | grep -q pbs
if [[ $? == 0 ]]; then
einfo "Setting up torque on $HOSTNAME and in $NFSROOT"
- emerge --config =sys-cluster/torque-2.3.3
+ USE=server emerge --config =sys-cluster/torque-2.3.3
+ # if mom is not started on the master node, listing it in nodes doesn't hurt it and
+ # makes sure the file exists
+ echo $(hostname) >> $PBS_SERVER_HOME/server_priv/nodes
+ /etc/init.d/pbs_server start
USE=-server ROOT=$NFSROOT emerge --config =sys-cluster/torque-2.3.3
fi
@@ -171,3 +175,10 @@ einfo "Setting up auth on the $NFSROOT"
USE=-authmaster ROOT="$NFSROOT" emerge --config =net-nds/ldap-auth-0.1
[[ $? == 0 ]] && einfo "Once you have nodes going, restart Torque (pbs_server)"
+if [[ $1 == "--test" ]]; then
+ echo 'Using --test implies the following:
+- root password is "test" and can log on (passwordless) onto nodes !!!!
+- ldap admin password is "default" !!!!(again)
+- eth1 is the cluster\'s NIC and is set to 10.0.0.1/24
+- eth0 is the public nic
+- all defaults in .config files get used'
diff --git a/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec b/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec
index 17ab415..fa63839 100644
--- a/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec
+++ b/catalyst/livecd/2008.0/specs/amd64/livecd-stage1.spec
@@ -40,7 +40,7 @@ livecd/use:
tk
livecd/packages:
- app-accessibility/brltty
+# app-accessibility/brltty
app-admin/hddtemp
app-admin/ide-smart
app-admin/logrotate
diff --git a/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh b/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh
index 4f9b7c9..63ab733 100644
--- a/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh
+++ b/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh
@@ -63,7 +63,10 @@ openrc_diskless_setup() {
change_opt 'wipe_tmp="NO"' /etc/conf.d/bootmisc
# /etc/conf.d/net
- echo 'dhcpcd_eth0="--renew --persistent"' >> /etc/conf.d/net
+ echo '# server side DNSMASQ_USER_CLASS0 will contain the processor count'
+ echo 'dhcpcd_eth0="--renew --persistent --userclass=$(c=0; for i in /sys/devices/system/cpu/cpu[0-9]*; do ((c++)); done; echo $c)"' >> /etc/conf.d/net
+# The above is an alternative which doesn't use wc, thus no superficial process spawning.
+# echo 'dhcpcd_eth0="--persistent --userclass=$(ls -1d /sys/devices/system/cpu/cpu[0-9]* | /usr/bin/wc -l)"' >> /etc/conf.d/net
# Set clock to localtime as default