aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Thibodeau <kyron@neuralbs.com>2008-07-08 23:11:18 -0400
committerEric Thibodeau <kyron@neuralbs.com>2008-07-08 23:11:18 -0400
commit84b4c22f75f2930bc9122d66c6b0849d9cb88ac7 (patch)
treec4614d919524aa834e2cdd04f29a14543f423243 /overlay
parentlivecd-tools password patch (diff)
downloadclustering-livecd-84b4c22f75f2930bc9122d66c6b0849d9cb88ac7.tar.gz
clustering-livecd-84b4c22f75f2930bc9122d66c6b0849d9cb88ac7.tar.bz2
clustering-livecd-84b4c22f75f2930bc9122d66c6b0849d9cb88ac7.zip
NFSroot now boots cleanly (almost)
- sshd keys generated in catalyst run - runlevel scripts cleaned out for a smoother boot * shutdown and reboots are still unclean, OpenRC needs to ignore useless tasks (given it's an ro ROOT) * still need to resolve the "Caching service dependencies" at boot time (very slow) Updated HOWTOs for merging nfsroot and livecd into a single ISO, currently incomplete: - Added AUFS to livecd, needs to be configured to mount nfsroot as rw for the beaowulf-head config script to function - Once AUFS is functionnal, we can start testing the booting of nodes off the livecd! ** Vmware is being used and is causing some problems: -- e1000 emulation is so good we're getting kernel module problems (irq related...is it the module or VMware...) -- found out how to disable DHCP on the local virtual net (thanks go to Demosthenes on gentoo-server): simply delete the files in /etc/vmware/vmnet1/dhcpd/ and the VMWare dhcpd won't start.
Diffstat (limited to 'overlay')
-rw-r--r--overlay/sys-cluster/beowulf-head/Manifest2
-rw-r--r--overlay/sys-cluster/beowulf-head/beowulf-head-0.1.ebuild6
2 files changed, 4 insertions, 4 deletions
diff --git a/overlay/sys-cluster/beowulf-head/Manifest b/overlay/sys-cluster/beowulf-head/Manifest
index fa39c33..9b81f41 100644
--- a/overlay/sys-cluster/beowulf-head/Manifest
+++ b/overlay/sys-cluster/beowulf-head/Manifest
@@ -1,3 +1,3 @@
AUX cluster.conf 2401 RMD160 e5f37c56b03791f6a884bfad6b37ec17f27045cf SHA1 685c32c8deab47c326e7e05f41caa127e11de863 SHA256 e0142db68ecb9182161b9818d1a8cf944cf316ae694c095123c6d4f8a6f0ce10
-EBUILD beowulf-head-0.1.ebuild 4595 RMD160 a51519bd209f7e6f975b2782a89768285b347686 SHA1 efda02f1b099d52f7248b3859441a19ee9a5b543 SHA256 bde4111437ca6e1ec2a7aa6207cfa496b5ae115a11f033a3585e244044f99a69
+EBUILD beowulf-head-0.1.ebuild 4575 RMD160 bdb06c2362c3e0b09197f2afadca44e1fc6f8047 SHA1 3e9a7362cbbf42f8f151a54b910e364126a0ea74 SHA256 81caa246e7e0eedf33de18f0093bde6801fb04a037d9c7d81d7dad24a90146e7
MISC ChangeLog 101 RMD160 d735719ccc09237e68e4e984eb5451000b06c382 SHA1 79098d1e8ae451f0430d363da6b717966ade6e78 SHA256 8dd010e2772026c4a6b86839842931b99c85c44a5e9f380864cc275b55587ac2
diff --git a/overlay/sys-cluster/beowulf-head/beowulf-head-0.1.ebuild b/overlay/sys-cluster/beowulf-head/beowulf-head-0.1.ebuild
index ca90337..1e23f3c 100644
--- a/overlay/sys-cluster/beowulf-head/beowulf-head-0.1.ebuild
+++ b/overlay/sys-cluster/beowulf-head/beowulf-head-0.1.ebuild
@@ -99,7 +99,7 @@ pxe_conf()
label $PROFNAME
kernel ${BOOTPATH}/kernel
- append ip=dhcp nfsroot=rootserver:${NFSROOT},hard,intr init=/boot/stateless.sh softlevel=nfsmount
+ append ip=dhcp nfsroot=rootserver:${NFSROOT},hard,intr init=/boot/stateless.sh
label local
localboot 0
@@ -117,8 +117,8 @@ pxe_conf()
nfs_root_conf()
{
[ -d ${NFSROOT} ] || die "${NFSROOT} is missing! Either create your own of find one ;)"
- if [ ! -f ${NFSROOT}/boot/vmlinuz ]; then
- ewarn "Couldn't find ${NFSROOT}/boot/vmlinuz !"
+ if [ ! -f ${NFSROOT}/boot/kernel ]; then
+ ewarn "Couldn't find ${NFSROOT}/boot/kernel !"
ewarn "This is what we built the config files to expect."
ewarn "You might have to perform"
fi