summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormchiang <phidias.chiang@gmail.com>2014-01-15 22:26:14 -0500
committerMike Gilbert <floppym@gentoo.org>2014-01-18 20:50:59 -0500
commit2c3be0bbbfa5f443c2afe7c4dfc1d703987cda5d (patch)
treed23fab59ab4b918807a3203205dd6ff7661509e9
parentUpdate version (diff)
downloadeselect-python-2c3be0bbbfa5f443c2afe7c4dfc1d703987cda5d.tar.gz
eselect-python-2c3be0bbbfa5f443c2afe7c4dfc1d703987cda5d.tar.bz2
eselect-python-2c3be0bbbfa5f443c2afe7c4dfc1d703987cda5d.zip
Support Windows binaries via @EXEEXT@, bug 337601eselect-python-20140115
-rw-r--r--Makefile.am2
-rw-r--r--configure.ac4
-rw-r--r--python.eselect.in (renamed from python.eselect)14
3 files changed, 10 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index e92a315..69fd8d8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
bin_PROGRAMS = python-wrapper
eselectdir = $(datadir)/eselect/modules
-dist_eselect_DATA = python.eselect
+nodist_eselect_DATA = python.eselect
diff --git a/configure.ac b/configure.ac
index c49e7d5..c85be38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([eselect-python], [20131210])
+AC_INIT([eselect-python], [20140115])
AM_INIT_AUTOMAKE([-Wall foreign no-dist-gzip dist-bzip2])
AC_PROG_CC
@@ -31,6 +31,6 @@ CFLAGS="${old_CFLAGS}"
# Create output files.
AC_CONFIG_HEADERS([config.h])
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile python.eselect])
AC_OUTPUT
diff --git a/python.eselect b/python.eselect.in
index 9c58391..9a52791 100644
--- a/python.eselect
+++ b/python.eselect.in
@@ -1,4 +1,4 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id: $
@@ -15,12 +15,12 @@ PYTHON_INTERPRETERS_GROUP=""
# Find a list of Python versions
find_targets() {
- local interpreter interpreters="python?.?"
+ local interpreter interpreters="python?.?@EXEEXT@"
if [[ "${PYTHON_INTERPRETERS_GROUP}" == "2" ]]; then
- interpreters="python2.?"
+ interpreters="python2.?@EXEEXT@"
elif [[ "${PYTHON_INTERPRETERS_GROUP}" == "3" ]]; then
- interpreters="python3.?"
+ interpreters="python3.?@EXEEXT@"
fi
# Think twice before adding jython to this list. /usr/bin/jython
@@ -349,7 +349,7 @@ describe_update_options() {
}
do_update() {
- local if_unset="0" ignored_slots=() interpreters="python?.?" python2="0" python3="0" python_version_option= slot= target targets=()
+ local if_unset="0" ignored_slots=() interpreters="python?.?@EXEEXT@" python2="0" python3="0" python_version_option= slot= target targets=()
while [[ $# > 0 ]]; do
case "$1" in
--if-unset)
@@ -388,9 +388,9 @@ do_update() {
fi
if [[ "${python2}" == "1" ]]; then
- interpreters="python2.?"
+ interpreters="python2.?@EXEEXT@"
elif [[ "${python3}" == "1" ]]; then
- interpreters="python3.?"
+ interpreters="python3.?@EXEEXT@"
fi
targets=($(cd "${INTERPRETER_PATH}"; ls ${interpreters} 2> /dev/null | sort -r))