aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-12-04 10:08:45 +0000
committerUlrich Müller <ulm@gentoo.org>2009-12-04 10:08:45 +0000
commit19cb82aa0afec4fbe194f944d5562e4251d668e3 (patch)
tree1fe4e00d77a609cd82efb8cd12602929543bbcd4
parentRemove redundant error checking. (diff)
downloadeselect-19cb82aa0afec4fbe194f944d5562e4251d668e3.tar.gz
eselect-19cb82aa0afec4fbe194f944d5562e4251d668e3.tar.bz2
eselect-19cb82aa0afec4fbe194f944d5562e4251d668e3.zip
Some autoconf/automake changes.
svn path=/trunk/; revision=741
-rw-r--r--ChangeLog7
-rw-r--r--Makefile.am4
-rw-r--r--configure.ac15
3 files changed, 18 insertions, 8 deletions
diff --git a/ChangeLog b/ChangeLog
index a8bdc32..2d5f547 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,12 @@
2009-12-04 Ulrich Mueller <ulm@gentoo.org>
+ * Makefile.am (MAINTAINERCLEANFILES): Remove config dir, since
+ only simple files are allowed here.
+ (maintainer-clean-local): Add rule for cleaning of config dir.
+
+ * configure.ac: AC_OUTPUT with arguments is obsolete, use
+ AC_CONFIG files instead.
+
* libs/package-manager.bash.in (envvar, best_version, has_version)
(get_repositories, get_repo_news_dir): Error checking was
redundant, because package_manager cannot return unknown values.
diff --git a/Makefile.am b/Makefile.am
index 74eccb3..e7eac35 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,6 @@ SUBDIRS = doc man misc bin libs modules
MAINTAINERCLEANFILES = aclocal.m4 \
configure \
Makefile.in \
- config/ \
*.html
EXTRA_DIST = autogen.bash \
@@ -19,3 +18,6 @@ html: $(foreach f, $(doc_files), $(f).html)
%.html: %
@RST2HTML@ < $? > $@
+
+maintainer-clean-local:
+ -rm -rf config
diff --git a/configure.ac b/configure.ac
index 6af02ab..8639b86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,10 +87,11 @@ AC_SUBST(DODGY_MODULES)
AC_MSG_RESULT(${DODGY_MODULES:-nope})
AM_CONDITIONAL([DODGY_MODULES], test "x$DODGY_MODULES" = "xyes")
-AC_OUTPUT(Makefile
- doc/Makefile
- man/Makefile
- misc/Makefile
- bin/Makefile
- libs/Makefile
- modules/Makefile)
+AC_CONFIG_FILES(Makefile
+ doc/Makefile
+ man/Makefile
+ misc/Makefile
+ bin/Makefile
+ libs/Makefile
+ modules/Makefile)
+AC_OUTPUT