aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-06-18 12:08:02 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-06-18 12:08:02 +0000
commit2bd14992d8ad638c3c050041d55138990f236b3f (patch)
tree5abc7d482b6e311822a600b0d54c8ba8c1d59e72
parentUpdated usage info with global options; Added OPTIONS section where global op... (diff)
downloadeselect-2bd14992d8ad638c3c050041d55138990f236b3f.tar.gz
eselect-2bd14992d8ad638c3c050041d55138990f236b3f.tar.bz2
eselect-2bd14992d8ad638c3c050041d55138990f236b3f.zip
Added html target to generate HTML for TODO and README in addition to those in doc/.
svn path=/trunk/; revision=145
-rw-r--r--ChangeLog24
-rw-r--r--Makefile.am13
-rw-r--r--misc/eselect.bashcomp8
3 files changed, 39 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index 8506c2d..276410a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,29 @@
ChangeLog for eselect
+2005-06-18 Aaron Walker <ka0ttic@gentoo.org>
+
+ * libs/output.bash.in: Fixed typo in write_kv_list_entry() that caused
+ misaligned value text.
+ * bin/eselect.in: Added missing 'shift' when unrecognized global
+ options are encountered. Otherwise an infinite loop occurs if a user
+ specifies one. Also added ec_do_list-options() and updated
+ ec_do_help() to call it.
+ * bin/Makefile.am: Add bashcomp-config to symlinks list.
+ * doc/developer-guide.txt: Fixed headers so that it'll compile.
+ * modules/bashcomp.eselect: Fixed bug if do_list is passed an argument
+ besides --global.
+ * man/eselect.1: updated usage info with global options. Added OPTIONS
+ section where global options will be described.
+ * README, man/profile.eselect.5: Fixed minor typo.
+ * man/Makefile.am, man/bashcomp.eselect.5: Added manual page for
+ bashcomp.eselect.
+ * misc/eselect.bashcomp: Parse 'eselect help' instead of 'eselect
+ list-modules' so that we can pick up supported global options and add
+ them to possible completions. This means we *never* will have to edit
+ this file when we add new global options.
+ * Makefile.am: Added html target to generate HTML for TODO and README
+ in addition to those in doc/.
+
2005-06-17 Danny van Dyk <kugelfang@gentoo.org>
* libs/output.bash.in: Moved back to use COLOUR_* envvars instead of a
diff --git a/Makefile.am b/Makefile.am
index 64158fd..0f33798 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,14 +2,23 @@
AUTOMAKE_OPTIONS = dist-bzip2 no-dist-gzip
+doc_files = README TODO
+
SUBDIRS = doc man misc bin libs modules
MAINTAINERCLEANFILES = aclocal.m4 \
configure \
Makefile.in \
config/config.guess \
config/ltmain.sh \
- config/config.sub
+ config/config.sub \
+ *.html
EXTRA_DIST = autogen.sh \
ChangeLog \
- README
+ $(doc_files)
+
+html: $(foreach f, $(doc_files), $(f).html)
+ cd doc && $(MAKE) html
+
+%.html: %
+ rst2html.py < $? > $@
diff --git a/misc/eselect.bashcomp b/misc/eselect.bashcomp
index 82730d3..db19d2e 100644
--- a/misc/eselect.bashcomp
+++ b/misc/eselect.bashcomp
@@ -6,22 +6,22 @@
# Author: Aaron Walker <ka0ttic@gentoo.org>
_eselect() {
- local cur prev preprev sedcmd possibles
+ local cur prev sedcmd possibles
COMPREPLY=()
cur="${COMP_WORDS[COMP_CWORD]}"
prev="${COMP_WORDS[COMP_CWORD-1]}"
sedcmd='sed -n -e s/^[[:space:]]\+.*1m\([^[:space:]][[:alnum:]-]\+\).*[[:space:]]\+.*$/\1/p'
- opts="--no-colour"
if [[ ${COMP_CWORD} -eq 1 ]] || [[ -n "${prev}" && ${prev} == -* ]]
then
- possibles="$(eselect list-modules | ${sedcmd}) ${opts}"
+ possibles="$(eselect help | ${sedcmd})"
elif eselect ${prev} usage &>/dev/null ; then
possibles=$(eselect ${prev} usage | ${sedcmd})
fi
[[ -n "${possibles}" ]] && \
- COMPREPLY=($(compgen -W "${possibles}" -- ${cur}))
+ COMPREPLY=( $(compgen -W "${possibles}" -- ${cur}) )
+
return 0
}
complete -F _eselect eselect