aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-12-04 09:57:32 +0000
committerUlrich Müller <ulm@gentoo.org>2009-12-04 09:57:32 +0000
commitd1b5cf15eb55fd839603fa84aa65f7750f7b5a1d (patch)
treee9e981e45ac15d099d5a8fe36e638d68994f7a11
parentUpdate comment on GNU sort. (diff)
downloadeselect-d1b5cf15eb55fd839603fa84aa65f7750f7b5a1d.tar.gz
eselect-d1b5cf15eb55fd839603fa84aa65f7750f7b5a1d.tar.bz2
eselect-d1b5cf15eb55fd839603fa84aa65f7750f7b5a1d.zip
Globally replace ec_ by es_ for consistency reasons.
svn path=/trunk/; revision=739
-rw-r--r--ChangeLog16
-rw-r--r--README2
-rwxr-xr-xbin/eselect.in36
-rw-r--r--libs/core.bash.in2
4 files changed, 28 insertions, 28 deletions
diff --git a/ChangeLog b/ChangeLog
index 92a89bb..a49e93a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -22,7 +22,7 @@
* configure.ac: Update version to 1.2.6.
* Tagged 1.2.6 release.
- * bin/eselect.in (ec_do_list_options): Mention "--brief" option.
+ * bin/eselect.in (es_do_list_options): Mention "--brief" option.
* libs/output.bash.in (is_output_mode): New function.
(write_list_start, write_numbered_list_entry, write_numbered_list)
@@ -44,10 +44,10 @@
* modules/rc.eselect (do_show): Remove workaround for eval.
* README: Update style notes.
- * bin/eselect.in (ec_do_list_options, ec_do_list_modules):
- Renamed from ec_do_list-* to prevent invalid identifier errors in
+ * bin/eselect.in (es_do_list_options, es_do_list_modules):
+ Renamed from es_do_list-* to prevent invalid identifier errors in
POSIX mode, bug 280191. Substitute underscore for hyphen in call.
- (ec_do_help): Fix call for ec_do_list_*.
+ (es_do_help): Fix call for es_do_list_*.
* modules/news.eselect (do_read): Suppress "no news" message in
brief output mode, bug 288527.
@@ -150,7 +150,7 @@
* bin/eselect.in (ESELECT_KNOWN_OPTIONS): Add --brief option,
which will enable shorter output. Bug 154511.
- (ec_do_help): Reset output mode to default.
+ (es_do_help): Reset output mode to default.
* libs/output.bash.in (set_output_mode): New function.
(write_list_start): Suppress all output in "brief" output mode.
(write_numbered_list_entry): Suppress numbers in "brief" mode.
@@ -553,7 +553,7 @@
* libs/core.bash.in (die): Eliminate pgrep call; just kill the
main process and exit.
- * bin/eselect.in (ec_do_list-modules): Use do_action for calling
+ * bin/eselect.in (es_do_list-modules): Use do_action for calling
the module, not eselect. Quote "$@".
(ESELECT_KNOWN_OPTIONS): Treat 'help' and 'version' options as if
they were actions. Fixes bug 153890.
@@ -1167,8 +1167,8 @@
misaligned value text.
* bin/eselect.in: Added missing 'shift' when unrecognized global
options are encountered. Otherwise an infinite loop occurs if a user
- specifies one. Also added ec_do_list-options() and updated
- ec_do_help() to call it.
+ specifies one. Also added es_do_list-options() and updated
+ es_do_help() to call it.
* bin/Makefile.am: Add bashcomp-config to symlinks list.
* doc/developer-guide.txt: Fixed headers so that it'll compile.
* modules/bashcomp.eselect: Fixed bug if do_list is passed an argument
diff --git a/README b/README
index bb9c2ce..09a8cee 100644
--- a/README
+++ b/README
@@ -25,6 +25,6 @@ Style Notes
* For all source files, the same indenting rules apply as for ebuilds:
one tab per indent level, with each tab representing 4 places.
* Avoid lines wider than 79 positions.
-* Public functions don't get the ``ec_`` prefix, private functions do.
+* Public functions don't get the ``es_`` prefix, private functions do.
* eval is evil, so don't use it.
* Absolute paths to executables are not portable, so don't use them.
diff --git a/bin/eselect.in b/bin/eselect.in
index bf4e28c..5dbad5d 100755
--- a/bin/eselect.in
+++ b/bin/eselect.in
@@ -67,10 +67,10 @@ inherit manip output path-manipulation tests
# it, don't ask...
trap 'echo "exiting" >&2; exit 250' 15
-# ec_find_module foo
+# es_find_module foo
# Find and echo the filename of the foo module. If there's no foo module,
# die.
-ec_find_module() {
+es_find_module() {
local modname="$1" modpath="" modfile=""
[[ -z ${modname} ]] && die "Usage: ${FUNCNAME} <module>"
for modpath in "${ESELECT_MODULES_PATH[@]}" ; do
@@ -82,43 +82,43 @@ ec_find_module() {
echo ${modfile}
}
-# ec_do_usage
+# es_do_usage
# Display eselect usage
-ec_do_usage() {
+es_do_usage() {
echo "Usage: eselect <global options> <module name> <module options>"
}
-# ec_do_help
+# es_do_help
# Display eselect help
-ec_do_help() {
+es_do_help() {
set_output_mode default
- ec_do_usage
+ es_do_usage
echo
- ec_do_list_options
+ es_do_list_options
echo
- ec_do_list_modules
+ es_do_list_modules
}
-# ec_do_version
+# es_do_version
# Display eselect version
-ec_do_version() {
+es_do_version() {
echo "eselect ${ESELECT_VERSION}"
echo
echo "Copyright (c) 2005-2009 Gentoo Foundation."
echo "Distributed under the terms of the GNU General Public License v2."
}
-# ec_do_list_options
+# es_do_list_options
# Display all recognized global options
-ec_do_list_options() {
+es_do_list_options() {
write_list_start "Global options:"
write_kv_list_entry "--brief" "Make output shorter"
write_kv_list_entry "--no-color,--no-colour" "Disable coloured output"
}
-# ec_do_list_modules
+# es_do_list_modules
# Display all available eselect modules DEPRECATED
-ec_do_list_modules() {
+es_do_list_modules() {
do_action modules list "$@"
}
@@ -184,12 +184,12 @@ if [[ -z ${action} ]] && [[ -n ${1##--} ]] ; then
fi
if [[ -n ${action} ]] ; then
- if is_function "ec_do_${action//-/_}" ; then
+ if is_function "es_do_${action//-/_}" ; then
[[ $# -gt 0 ]] && die -q "Too many parameters"
- ec_do_${action//-/_}
+ es_do_${action//-/_}
else
do_action "${action}" "$@"
fi
else
- ec_do_help
+ es_do_help
fi
diff --git a/libs/core.bash.in b/libs/core.bash.in
index ceb9a4a..55955af 100644
--- a/libs/core.bash.in
+++ b/libs/core.bash.in
@@ -75,7 +75,7 @@ do_action() {
[[ ${ESELECT_BINARY_NAME##*/} != ${ESELECT_PROGRAM_NAME} ]] && \
ESELECT_COMMAND="${ESELECT_BINARY_NAME##*/}"
- modfile=$( ec_find_module "${action}" )
+ modfile=$( es_find_module "${action}" )
(
source "$ESELECT_DEFAULT_ACTIONS" 2>/dev/null \
|| die "Couldn't source ${ESELECT_DEFAULT_ACTIONS}"