aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-05-20 09:59:09 +0200
committerUlrich Müller <ulm@gentoo.org>2014-05-20 09:59:09 +0200
commit2996ee3ab94c875f7d000ce73ea1918d748793c5 (patch)
tree4cf6f705dd59bdd952635b7267326468bdf5cb80 /bin
parentAutomake doesn't play well with leading whitespace in variables. (diff)
downloadeselect-2996ee3ab94c875f7d000ce73ea1918d748793c5.tar.gz
eselect-2996ee3ab94c875f7d000ce73ea1918d748793c5.tar.bz2
eselect-2996ee3ab94c875f7d000ce73ea1918d748793c5.zip
Use "%" instead of "," as delimiter for sed.
* bin/Makefile.am (dosed): * libs/Makefile.am (dosed): * man/Makefile.am (dosed): Use "%" instead of "," as delimiter.
Diffstat (limited to 'bin')
-rw-r--r--bin/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
index 7ba2996..20902c1 100644
--- a/bin/Makefile.am
+++ b/bin/Makefile.am
@@ -1,10 +1,10 @@
bin_SCRIPTS = eselect
EXTRA_DIST = eselect.in
-dosed = @SED@ -e 's,\@BASH\@,$(BASH),g' \
- -e 's,\@DATADIR\@,$(datadir),g' \
- -e 's,\@EPREFIX\@,$(EPREFIX),g' \
- -e 's,\@VERSION\@,$(VERSION)$(EXTRAVERSION),g'
+dosed = @SED@ -e 's%\@BASH\@%$(BASH)%g' \
+ -e 's%\@DATADIR\@%$(datadir)%g' \
+ -e 's%\@EPREFIX\@%$(EPREFIX)%g' \
+ -e 's%\@VERSION\@%$(VERSION)$(EXTRAVERSION)%g'
% : %.in
@echo "Building $@..."