aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-05-11 19:04:20 +0200
committerUlrich Müller <ulm@gentoo.org>2023-05-11 19:04:20 +0200
commitad863d288f29bcca776369dec7765dbb0174ba82 (patch)
tree30f79a3b094fa5a28967949e1ddbfeffaa156beb /bin
parentDon't substitute PORTAGEQ in libs (diff)
downloadeselect-ad863d288f29bcca776369dec7765dbb0174ba82.tar.gz
eselect-ad863d288f29bcca776369dec7765dbb0174ba82.tar.bz2
eselect-ad863d288f29bcca776369dec7765dbb0174ba82.zip
Don't autodetect bash and env-update at configure time
* bin/eselect.in: Update shebang to use EPREFIX. Bug 905934. * bin/Makefile.am (dosed): Don't substitute BASH. * libs/package-manager.bash.in (env_update): Don't use an absolute path for env-update. * libs/Makefile.am (dosed): Don't substitute ENV_UPDATE. * configure.ac: Drop checks for bash and env-update paths. Bug: https://bugs.gentoo.org/905934 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'bin')
-rw-r--r--bin/Makefile.am3
-rwxr-xr-xbin/eselect.in2
2 files changed, 2 insertions, 3 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
index 20902c1..a4bf2a2 100644
--- a/bin/Makefile.am
+++ b/bin/Makefile.am
@@ -1,8 +1,7 @@
bin_SCRIPTS = eselect
EXTRA_DIST = eselect.in
-dosed = @SED@ -e 's%\@BASH\@%$(BASH)%g' \
- -e 's%\@DATADIR\@%$(datadir)%g' \
+dosed = @SED@ -e 's%\@DATADIR\@%$(datadir)%g' \
-e 's%\@EPREFIX\@%$(EPREFIX)%g' \
-e 's%\@VERSION\@%$(VERSION)$(EXTRAVERSION)%g'
diff --git a/bin/eselect.in b/bin/eselect.in
index 7a74098..9109627 100755
--- a/bin/eselect.in
+++ b/bin/eselect.in
@@ -1,4 +1,4 @@
-#!@BASH@
+#!@EPREFIX@/bin/bash
# -*-eselect-*- vim: ft=eselect
# Copyright (c) 2005-2023 Gentoo Authors
#