aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2006-07-03 00:22:15 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2006-07-03 00:22:15 +0000
commit37dc024f4780af5aab62c15d019758f03ab2680f (patch)
tree797afdde8ca26a96e4aded5973c6aea26d820999 /configure.ac
parentFix update action (variable name typo), and handle missing OOo dictionary.lst... (diff)
downloadeselect-37dc024f4780af5aab62c15d019758f03ab2680f.tar.gz
eselect-37dc024f4780af5aab62c15d019758f03ab2680f.tar.bz2
eselect-37dc024f4780af5aab62c15d019758f03ab2680f.zip
2006-07-01 Danny van Dyk <kugelfang@gentoo.org>
* libs/portage.bash.in, libs/paludis.bash.in, libs/package-manager.bash.in, libs/Makefile.am, configure.ac: Added support for other package managers than portage. Public functions are part of package-manager.bash. paludis.bash and portage.bash provide private backend functions. * modules/profile.eselect: Marked as portage-only module. * modules/opengl.eselect, modules/binutils.eselect: Change from inherit portage to inherit package-manager. * modules/rc.eselect: Fix bug in list_runlevels(). Respect setting of ${svcdir} in /etc/rc.conf. Add support to show() runlevels other than the current. diffstat: NEWS | 13 ++++ configure.ac | 13 ++-- libs/Makefile.am | 8 ++ libs/package-manager.bash.in | 125 +++++++++++++++++++++++++++++++++++++++++++ libs/paludis.bash.in | 43 ++++++++++++++ libs/portage.bash.in | 48 ---------------- modules/binutils.eselect | 2 modules/opengl.eselect | 2 modules/profile.eselect | 1 modules/rc.eselect | 19 ++++-- 10 files changed, 211 insertions(+), 63 deletions(-) svn path=/trunk/; revision=279
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index e0c7062..987214d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,24 +23,25 @@ if test x$SED = "x" ; then
fi
AC_PATH_PROG(PORTAGEQ, portageq)
+AC_PATH_PROG(PALUDIS, paludis)
AC_PATH_PROG(READLINK, greadlink)
if test x$CANONICALISE = "x" ; then
AC_CHECK_PROG(READLINK, readlink -f ., yes, no, [$PATH])
if test x$READLINK = "xyes" ; then
- AC_PATH_PROG(READLINK, readlink)
+ AC_PATH_PROG(READLINK, readlink)
fi
-
+
CANONICALISE_TEST=`$READLINK -f . > /dev/null 2>&1`
if ! test x$? = "x0" ; then
- unset READLINK
+ unset READLINK
fi
-
+
if test x$READLINK = "x" ; then
- AC_PATH_PROG(REALPATH, realpath)
+ AC_PATH_PROG(REALPATH, realpath)
if test x$REALPATH = "x" ; then
AC_MSG_ERROR([Either GNU readlink or realpath is required])
- fi
+ fi
fi
fi
if test x$READLINK != "x"; then