aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-04-28 09:40:31 +0000
committerUlrich Müller <ulm@gentoo.org>2009-04-28 09:40:31 +0000
commitfcb7c02fe2cb861a9518c76cadd23c9d88b31e7d (patch)
tree58913aa6b3f2f1cc8a27a289d233d502e76e8154 /configure.ac
parentDon't call portageq directly, use generic has_version function instead. (diff)
downloadeselect-fcb7c02fe2cb861a9518c76cadd23c9d88b31e7d.tar.gz
eselect-fcb7c02fe2cb861a9518c76cadd23c9d88b31e7d.tar.bz2
eselect-fcb7c02fe2cb861a9518c76cadd23c9d88b31e7d.zip
Add --with-pm option for configuring the preferred package manager.
svn path=/trunk/; revision=513
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 36e5f88..9fe8078 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,7 @@ if test x$SED = "x" ; then
AC_MSG_ERROR([GNU sed is required])
fi
-AC_PATH_PROG(PORTAGEQ, portageq)
+AC_PATH_PROG(PORTAGEQ, portageq, /usr/bin/portageq)
AC_PATH_PROG(READLINK, greadlink)
if test x$CANONICALISE = "x" ; then
@@ -57,9 +57,18 @@ if test x$RST2HTML = "x" ; then
AC_PATH_PROG(RST2HTML, rst2html.py)
fi
+AC_MSG_CHECKING([what package manager we shall use])
+AC_ARG_WITH(pm, [AS_HELP_STRING([--with-pm=PM], [use package manager PM])],
+ [], [withval=portage])
+AS_CASE([x$withval], xportage,, xpaludis,,
+ [AC_MSG_ERROR([package manager "$withval" not known])])
+AC_SUBST(PACKAGE_MANAGER, [$withval])
+AC_MSG_RESULT([$PACKAGE_MANAGER])
+
AC_MSG_CHECKING([whether dodgy modules should be installed])
AC_ARG_ENABLE(dodgy_modules,
- [ --enable-dodgy-modules Enable experimental and incomplete modules],
+ [AS_HELP_STRING([--enable-dodgy-modules],
+ [enable experimental and incomplete modules])]
if test x$enableval = "xyes" ; then
DODGY_MODULES="yes"
else