aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-05-19 19:04:47 +0000
committerUlrich Müller <ulm@gentoo.org>2009-05-19 19:04:47 +0000
commit63e3fcdde2747b7e5515a2ca45a5381bb3778fb9 (patch)
tree0e53691b5b13c16ea3f1b5bf0c60b452b130f79b /libs
parentUpdate version to 1.1_rc2. (diff)
downloadeselect-63e3fcdde2747b7e5515a2ca45a5381bb3778fb9.tar.gz
eselect-63e3fcdde2747b7e5515a2ca45a5381bb3778fb9.tar.bz2
eselect-63e3fcdde2747b7e5515a2ca45a5381bb3778fb9.zip
Don't hardcode /bin/bash in order to be more Prefix-friendly.
svn path=/trunk/; revision=552
Diffstat (limited to 'libs')
-rw-r--r--libs/Makefile.am26
-rw-r--r--libs/config.bash.in1
-rw-r--r--libs/core.bash.in1
-rw-r--r--libs/default.eselect.in1
-rw-r--r--libs/editor-variable.bash.in1
-rw-r--r--libs/manip.bash.in1
-rw-r--r--libs/multilib.bash.in1
-rw-r--r--libs/output.bash.in1
-rw-r--r--libs/package-manager.bash.in1
-rw-r--r--libs/path-manipulation.bash.in1
-rw-r--r--libs/skel.bash.in1
-rw-r--r--libs/tests.bash.in1
12 files changed, 13 insertions, 24 deletions
diff --git a/libs/Makefile.am b/libs/Makefile.am
index e4e2d95..e53a7b8 100644
--- a/libs/Makefile.am
+++ b/libs/Makefile.am
@@ -1,17 +1,17 @@
eselectlibsdir = $(datadir)/$(PACKAGE_NAME)/libs/
-eselectlibs_SCRIPTS = \
- config.bash \
- core.bash \
- default.eselect \
- editor-variable.bash \
- manip.bash \
- multilib.bash \
- output.bash \
- package-manager.bash \
- path-manipulation.bash \
- skel.bash \
- tests.bash
+eselectlibs_DATA = \
+ config.bash \
+ core.bash \
+ default.eselect \
+ editor-variable.bash \
+ manip.bash \
+ multilib.bash \
+ output.bash \
+ package-manager.bash \
+ path-manipulation.bash \
+ skel.bash \
+ tests.bash
EXTRA_DIST = \
config.bash.in \
@@ -42,4 +42,4 @@ dosed = @SED@ \
cp $? $@
MAINTAINERCLEANFILES = Makefile.in
-CLEANFILES = $(eselectlibs_SCRIPTS)
+CLEANFILES = $(eselectlibs_DATA)
diff --git a/libs/config.bash.in b/libs/config.bash.in
index fc7e1cf..3902ab0 100644
--- a/libs/config.bash.in
+++ b/libs/config.bash.in
@@ -1,4 +1,3 @@
-#!/bin/bash
# Copyright (c) 2005-2009 Gentoo Foundation -*-eselect-*-
# $Id$
# This file is part of the 'eselect' tools framework.
diff --git a/libs/core.bash.in b/libs/core.bash.in
index a55ce69..d5ccfb8 100644
--- a/libs/core.bash.in
+++ b/libs/core.bash.in
@@ -1,4 +1,3 @@
-#!/bin/bash
# Copyright (c) 2005-2009 Gentoo Foundation -*-eselect-*-
# $Id$
# This file is part of the 'eselect' tools framework.
diff --git a/libs/default.eselect.in b/libs/default.eselect.in
index ed19f81..56fac10 100644
--- a/libs/default.eselect.in
+++ b/libs/default.eselect.in
@@ -1,4 +1,3 @@
-#!/bin/bash
# Copyright (c) 2005-2009 Gentoo Foundation -*-eselect-*-
# $Id$
# This file is part of the 'eselect' tools framework.
diff --git a/libs/editor-variable.bash.in b/libs/editor-variable.bash.in
index f57659d..e5fca29 100644
--- a/libs/editor-variable.bash.in
+++ b/libs/editor-variable.bash.in
@@ -1,4 +1,3 @@
-#!/bin/bash
# Copyright (c) 2005-2009 Gentoo Foundation -*-eselect-*-
# $Id$
# This file is part of the 'eselect' tools framework.
diff --git a/libs/manip.bash.in b/libs/manip.bash.in
index 522f4c4..f6cdac0 100644
--- a/libs/manip.bash.in
+++ b/libs/manip.bash.in
@@ -1,4 +1,3 @@
-#!/bin/bash
# Copyright (c) 2005-2009 Gentoo Foundation -*-eselect-*-
# $Id$
# This file is part of the 'eselect' tools framework.
diff --git a/libs/multilib.bash.in b/libs/multilib.bash.in
index 9871602..f40e304 100644
--- a/libs/multilib.bash.in
+++ b/libs/multilib.bash.in
@@ -1,4 +1,3 @@
-#!/bin/bash
# Copyright (c) 2005-2009 Gentoo Foundation -*-eselect-*-
# $Id$
# This file is part of the 'eselect' tools framework.
diff --git a/libs/output.bash.in b/libs/output.bash.in
index 27a357f..53a806f 100644
--- a/libs/output.bash.in
+++ b/libs/output.bash.in
@@ -1,4 +1,3 @@
-#!/bin/bash
# Copyright (c) 2005-2009 Gentoo Foundation -*-eselect-*-
# $Id$
# This file is part of the 'eselect' tools framework.
diff --git a/libs/package-manager.bash.in b/libs/package-manager.bash.in
index 80e8ef3..9fddf02 100644
--- a/libs/package-manager.bash.in
+++ b/libs/package-manager.bash.in
@@ -1,4 +1,3 @@
-#!/bin/bash
# Copyright (c) 2005-2009 Gentoo Foundation -*-eselect-*-
# $Id$
# This file is part of the 'eselect' tools framework.
diff --git a/libs/path-manipulation.bash.in b/libs/path-manipulation.bash.in
index 84f57e2..b400a98 100644
--- a/libs/path-manipulation.bash.in
+++ b/libs/path-manipulation.bash.in
@@ -1,4 +1,3 @@
-#!/bin/bash
# Copyright (c) 2005-2009 Gentoo Foundation -*-eselect-*-
# $Id$
# This file is part of the 'eselect' tools framework.
diff --git a/libs/skel.bash.in b/libs/skel.bash.in
index 24f44b6..bc7e697 100644
--- a/libs/skel.bash.in
+++ b/libs/skel.bash.in
@@ -1,4 +1,3 @@
-#!/bin/bash
# Copyright (c) 1999-2009 Gentoo Foundation -*-eselect-*-
# $Id$
# This file is part of the 'eselect' tools framework.
diff --git a/libs/tests.bash.in b/libs/tests.bash.in
index 4d32e52..c0e3ae3 100644
--- a/libs/tests.bash.in
+++ b/libs/tests.bash.in
@@ -1,4 +1,3 @@
-#!/bin/bash
# Copyright (c) 2005-2009 Gentoo Foundation -*-eselect-*-
# $Id$
# This file is part of the 'eselect' tools framework.