aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog21
-rw-r--r--libs/default.eselect.in6
-rw-r--r--modules/bashcomp.eselect2
-rw-r--r--modules/binutils.eselect2
-rw-r--r--modules/config.eselect2
-rw-r--r--modules/cow.eselect2
-rw-r--r--modules/editor.eselect2
-rw-r--r--modules/env.eselect2
-rw-r--r--modules/kernel.eselect2
-rw-r--r--modules/locale.eselect2
-rw-r--r--modules/modules.eselect2
-rw-r--r--modules/news.eselect2
-rw-r--r--modules/pager.eselect2
-rw-r--r--modules/profile.eselect2
-rw-r--r--modules/rc.eselect2
-rw-r--r--modules/visual.eselect2
16 files changed, 25 insertions, 30 deletions
diff --git a/ChangeLog b/ChangeLog
index ea44339..cb13064 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,24 @@
+2012-02-18 Ulrich Müller <ulm@gentoo.org>
+
+ * libs/default.eselect.in (do_version): Show version of eselect;
+ show version of the module if it is available.
+ (VERSION): Set default version to empty string.
+ * modules/bashcomp.eselect (VERSION):
+ * modules/binutils.eselect (VERSION):
+ * modules/config.eselect (VERSION):
+ * modules/cow.eselect (VERSION):
+ * modules/editor.eselect (VERSION):
+ * modules/env.eselect (VERSION):
+ * modules/kernel.eselect (VERSION):
+ * modules/locale.eselect (VERSION):
+ * modules/modules.eselect (VERSION):
+ * modules/news.eselect (VERSION):
+ * modules/pager.eselect (VERSION):
+ * modules/profile.eselect (VERSION):
+ * modules/rc.eselect (VERSION):
+ * modules/visual.eselect (VERSION): Don't assign an extra version
+ for modules that are part of eselect proper.
+
2012-02-12 Ulrich Müller <ulm@gentoo.org>
* configure.ac: Update version to 1.3.1.
diff --git a/libs/default.eselect.in b/libs/default.eselect.in
index a65cf36..fb0241a 100644
--- a/libs/default.eselect.in
+++ b/libs/default.eselect.in
@@ -16,7 +16,7 @@
# eselect. If not, see <http://www.gnu.org/licenses/>.
DESCRIPTION="No description available"
-VERSION="No version available"
+VERSION=""
DEFAULT_ACTION="usage"
describe_usage() {
@@ -85,7 +85,9 @@ describe_version() {
}
do_version() {
- echo "Version ${VERSION}"
+ [[ -n ${ESELECT_MODULE_NAME} && -n ${VERSION} ]] \
+ && echo "${ESELECT_MODULE_NAME}.eselect ${VERSION}"
+ echo "${ESELECT_PROGRAM_NAME} ${ESELECT_VERSION}"
}
describe_help() {
diff --git a/modules/bashcomp.eselect b/modules/bashcomp.eselect
index cbea89c..764430e 100644
--- a/modules/bashcomp.eselect
+++ b/modules/bashcomp.eselect
@@ -5,8 +5,6 @@
DESCRIPTION="Manage contributed bash-completion scripts"
MAINTAINER="eselect@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}")
find_targets() {
local bcdir bc
diff --git a/modules/binutils.eselect b/modules/binutils.eselect
index efff857..6b7d4c1 100644
--- a/modules/binutils.eselect
+++ b/modules/binutils.eselect
@@ -7,8 +7,6 @@ inherit config package-manager
DESCRIPTION="Manage installed versions of sys-devel/binutils"
MAINTAINER="eselect@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}" )
BINUTILS_ENVFILE=${EROOT}/etc/env.d/05binutils
diff --git a/modules/config.eselect b/modules/config.eselect
index 1cdaf93..9cdd9f6 100644
--- a/modules/config.eselect
+++ b/modules/config.eselect
@@ -7,8 +7,6 @@ inherit portage
DESCRIPTION="Handle configuration file merges"
MAINTAINER="eselect@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}" )
show_extra_help_text() {
cat <<ENDOFTEXT
diff --git a/modules/cow.eselect b/modules/cow.eselect
index 18c7029..9f96354 100644
--- a/modules/cow.eselect
+++ b/modules/cow.eselect
@@ -5,8 +5,6 @@
DESCRIPTION="Do things to a cow"
MAINTAINER="eselect@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}" )
### moo action
diff --git a/modules/editor.eselect b/modules/editor.eselect
index c09cdf1..4b68422 100644
--- a/modules/editor.eselect
+++ b/modules/editor.eselect
@@ -17,5 +17,3 @@ inherit editor-variable
DESCRIPTION="Manage the ${EDITOR_VAR} environment variable"
MAINTAINER="ulm@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}")
diff --git a/modules/env.eselect b/modules/env.eselect
index 2c37327..8028185 100644
--- a/modules/env.eselect
+++ b/modules/env.eselect
@@ -7,8 +7,6 @@ inherit config multilib package-manager
DESCRIPTION="Manage environment variables set in /etc/env.d/"
MAINTAINER="eselect@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}" )
# Classes of env-vars
SPACE_CLASS="CONFIG_PROTECT
diff --git a/modules/kernel.eselect b/modules/kernel.eselect
index 7a76361..91e1fe1 100644
--- a/modules/kernel.eselect
+++ b/modules/kernel.eselect
@@ -5,8 +5,6 @@
DESCRIPTION="Manage the /usr/src/linux symlink"
MAINTAINER="eselect@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}")
# sort function for kernel versions, to be used in a pipe
sort_kernel_versions() {
diff --git a/modules/locale.eselect b/modules/locale.eselect
index 4a530fd..5e1af4e 100644
--- a/modules/locale.eselect
+++ b/modules/locale.eselect
@@ -7,8 +7,6 @@ inherit config
DESCRIPTION="Manage the LANG environment variable"
MAINTAINER="matsuu@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}")
# file name as documented in http://www.gentoo.org/doc/en/utf-8.xml
LOCALE_ENVFILE="/etc/env.d/02locale"
diff --git a/modules/modules.eselect b/modules/modules.eselect
index f664cee..40f1d19 100644
--- a/modules/modules.eselect
+++ b/modules/modules.eselect
@@ -5,8 +5,6 @@
DESCRIPTION="A module for querying modules. By default, it lists all available modules"
MAINTAINER="eselect@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}" )
DEFAULT_ACTION="list"
diff --git a/modules/news.eselect b/modules/news.eselect
index e156b7e..552d906 100644
--- a/modules/news.eselect
+++ b/modules/news.eselect
@@ -7,8 +7,6 @@ inherit package-manager
DESCRIPTION="Read Gentoo (\"GLEP 42\") news items"
MAINTAINER="ulm@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}")
NEWS_DIR="/var/lib/gentoo/news"
diff --git a/modules/pager.eselect b/modules/pager.eselect
index 2a4db05..5af5e7c 100644
--- a/modules/pager.eselect
+++ b/modules/pager.eselect
@@ -11,5 +11,3 @@ inherit editor-variable
DESCRIPTION="Manage the ${EDITOR_VAR} environment variable"
MAINTAINER="ulm@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}")
diff --git a/modules/profile.eselect b/modules/profile.eselect
index 3b4f930..02b21f3 100644
--- a/modules/profile.eselect
+++ b/modules/profile.eselect
@@ -8,8 +8,6 @@ inherit package-manager
DESCRIPTION="Manage the make.profile symlink"
MAINTAINER="eselect@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}")
DEFAULT_REPO="gentoo"
diff --git a/modules/rc.eselect b/modules/rc.eselect
index 6ada703..a905b3c 100644
--- a/modules/rc.eselect
+++ b/modules/rc.eselect
@@ -7,8 +7,6 @@ inherit config
DESCRIPTION="Manage /etc/init.d scripts in runlevels"
MAINTAINER="eselect@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}")
# source_rc_functions PRIVATE
# API for OpenRC or baselayout-1
diff --git a/modules/visual.eselect b/modules/visual.eselect
index ec3c610..87a7033 100644
--- a/modules/visual.eselect
+++ b/modules/visual.eselect
@@ -15,5 +15,3 @@ inherit editor-variable
DESCRIPTION="Manage the ${EDITOR_VAR} environment variable"
MAINTAINER="ulm@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}")