summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikoli <nikoli@lavabit.com>2011-01-02 02:21:37 +0300
committerNikoli <nikoli@lavabit.com>2011-01-02 02:21:37 +0300
commit33d15fb8809511a43f96450ba0d277a5e87d2018 (patch)
tree3d57e128225614bf49734915e7e9f98d8903f455 /games-fps
parentfteqcc-xonotic: initial ebuild (diff)
downloadgamerlay-33d15fb8809511a43f96450ba0d277a5e87d2018.tar.gz
gamerlay-33d15fb8809511a43f96450ba0d277a5e87d2018.tar.bz2
gamerlay-33d15fb8809511a43f96450ba0d277a5e87d2018.zip
xonotic: fix live ebuild
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/xonotic/ChangeLog5
-rw-r--r--games-fps/xonotic/Manifest4
-rw-r--r--games-fps/xonotic/xonotic-9999.ebuild67
3 files changed, 26 insertions, 50 deletions
diff --git a/games-fps/xonotic/ChangeLog b/games-fps/xonotic/ChangeLog
index 2579938..e2e3b4f 100644
--- a/games-fps/xonotic/ChangeLog
+++ b/games-fps/xonotic/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for games-fps/xonotic
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 01 Jan 2011; Nikoli <nikoli@lavabit.com> xonotic-9999.ebuild:
+ fix live ebuild
+
*xonotic-0.1.0_pre (30 Dec 2010)
30 Dec 2010; Nikoli <nikoli@lavabit.com> +xonotic-0.1.0_pre.ebuild:
diff --git a/games-fps/xonotic/Manifest b/games-fps/xonotic/Manifest
index 812ef12..77690a1 100644
--- a/games-fps/xonotic/Manifest
+++ b/games-fps/xonotic/Manifest
@@ -1,5 +1,5 @@
DIST xonotic-0.1.0preview.zip 1386789859 RMD160 abcf512141e9aab970ff0a91c0c0d02ac8a3b4b9 SHA1 debda2b012e6cf423fe61435f02226746fdaf9fb SHA256 7f86a9e87d050cc490fb15e3e27142a8c2522ad84907d78dadc294bf7a687b0d
EBUILD xonotic-0.1.0_pre.ebuild 3197 RMD160 0eff02d0edd3a9d2a9e44c50e915d6c9ebe2d008 SHA1 bf2a83a4fcd3865200a4e52789a2c4459fc38665 SHA256 4e1e7c51ad9a16666ddc46fe12ae063344bcf56dca1155601286dc88cf90e0ff
-EBUILD xonotic-9999.ebuild 6014 RMD160 5891a6ec26bd6f53df0ee83dafad684bd7d998df SHA1 4d345ed6949fc4a0428c9197acfa4e38bbc92b91 SHA256 8b2f9f44f700b5de7c4ead74d9d931f02bf8baa767b79aa655786403d0f5c7d0
-MISC ChangeLog 375 RMD160 aa9a42b850f0ba02590c36741cd6e303cc894bb1 SHA1 fcfc15e5ce701e9f3ebbdc9fd1128468f7d82fb6 SHA256 b7ad1568efbf86e28f9a69a563ccae031bcce7c33f2e4f0ebd5d3072848844af
+EBUILD xonotic-9999.ebuild 5477 RMD160 5f27a8fe967bbe1b4f920e5fad6d53cfca3785dd SHA1 54af37960259fe70c8e7ecf943465d549659fe74 SHA256 cb65296679f3471d830bab1ebc04fcd5694eda43327c9118e5e723470f7731d0
+MISC ChangeLog 458 RMD160 ce0da0586438b4e574253486edb04a13869dcaef SHA1 cd201fb67f29327b341f55f55a6c899b980b12ac SHA256 70eb358cab715a5cf20407b898fef702fd59aa15b1fe58e8e402ffad063c13ff
MISC metadata.xml 328 RMD160 c9a2ca482764130c8dc652b4be738d01f9cba4dc SHA1 f550b5afab2dd44ee6151c2d406208a018e73d19 SHA256 32d1d058d941314aa0097412ca00f5ff8e51ce484d11169ca070b67f4643a095
diff --git a/games-fps/xonotic/xonotic-9999.ebuild b/games-fps/xonotic/xonotic-9999.ebuild
index 376a3d5..1312568 100644
--- a/games-fps/xonotic/xonotic-9999.ebuild
+++ b/games-fps/xonotic/xonotic-9999.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI=2
inherit eutils games toolchain-funcs check-reqs git
MY_PN="${PN^}"
DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
HOMEPAGE="http://www.xonotic.org/"
-BASE_URI="git://git.${PN}.org/${PN}/"
+BASE_URI="git://git.xonotic.org/${PN}/"
EGIT_REPO_URI="${BASE_URI}${PN}.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="alsa debug dedicated opengl sdl +zip"
+IUSE="alsa crypt debug dedicated opengl sdl +zip"
UIRDEPEND="
media-libs/libogg
@@ -33,6 +33,7 @@ UIRDEPEND="
alsa? ( media-libs/alsa-lib )
sdl? ( media-libs/libsdl[X,audio,joystick,opengl,video,alsa?] )
"
+# s3tc? ( dev-libs/libtxc_dxtn )
UIDEPEND="
x11-proto/xextproto
x11-proto/xf86dgaproto
@@ -44,10 +45,12 @@ RDEPEND="
media-libs/jpeg
media-libs/libpng
net-misc/curl
+ ~dev-libs/d0_blind_id-${PV}[crypt?]
opengl? ( ${UIRDEPEND} )
!dedicated? ( !opengl? ( ${UIRDEPEND} ) )
"
DEPEND="${RDEPEND}
+ ~games-util/fteqcc-xonotic-9999
zip? ( app-arch/p7zip )
opengl? ( ${UIDEPEND} )
!dedicated? ( !opengl? ( ${UIDEPEND} ) )
@@ -70,11 +73,11 @@ pkg_setup() {
}
git_pk3_unpack() {
- EGIT_REPO_URI="${BASE_URI}xonotic-${1}.pk3dir.git"
- EGIT_PROJECT="${PN}-${1}.pk3dir"
- S+="/data/${PN}-${1}.pk3dir"
+ EGIT_REPO_URI="${BASE_URI}xonotic-${1}.pk3dir.git" \
+ EGIT_PROJECT="${PN}-${1}.pk3dir" \
+ S="${S}/data/${PN}-${1}.pk3dir" \
+ EGIT_BRANCH="master" \
git_fetch
- S="${WORKDIR}/${P}"
}
src_unpack() {
@@ -82,20 +85,11 @@ src_unpack() {
git_src_unpack
# Engine
- EGIT_REPO_URI="${BASE_URI}darkplaces.git"
- EGIT_PROJECT="darkplaces"
- S+="/darkplaces"
- # comment next line if you prefer unstable
+ EGIT_REPO_URI="${BASE_URI}darkplaces.git" \
+ EGIT_PROJECT="darkplaces" \
+ S="${S}/darkplaces" \
EGIT_BRANCH="div0-stable" \
git_fetch
- S="${WORKDIR}/${P}"
-
- # QC compiler
- EGIT_REPO_URI="git://github.com/Blub/qclib.git"
- EGIT_PROJECT="qclib"
- S+="/fteqcc"
- git_fetch
- S="${WORKDIR}/${P}"
# Data
git_pk3_unpack data
@@ -110,9 +104,12 @@ src_unpack() {
}
src_prepare() {
- # for darkplaces and fteqcc
+ # for darkplaces
tc-export CC
+ # use system libs
+ rm -rf misc/buildfiles/
+
# Engine
pushd darkplaces
sed -i \
@@ -126,26 +123,6 @@ src_prepare() {
sed -e "/DEFAULT_SNDAPI/s:ALSA:OSS:" \
-i makefile || die "sed failed"
fi
-
- # rebranding, suddenly it works fine
- for i in nexuiz.*; do
- mv -v "${i}" "${i/nexuiz/${PN}}" || die "mv failed"
- done
- sed -i \
- -e "s/nexuiz/${PN}/g" \
- -e "s/Nexuiz/${PN^}/g" \
- -e "s/NEXUIZ/${PN^^}/g" \
- $(find -type f ! -name '*makefile*') || die "sed failed"
- popd
-
- # QC compiler
- pushd fteqcc
- sed -i \
- -e '/^CC/d' \
- -e "s: -O3 : :g" \
- -e "s: -s : :g" \
- -e 's/-o fteqcc.bin/$(LDFLAGS) -o fteqcc.bin/' \
- Makefile || die "sed failed"
popd
# Data
@@ -202,18 +179,14 @@ src_compile() {
fi
popd
- # QC compiler
- pushd fteqcc
- emake BASE_CFLAGS="${CFLAGS} -Wall" || die "emake fteqcc failed"
- popd
-
# Data
pushd data/xonotic-data.pk3dir
emake \
- FTEQCC="${S}/fteqcc/fteqcc.bin" \
+ FTEQCC="/usr/bin/fteqcc-xonotic" \
FTEQCCFLAGS_WATERMARK='' \
|| die "emake data.pk3 failed"
popd
+ sh misc/tools/xonotic-map-compiler-autobuild download
}
src_install() {