summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikoli <nikoli@lavabit.com>2011-01-18 01:41:56 +0300
committerNikoli <nikoli@lavabit.com>2011-01-18 01:41:56 +0300
commit44204764e49c6a7cdd70ddd76eeec441d09d759a (patch)
tree5edc44766b4d02e7018561e4c366c678ca843030 /games-fps
parent[games-simulation/fgrun] simplify fltk dep (diff)
downloadgamerlay-44204764e49c6a7cdd70ddd76eeec441d09d759a.tar.gz
gamerlay-44204764e49c6a7cdd70ddd76eeec441d09d759a.tar.bz2
gamerlay-44204764e49c6a7cdd70ddd76eeec441d09d759a.zip
xonotic: move *.pk3 to xonotic-data package, cosmetics
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/xonotic-data/ChangeLog10
-rw-r--r--games-fps/xonotic-data/Manifest3
-rw-r--r--games-fps/xonotic-data/metadata.xml14
-rw-r--r--games-fps/xonotic-data/xonotic-data-9999.ebuild144
-rw-r--r--games-fps/xonotic/ChangeLog4
-rw-r--r--games-fps/xonotic/Manifest8
-rw-r--r--games-fps/xonotic/metadata.xml4
-rw-r--r--games-fps/xonotic/xonotic-0.1.0_pre.ebuild10
-rw-r--r--games-fps/xonotic/xonotic-9999.ebuild119
9 files changed, 192 insertions, 124 deletions
diff --git a/games-fps/xonotic-data/ChangeLog b/games-fps/xonotic-data/ChangeLog
new file mode 100644
index 0000000..f521590
--- /dev/null
+++ b/games-fps/xonotic-data/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-fps/xonotic-data
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*xonotic-data-9999 (17 Jan 2011)
+
+ 17 Jan 2011; Nikoli <nikoli@lavabit.com> +xonotic-data-9999.ebuild,
+ +metadata.xml:
+ initial ebuild
+
diff --git a/games-fps/xonotic-data/Manifest b/games-fps/xonotic-data/Manifest
new file mode 100644
index 0000000..225a610
--- /dev/null
+++ b/games-fps/xonotic-data/Manifest
@@ -0,0 +1,3 @@
+EBUILD xonotic-data-9999.ebuild 3132 RMD160 d3055bfae6c5b31b2dcb31cebce2425431342ad7 SHA1 2105f8513be551dcdd892b27db27fe0c1892afd2 SHA256 bfe1665159a1e4b6728b1bd5e4ed5c82d05f2bdb7eba6a3de32611fe0f18ab62
+MISC ChangeLog 262 RMD160 51e22029be52a9b81c7e6162cf5a7ed166471a43 SHA1 116eaa1db6c7d10cce6e99e2b136f0b4133bf6b5 SHA256 eeaa809356bbf326814be955dd8f76ee9bb484a5f3cd278d64879c365a1ec24e
+MISC metadata.xml 464 RMD160 86d7fbea6edcba6452d3581044ca1a1a77239da5 SHA1 4615957949527226200e033661405ed8459f498d SHA256 d9a07557c99e4b12bafbb7f547ee63cf6d9931e4a8a47e2a5a5bbefc89097af2
diff --git a/games-fps/xonotic-data/metadata.xml b/games-fps/xonotic-data/metadata.xml
new file mode 100644
index 0000000..9533e9d
--- /dev/null
+++ b/games-fps/xonotic-data/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>nikoli@lavabit.com</email>
+ <name>Nikoli</name>
+ </maintainer>
+ <use>
+ <flag name="client">Install files for client. Disabling is experimental.</flag>
+ <flag name="maps">Download and install maps.</flag>
+ <flag name="zip">Compress resources dirs in zip archives.</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-fps/xonotic-data/xonotic-data-9999.ebuild b/games-fps/xonotic-data/xonotic-data-9999.ebuild
new file mode 100644
index 0000000..667f6f5
--- /dev/null
+++ b/games-fps/xonotic-data/xonotic-data-9999.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit games check-reqs git
+
+MY_PN="${PN%-data}"
+DESCRIPTION="Xonotic data files"
+HOMEPAGE="http://www.xonotic.org/"
+BASE_URI="git://git.xonotic.org/${MY_PN}/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+client +maps +zip"
+
+RDEPEND=""
+DEPEND="
+ ~games-util/fteqcc-xonotic-9999
+ zip? ( app-arch/p7zip )
+"
+
+pkg_setup() {
+ if use !client; then
+ ewarn "You have disabled client USE flag, only files for server will be installed."
+ ewarn "This feature is experimental, if anything goes wrong, contact the maintainer."
+ echo
+ fi
+
+ ewarn "You need 1,5 Gb diskspace for distfiles."
+ if use !client; then
+ CHECKREQS_DISK_BUILD="3000"
+ CHECKREQS_DISK_USR="320"
+ else
+ if use zip; then
+ CHECKREQS_DISK_BUILD="3850"
+ CHECKREQS_DISK_USR="1830"
+ else
+ CHECKREQS_DISK_BUILD="7020"
+ CHECKREQS_DISK_USR="3520"
+ fi
+ fi
+ check_reqs
+}
+
+git_pk3_unpack() {
+ EGIT_REPO_URI="${BASE_URI}xonotic-${1}.pk3dir.git" \
+ EGIT_PROJECT="${MY_PN}-${1}.pk3dir" \
+ S="${S}/data/${MY_PN}-${1}.pk3dir" \
+ EGIT_BRANCH="master" \
+ git_fetch
+}
+
+src_unpack() {
+ # Data
+ git_pk3_unpack data
+ git_pk3_unpack maps
+ # needed only for client
+ if use client; then
+ git_pk3_unpack music
+ git_pk3_unpack nexcompat
+ else
+ rm -rf "${S}/data/font-dejavu.pk3dir" || die "rm failed"
+ fi
+ if use maps; then
+ cd "${S}/data"
+ wget \
+ -r -l1 --no-parent --no-directories \
+ -A "*-full.pk3" \
+ "http://beta.xonotic.org/autobuild-bsp/latest"
+ fi
+}
+
+src_prepare() {
+ # Data
+ if use !client; then
+ pushd data
+ rm -rf \
+ xonotic-data.pk3dir/gfx \
+ xonotic-data.pk3dir/particles \
+ xonotic-data.pk3dir/sound/cyberparcour01/rocket.txt \
+ xonotic-data.pk3dir/textures \
+ xonotic-maps.pk3dir/textures \
+ || die "rm failed"
+ rm -f \
+ $(find -type f -name '*.jpg') \
+ $(find -type f -name '*.png' ! -name 'sky??.png') \
+ $(find -type f -name '*.svg') \
+ $(find -type f -name '*.tga') \
+ $(find -type f -name '*.wav') \
+ $(find -type f -name '*.ogg') \
+ $(find -type f -name '*.ase') \
+ $(find -type f -name '*.map') \
+ $(find -type f -name '*.zym') \
+ $(find -type f -name '*.obj') \
+ $(find -type f -name '*.blend') \
+ || die "rm failed"
+ find -type d \
+ -exec rmdir '{}' &>/dev/null \;
+ sed -i \
+ -e '/^qc-recursive:/s/menu.dat//' \
+ xonotic-data.pk3dir/Makefile || die "sed failed"
+ popd
+ fi
+}
+
+src_compile() {
+ # Data
+ pushd data/xonotic-data.pk3dir
+ emake \
+ FTEQCC="/usr/bin/fteqcc-xonotic" \
+ FTEQCCFLAGS_WATERMARK='' \
+ || die "emake data.pk3 failed"
+ popd
+}
+
+src_install() {
+ # Data
+ cd data
+ rm -rf \
+ $(find -name '.git*') \
+ $(find -type d -name '.svn') \
+ $(find -type d -name 'qcsrc') \
+ $(find -type f -name '*.sh') \
+ $(find -type f -name '*.pl') \
+ $(find -type f -name 'Makefile') \
+ || die "rm failed"
+
+ if use zip; then
+ for d in *.pk3dir; do
+ pushd "${d}"
+ 7za a -tzip "../${d%dir}" . || die "zip failed"
+ popd
+ rm -rf "${d}" || die "rm failed"
+ done
+ fi
+
+ insinto "${GAMES_DATADIR}/${MY_PN}/data"
+ doins -r . || die "doins data failed"
+
+ prepgamesdirs
+}
diff --git a/games-fps/xonotic/ChangeLog b/games-fps/xonotic/ChangeLog
index e2e3b4f..ca39392 100644
--- a/games-fps/xonotic/ChangeLog
+++ b/games-fps/xonotic/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 17 Jan 2011; Nikoli <nikoli@lavabit.com> xonotic-0.1.0_pre.ebuild,
+ xonotic-9999.ebuild, metadata.xml:
+ move *.pk3 to xonotic-data package, cosmetics
+
01 Jan 2011; Nikoli <nikoli@lavabit.com> xonotic-9999.ebuild:
fix live ebuild
diff --git a/games-fps/xonotic/Manifest b/games-fps/xonotic/Manifest
index 9b3f8f1..43322ab 100644
--- a/games-fps/xonotic/Manifest
+++ b/games-fps/xonotic/Manifest
@@ -1,5 +1,5 @@
DIST xonotic-0.1.0preview.zip 1386789859 RMD160 abcf512141e9aab970ff0a91c0c0d02ac8a3b4b9 SHA1 debda2b012e6cf423fe61435f02226746fdaf9fb SHA256 7f86a9e87d050cc490fb15e3e27142a8c2522ad84907d78dadc294bf7a687b0d
-EBUILD xonotic-0.1.0_pre.ebuild 3197 RMD160 0eff02d0edd3a9d2a9e44c50e915d6c9ebe2d008 SHA1 bf2a83a4fcd3865200a4e52789a2c4459fc38665 SHA256 4e1e7c51ad9a16666ddc46fe12ae063344bcf56dca1155601286dc88cf90e0ff
-EBUILD xonotic-9999.ebuild 5589 RMD160 465b28a5bb33f0af5a62775d5d91b404cac9799b SHA1 88ab3834e51e5627d99dd52a468a50bd723f6f2e SHA256 53760f50020e1c0c4992085c3fb88f56e348658de6365ee43c774dbf92da1241
-MISC ChangeLog 458 RMD160 ce0da0586438b4e574253486edb04a13869dcaef SHA1 cd201fb67f29327b341f55f55a6c899b980b12ac SHA256 70eb358cab715a5cf20407b898fef702fd59aa15b1fe58e8e402ffad063c13ff
-MISC metadata.xml 382 RMD160 3a5b38975546b50b1fbfb58cd5f6276111a710ad SHA1 4fddf5a266a9230d87903d9af0b8e7e440405dbe SHA256 b54470095e0eb93c37d24cd10c7cd6ba9d13124500e134b2cee9a8804c66366c
+EBUILD xonotic-0.1.0_pre.ebuild 3193 RMD160 7e06ad6af4895ad5b6e66c6c882577d74d3e2bf9 SHA1 cbb4886f7d58e686aad6a270f59830269c4736b5 SHA256 d27d8411f2446733c17a4365b5574eff1364127c24f01dfa6d1806ae21e79d2d
+EBUILD xonotic-9999.ebuild 3131 RMD160 b3bde10c81adf4d524cd6eea2c29ab26ddf052f4 SHA1 9d77c61bc9d293778703efca00f9975504576f99 SHA256 804d2432faf6dfac9740bf2aeee2b250363c7eb708b151297b2c2b5784e5d199
+MISC ChangeLog 613 RMD160 257b6b87ecacfa69baa674c10cd383b7ef73ef8d SHA1 223e1c7ea75a8939f02ffdf77c33e9655adb3c51 SHA256 df6cfffe3dcef960da698651d67be3bb070b28d6813e1b936c5fd27386f1fc24
+MISC metadata.xml 246 RMD160 fe65f53ca2aa31f6d8c4fc4ee289e6c67b53441f SHA1 15de876352ad307fca2fd3468eab43bf327ac848 SHA256 9ff4ee44fd0e30e11a2fc610b39ff825cc265c0ee045c18c1a5873e7b579f6e6
diff --git a/games-fps/xonotic/metadata.xml b/games-fps/xonotic/metadata.xml
index cb5affd..bbbc0be 100644
--- a/games-fps/xonotic/metadata.xml
+++ b/games-fps/xonotic/metadata.xml
@@ -6,8 +6,4 @@
<email>nikoli@lavabit.com</email>
<name>Nikoli</name>
</maintainer>
- <use>
- <flag name="maps">Download and install maps.</flag>
- <flag name="zip">Compress resources dirs in zip archives.</flag>
- </use>
</pkgmetadata>
diff --git a/games-fps/xonotic/xonotic-0.1.0_pre.ebuild b/games-fps/xonotic/xonotic-0.1.0_pre.ebuild
index b9ca260..79a5e85 100644
--- a/games-fps/xonotic/xonotic-0.1.0_pre.ebuild
+++ b/games-fps/xonotic/xonotic-0.1.0_pre.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -31,14 +31,14 @@ UIRDEPEND="
media-libs/freetype:2
alsa? ( media-libs/alsa-lib )
sdl? ( media-libs/libsdl[X,audio,joystick,opengl,video,alsa?] )
- "
+"
# s3tc? ( dev-libs/libtxc_dxtn )
UIDEPEND="
x11-proto/xextproto
x11-proto/xf86dgaproto
x11-proto/xf86vidmodeproto
x11-proto/xproto
- "
+"
RDEPEND="
sys-libs/zlib
media-libs/jpeg
@@ -47,11 +47,11 @@ RDEPEND="
~dev-libs/d0_blind_id-${PV}[crypt?]
opengl? ( ${UIRDEPEND} )
!dedicated? ( !opengl? ( ${UIRDEPEND} ) )
- "
+"
DEPEND="${RDEPEND}
opengl? ( ${UIDEPEND} )
!dedicated? ( !opengl? ( ${UIDEPEND} ) )
- "
+"
S="${WORKDIR}/${MY_PN}"
diff --git a/games-fps/xonotic/xonotic-9999.ebuild b/games-fps/xonotic/xonotic-9999.ebuild
index 114433e..c4ada1b 100644
--- a/games-fps/xonotic/xonotic-9999.ebuild
+++ b/games-fps/xonotic/xonotic-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=2
-inherit eutils games toolchain-funcs check-reqs git
+inherit eutils games toolchain-funcs git
MY_PN="${PN^}"
DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
@@ -15,7 +15,7 @@ EGIT_REPO_URI="${BASE_URI}${PN}.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="alsa crypt debug dedicated +maps opengl sdl +zip"
+IUSE="alsa crypt debug dedicated opengl sdl"
UIRDEPEND="
media-libs/libogg
@@ -30,55 +30,31 @@ UIRDEPEND="
x11-libs/libXxf86vm
virtual/opengl
media-libs/freetype:2
+ ~games-fps/xonotic-data-9999[client]
alsa? ( media-libs/alsa-lib )
sdl? ( media-libs/libsdl[X,audio,joystick,opengl,video,alsa?] )
- "
+"
# s3tc? ( dev-libs/libtxc_dxtn )
UIDEPEND="
x11-proto/xextproto
x11-proto/xf86dgaproto
x11-proto/xf86vidmodeproto
x11-proto/xproto
- "
+"
RDEPEND="
sys-libs/zlib
media-libs/jpeg
media-libs/libpng
net-misc/curl
~dev-libs/d0_blind_id-${PV}[crypt?]
+ ~games-fps/xonotic-data-9999
opengl? ( ${UIRDEPEND} )
!dedicated? ( !opengl? ( ${UIRDEPEND} ) )
- "
+"
DEPEND="${RDEPEND}
- ~games-util/fteqcc-xonotic-9999
- zip? ( app-arch/p7zip )
opengl? ( ${UIDEPEND} )
!dedicated? ( !opengl? ( ${UIDEPEND} ) )
- "
-
-pkg_setup() {
- ewarn "You need 1,5 Gb diskspace for distfiles."
- if use dedicated && use !opengl; then
- CHECKREQS_DISK_BUILD="1500"
- else
- if use zip; then
- CHECKREQS_DISK_BUILD="2650"
- CHECKREQS_DISK_USR="910"
- else
- CHECKREQS_DISK_BUILD="4800"
- CHECKREQS_DISK_USR="2400"
- fi
- fi
- check_reqs
-}
-
-git_pk3_unpack() {
- EGIT_REPO_URI="${BASE_URI}xonotic-${1}.pk3dir.git" \
- EGIT_PROJECT="${PN}-${1}.pk3dir" \
- S="${S}/data/${PN}-${1}.pk3dir" \
- EGIT_BRANCH="master" \
- git_fetch
-}
+"
src_unpack() {
# root
@@ -90,24 +66,6 @@ src_unpack() {
S="${S}/darkplaces" \
EGIT_BRANCH="div0-stable" \
git_fetch
-
- # Data
- git_pk3_unpack data
- git_pk3_unpack maps
- # needed only for client
- if use opengl || use !dedicated; then
- git_pk3_unpack music
- git_pk3_unpack nexcompat
- else
- rm -rf "${S}/data/font-dejavu.pk3dir" || die "rm failed"
- fi
- if use maps; then
- cd "${S}/data"
- wget \
- -r -l1 --no-parent --no-directories \
- -A "*-full.pk3" \
- "http://beta.xonotic.org/autobuild-bsp/latest"
- fi
}
src_prepare() {
@@ -131,37 +89,6 @@ src_prepare() {
-i makefile || die "sed failed"
fi
popd
-
- # Data
- if use dedicated && use !opengl; then
- pushd data
- rm -rf \
- xonotic-data.pk3dir/gfx \
- xonotic-data.pk3dir/particles \
- xonotic-data.pk3dir/sound/cyberparcour01/rocket.txt \
- xonotic-data.pk3dir/textures \
- xonotic-maps.pk3dir/textures \
- || die "rm failed"
- rm -f \
- $(find -type f -name '*.jpg') \
- $(find -type f -name '*.png' ! -name 'sky??.png') \
- $(find -type f -name '*.svg') \
- $(find -type f -name '*.tga') \
- $(find -type f -name '*.wav') \
- $(find -type f -name '*.ogg') \
- $(find -type f -name '*.ase') \
- $(find -type f -name '*.map') \
- $(find -type f -name '*.zym') \
- $(find -type f -name '*.obj') \
- $(find -type f -name '*.blend') \
- || die "rm failed"
- find -type d \
- -exec rmdir '{}' &>/dev/null \;
- sed -i \
- -e '/^qc-recursive:/s/menu.dat//' \
- xonotic-data.pk3dir/Makefile || die "sed failed"
- popd
- fi
}
src_compile() {
@@ -185,14 +112,6 @@ src_compile() {
emake sv-${ENGINEOPTS} || die "emake sv-${ENGINEOPTS} failed"
fi
popd
-
- # Data
- pushd data/xonotic-data.pk3dir
- emake \
- FTEQCC="/usr/bin/fteqcc-xonotic" \
- FTEQCCFLAGS_WATERMARK='' \
- || die "emake data.pk3 failed"
- popd
}
src_install() {
@@ -226,27 +145,5 @@ src_install() {
doins -r server || die "doins server failed"
fi
- # Data
- cd data
- rm -rf \
- $(find -name '.git*') \
- $(find -type d -name '.svn') \
- $(find -type d -name 'qcsrc') \
- $(find -type f -name '*.sh') \
- $(find -type f -name '*.pl') \
- $(find -type f -name 'Makefile') \
- || die "rm failed"
- if use zip; then
- for d in *.pk3dir; do
- pushd "${d}"
- a="${d#xonotic-}"
- 7za a -tzip -mx=9 "../${a%dir}" . || die "zip failed"
- popd
- rm -rf "${d}" || die "rm failed"
- done
- fi
- insinto "${GAMES_DATADIR}/${PN}/data"
- doins -r . || die "doins data failed"
-
prepgamesdirs
}