summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2015-06-21 02:32:23 +0500
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2015-06-21 02:32:23 +0500
commit718bd1d2cdd024fa340f4def1d1127681dfa5f09 (patch)
tree90d5dbbe99033263f61f9a87b3eec1848ba87dd6 /games-fps
parent[games-fps/brutal-doom] Bump to 20. (diff)
downloadgamerlay-718bd1d2cdd024fa340f4def1d1127681dfa5f09.tar.gz
gamerlay-718bd1d2cdd024fa340f4def1d1127681dfa5f09.tar.bz2
gamerlay-718bd1d2cdd024fa340f4def1d1127681dfa5f09.zip
[games-fps/zdoom] Some cleanup for zdoom
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/zdoom/zdoom-2.7.1.ebuild14
-rw-r--r--games-fps/zdoom/zdoom-9999.ebuild24
2 files changed, 19 insertions, 19 deletions
diff --git a/games-fps/zdoom/zdoom-2.7.1.ebuild b/games-fps/zdoom/zdoom-2.7.1.ebuild
index fa98fb8..bfdb12e 100644
--- a/games-fps/zdoom/zdoom-2.7.1.ebuild
+++ b/games-fps/zdoom/zdoom-2.7.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
inherit cmake-utils eutils games versionator unpacker
DESCRIPTION="ZDoom is an enhanced port of the official DOOM source code"
@@ -12,18 +12,18 @@ SRC_URI="http://www.zdoom.org/files/${PN}/$(get_version_component_range 1-2)/${P
LICENSE="BSD BUILD DOOM"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="gtk mmx"
+IUSE="cpu_flags_x86_mmx gtk"
RDEPEND="app-arch/bzip2
- media-libs/fmod
+ media-libs/fmod:1
media-libs/libsdl:0
media-sound/fluidsynth
sys-libs/zlib
- virtual/jpeg
+ virtual/jpeg:0
x11-libs/libXcursor
gtk? ( x11-libs/gtk+:2 )"
DEPEND="${RDEPEND}
- mmx? ( || ( dev-lang/nasm dev-lang/yasm ) )"
+ cpu_flags_x86_mmx? ( || ( dev-lang/nasm dev-lang/yasm ) )"
S="${WORKDIR}"
@@ -44,7 +44,7 @@ src_configure() {
"-DFMOD_INCLUDE_DIR=/opt/fmodex/api/inc"
# "-DSHARE_DIR=\"${GAMES_DATADIR}/doom-data\""
$(cmake-utils_use_no gtk GTK)
- $(cmake-utils_use_no mmx ASM)
+ $(cmake-utils_use_no cpu_flags_x86_mmx ASM)
)
cmake-utils_src_configure
}
diff --git a/games-fps/zdoom/zdoom-9999.ebuild b/games-fps/zdoom/zdoom-9999.ebuild
index fe53db0..ec827c8 100644
--- a/games-fps/zdoom/zdoom-9999.ebuild
+++ b/games-fps/zdoom/zdoom-9999.ebuild
@@ -1,29 +1,29 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
-inherit cmake-utils eutils games subversion
+EAPI=5
+inherit cmake-utils eutils games git-2
DESCRIPTION="ZDoom is an enhanced port of the official DOOM source code"
HOMEPAGE="http://www.zdoom.org"
-ESVN_REPO_URI="http://mancubus.net/svn/hosted/zdoom/zdoom/trunk"
+EGIT_REPO_URI="https://github.com/rheit/zdoom"
#SRC_URI="http://www.zdoom.org/files/${PN}/2.5/${P}-src.7z"
LICENSE="BSD BUILD DOOM"
SLOT="0"
KEYWORDS=""
-IUSE="gtk mmx"
+IUSE="cpu_flags_x86_mmx gtk"
RDEPEND="app-arch/bzip2
- media-libs/fmod
+ media-libs/fmod:1
media-sound/fluidsynth
sys-libs/zlib
- virtual/jpeg
+ virtual/jpeg:0
x11-libs/libXcursor
gtk? ( x11-libs/gtk+:2 )"
DEPEND="${RDEPEND}
- mmx? ( || ( dev-lang/nasm dev-lang/yasm ) )"
+ cpu_flags_x86_mmx? ( || ( dev-lang/nasm dev-lang/yasm ) )"
S="${WORKDIR}"
@@ -33,9 +33,9 @@ src_prepare() {
-e "s:\(set( MAJOR_VERSIONS\):\1 \"40\" \"38\":" \
src/CMakeLists.txt || die
# Use default game data path
- sed -i \
- -e "s:/usr/local/share/:${GAMES_DATADIR}/doom-data/:" \
- src/sdl/i_system.h || die "sed i_system.h failed"
+# sed -i \
+# -e "s:/usr/local/share/:${GAMES_DATADIR}/doom-data/:" \
+# src/sdl/i_system.h || die "sed i_system.h failed"
}
src_configure() {
@@ -44,7 +44,7 @@ src_configure() {
"-DFMOD_INCLUDE_DIR=/opt/fmodex/api/inc"
# "-DSHARE_DIR=\"${GAMES_DATADIR}/doom-data\""
$(cmake-utils_use_no gtk GTK)
- $(cmake-utils_use_no mmx ASM)
+ $(cmake-utils_use_no cpu_flags_x86_mmx ASM)
)
cmake-utils_src_configure
}