summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2012-08-13 13:28:32 +0600
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2012-08-13 13:28:32 +0600
commitd6efe99622af994cc514c1d1ed8c91ad7c6515e0 (patch)
treea1d79cb15be1007736330bd40a22c48b26c7d966 /games-fps
parent[games-action/voxatron] Version bump to 0.2.1. (diff)
downloadgamerlay-d6efe99622af994cc514c1d1ed8c91ad7c6515e0.tar.gz
gamerlay-d6efe99622af994cc514c1d1ed8c91ad7c6515e0.tar.bz2
gamerlay-d6efe99622af994cc514c1d1ed8c91ad7c6515e0.zip
[games-fps/dhewm3] Port of Doom3, initial commit.
(Portage version: 2.1.11.9/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/dhewm3/Manifest2
-rw-r--r--games-fps/dhewm3/dhewm3-9999.ebuild81
-rw-r--r--games-fps/dhewm3/metadata.xml21
3 files changed, 104 insertions, 0 deletions
diff --git a/games-fps/dhewm3/Manifest b/games-fps/dhewm3/Manifest
new file mode 100644
index 0000000..6fd2f99
--- /dev/null
+++ b/games-fps/dhewm3/Manifest
@@ -0,0 +1,2 @@
+EBUILD dhewm3-9999.ebuild 1970 SHA256 04b07b77f5dadf5a35f4163072108091dedf99b740dd4bdc1ce1e13dcb0b8ba5 SHA512 48181ffefda2403d0970778e2c39cb76910d50fcd86a2325d399bf32ed292370cce600ad690100cda030179e1c68f29d352a1dd26e06e557be8cd9214909ea03 WHIRLPOOL c94233fc4b287a37023f252298487773b7683bd853716afa410be281648a965cb913dd8b309e025a93e4f207097df7acad9564803f3328fad24edc9c49d487bc
+MISC metadata.xml 784 SHA256 a8b8906251ba457ea05106fca6a9bc55d95f8c5c3bfb8cb823d25c510f2a01a3 SHA512 ae1965935b8b569955a69c22e288d1aecdc23a79a45fcf761c66ed6644df722d966a4e1e428c4f33d79198cd66905b128a3c25e414d415909cb60fa87cbfece9 WHIRLPOOL fc8932a6cf1c18d5d6e781df20f5e82474d950031ce2c940c2bc26fed4a9162832371d6dd3fe79cbce45b5b9bf3f18d3921fa85fa885e13291ac1e4f6b0bca5f
diff --git a/games-fps/dhewm3/dhewm3-9999.ebuild b/games-fps/dhewm3/dhewm3-9999.ebuild
new file mode 100644
index 0000000..7cd4e0c
--- /dev/null
+++ b/games-fps/dhewm3/dhewm3-9999.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit cmake-utils games git-2
+
+DESCRIPTION="A Doom 3 GPL source modification."
+HOMEPAGE="https://github.com/dhewm/dhewm3"
+#SRC_URI="mirror://gentoo/doom3.png"
+EGIT_REPO_URI="https://github.com/dhewm/dhewm3.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="cdinstall curl dedicated roe"
+
+# TODO There declared SDL2 support...
+DEPEND="virtual/jpeg
+ media-libs/libogg
+ >=media-libs/libsdl-1.2
+ media-libs/libvorbis
+ media-libs/openal
+ curl? ( net-misc/curl )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ cdinstall? (
+ >=games-fps/doom3-data-1.1.1282-r1
+ roe? ( games-fps/doom3-roe )
+ )"
+
+CMAKE_USE_DIR="${S}/neo"
+
+src_prepare() {
+ sed -i -e 's:\(${CMAKE_INSTALL_FULL_DATADIR}\)/dhewm3:\1:' neo/CMakeLists.txt
+}
+
+src_configure() {
+ # TODO There declared SDL2 support...
+ mycmakeargs=(
+ "-DDEDICATED=ON"
+ $(cmake-utils_use_disable dedicated CORE)
+ $(cmake-utils_use_disable dedicated BASE)
+ $(cmake-utils_use_disable dedicated D3XP)
+ "-DCMAKE_INSTALL_BINDIR=${GAMES_BINDIR}"
+ "-DCMAKE_INSTALL_DATADIR=${GAMES_DATADIR}/doom3"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README.md" cmake-utils_src_install
+# newicon doom3.png ${PN}.png
+# make_desktop_entry ${PN} "Doom 3 - dhewm"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! use cdinstall; then
+ elog "You need to copy *.pk4 from either your installation media or your hard drive to"
+ elog "${GAMES_DATADIR}/doom3/base before running the game,"
+ elog "or 'emerge games-fps/doom3-data' to install from CD."
+ echo
+ if use roe ; then
+ elog "To use the Resurrection of Evil expansion pack, you also need to copy *.pk4"
+ elog "to ${GAMES_DATADIR}/doom3/d3xp from the RoE CD before running the game,"
+ elog "or 'emerge doom3-roe' to install from CD."
+ fi
+ fi
+
+ echo
+ elog "To play the game, run:"
+ elog " ${PN}"
+ echo
+}
diff --git a/games-fps/dhewm3/metadata.xml b/games-fps/dhewm3/metadata.xml
new file mode 100644
index 0000000..c1e1824
--- /dev/null
+++ b/games-fps/dhewm3/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>azamat.hackimov@gmail.com</email>
+<name>Azamat H. Hackimov</name>
+</maintainer>
+<longdescription lang="en">
+A Doom 3 GPL source modification.
+Compared to the original DOOM 3, the changes of dhewm 3 worth mentioning are:
+ * 64bit port
+ * SDL for low level OS support, OpenGL and input handling
+ * OpenAL for audio output, all OS specific audio backends are gone
+ * OpenAL EFX for EAX reverb effects (read: EAX on all platforms)
+ * A portable build system based on CMake
+ * (Cross-)compilation with mingw-w64
+</longdescription>
+<use>
+ <flag name="roe">Adds support for the Resurrection of Evil expansion</flag>
+</use>
+</pkgmetadata>