summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2013-03-06 20:55:54 +0600
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2013-03-06 20:55:54 +0600
commitdcb10d75c657671a180a638661cc7e8c4f6b778f (patch)
treee5400be663d9e7cc27a23b2ad28cd69d753a00d9 /games-fps
parent[dev-games/gmqcc] Strip strict -Werror cflag, ebuild cleanup. (diff)
downloadgamerlay-dcb10d75c657671a180a638661cc7e8c4f6b778f.tar.gz
gamerlay-dcb10d75c657671a180a638661cc7e8c4f6b778f.tar.bz2
gamerlay-dcb10d75c657671a180a638661cc7e8c4f6b778f.zip
[games-fps/xonotic-data] Refresh ebuild, fix QA warnings for req-check.
Package-Manager: portage-2.1.11.52 Manifest-Sign-Key: A018DE8C
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/xonotic-data/ChangeLog7
-rw-r--r--games-fps/xonotic-data/xonotic-data-9999.ebuild33
2 files changed, 20 insertions, 20 deletions
diff --git a/games-fps/xonotic-data/ChangeLog b/games-fps/xonotic-data/ChangeLog
index 265ecb1..14b2c92 100644
--- a/games-fps/xonotic-data/ChangeLog
+++ b/games-fps/xonotic-data/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for games-fps/xonotic-data
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 06 Mar 2013; Azamat H. Hackimov <azamat.hackimov@gmail.com>
+ xonotic-data-9999.ebuild:
+ [games-fps/xonotic-data] Refresh ebuild, fix QA warnings for req-check.
+
06 Jul 2011; Nikoli <nikoli@lavabit.com> xonotic-data-9999.ebuild:
fix store dir
@@ -20,4 +24,3 @@
17 Jan 2011; Nikoli <nikoli@lavabit.com> +xonotic-data-9999.ebuild,
+metadata.xml:
initial ebuild
-
diff --git a/games-fps/xonotic-data/xonotic-data-9999.ebuild b/games-fps/xonotic-data/xonotic-data-9999.ebuild
index 06b9354..3ce4766 100644
--- a/games-fps/xonotic-data/xonotic-data-9999.ebuild
+++ b/games-fps/xonotic-data/xonotic-data-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=5
inherit games check-reqs git-2
@@ -28,9 +28,20 @@ DEPEND="
"
PDEPEND="maps? ( ~games-fps/xonotic-maps-9999 )"
-pkg_setup() {
- games_pkg_setup
+if use !client; then
+ CHECKREQS_DISK_BUILD="3000M"
+ CHECKREQS_DISK_USR="320M"
+else
+ if use zip; then
+ CHECKREQS_DISK_BUILD="3850M"
+ CHECKREQS_DISK_USR="1830M"
+ else
+ CHECKREQS_DISK_BUILD="7020M"
+ CHECKREQS_DISK_USR="3520M"
+ fi
+fi
+pkg_setup() {
if use convert; then
ewarn "cached-converter.sh will use \"xonotic-cached-converter\" subdirectory of your DISTDIR"
echo
@@ -41,21 +52,7 @@ pkg_setup() {
ewarn "This feature is experimental, if anything goes wrong, contact the maintainer."
echo
fi
-
- ewarn "You need 1,5 Gb diskspace for distfiles."
- if use !client; then
- CHECKREQS_DISK_BUILD="3000"
- CHECKREQS_DISK_USR="320"
- else
- if use zip; then
- CHECKREQS_DISK_BUILD="3850"
- CHECKREQS_DISK_USR="1830"
- else
- CHECKREQS_DISK_BUILD="7020"
- CHECKREQS_DISK_USR="3520"
- fi
- fi
- check_reqs
+ check-reqs_pkg_setup
}
git_pk3_unpack() {