summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikoli <nikoli@lavabit.com>2011-01-04 23:38:55 +0300
committerNikoli <nikoli@lavabit.com>2011-01-04 23:38:55 +0300
commite452eee0d2841920fa3c91ed4a3b0fa17a46f2e2 (patch)
tree5326c51131f4f8a9ce6c9a68bfa127326958f06b /games-fps
parentRevert "[dev-games/simgear] move to cmake build system" (diff)
downloadgamerlay-e452eee0d2841920fa3c91ed4a3b0fa17a46f2e2.tar.gz
gamerlay-e452eee0d2841920fa3c91ed4a3b0fa17a46f2e2.tar.bz2
gamerlay-e452eee0d2841920fa3c91ed4a3b0fa17a46f2e2.zip
xonotic: download maps in src_unpack, make it optional
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/xonotic/Manifest4
-rw-r--r--games-fps/xonotic/metadata.xml1
-rw-r--r--games-fps/xonotic/xonotic-9999.ebuild7
3 files changed, 8 insertions, 4 deletions
diff --git a/games-fps/xonotic/Manifest b/games-fps/xonotic/Manifest
index 77690a1..16c60ef 100644
--- a/games-fps/xonotic/Manifest
+++ b/games-fps/xonotic/Manifest
@@ -1,5 +1,5 @@
DIST xonotic-0.1.0preview.zip 1386789859 RMD160 abcf512141e9aab970ff0a91c0c0d02ac8a3b4b9 SHA1 debda2b012e6cf423fe61435f02226746fdaf9fb SHA256 7f86a9e87d050cc490fb15e3e27142a8c2522ad84907d78dadc294bf7a687b0d
EBUILD xonotic-0.1.0_pre.ebuild 3197 RMD160 0eff02d0edd3a9d2a9e44c50e915d6c9ebe2d008 SHA1 bf2a83a4fcd3865200a4e52789a2c4459fc38665 SHA256 4e1e7c51ad9a16666ddc46fe12ae063344bcf56dca1155601286dc88cf90e0ff
-EBUILD xonotic-9999.ebuild 5477 RMD160 5f27a8fe967bbe1b4f920e5fad6d53cfca3785dd SHA1 54af37960259fe70c8e7ecf943465d549659fe74 SHA256 cb65296679f3471d830bab1ebc04fcd5694eda43327c9118e5e723470f7731d0
+EBUILD xonotic-9999.ebuild 5526 RMD160 b654ebb6a7cde9023dfd26e28b30dd3dd3b3e316 SHA1 9b3e0591543b155694588b479f31e43c73d5bfb8 SHA256 de067c855be5b9f78cbfd40d3c98a02ae820b1321a76d17615d9bd23fb91a899
MISC ChangeLog 458 RMD160 ce0da0586438b4e574253486edb04a13869dcaef SHA1 cd201fb67f29327b341f55f55a6c899b980b12ac SHA256 70eb358cab715a5cf20407b898fef702fd59aa15b1fe58e8e402ffad063c13ff
-MISC metadata.xml 328 RMD160 c9a2ca482764130c8dc652b4be738d01f9cba4dc SHA1 f550b5afab2dd44ee6151c2d406208a018e73d19 SHA256 32d1d058d941314aa0097412ca00f5ff8e51ce484d11169ca070b67f4643a095
+MISC metadata.xml 382 RMD160 3a5b38975546b50b1fbfb58cd5f6276111a710ad SHA1 4fddf5a266a9230d87903d9af0b8e7e440405dbe SHA256 b54470095e0eb93c37d24cd10c7cd6ba9d13124500e134b2cee9a8804c66366c
diff --git a/games-fps/xonotic/metadata.xml b/games-fps/xonotic/metadata.xml
index dd02719..cb5affd 100644
--- a/games-fps/xonotic/metadata.xml
+++ b/games-fps/xonotic/metadata.xml
@@ -7,6 +7,7 @@
<name>Nikoli</name>
</maintainer>
<use>
+ <flag name="maps">Download and install maps.</flag>
<flag name="zip">Compress resources dirs in zip archives.</flag>
</use>
</pkgmetadata>
diff --git a/games-fps/xonotic/xonotic-9999.ebuild b/games-fps/xonotic/xonotic-9999.ebuild
index 1312568..317905f 100644
--- a/games-fps/xonotic/xonotic-9999.ebuild
+++ b/games-fps/xonotic/xonotic-9999.ebuild
@@ -15,7 +15,7 @@ EGIT_REPO_URI="${BASE_URI}${PN}.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="alsa crypt debug dedicated opengl sdl +zip"
+IUSE="alsa crypt debug dedicated +maps opengl sdl +zip"
UIRDEPEND="
media-libs/libogg
@@ -101,6 +101,10 @@ src_unpack() {
else
rm -rf "${S}/data/font-dejavu.pk3dir" || die "rm failed"
fi
+ if use maps; then
+ cd "${S}"
+ sh misc/tools/xonotic-map-compiler-autobuild download || die
+ fi
}
src_prepare() {
@@ -186,7 +190,6 @@ src_compile() {
FTEQCCFLAGS_WATERMARK='' \
|| die "emake data.pk3 failed"
popd
- sh misc/tools/xonotic-map-compiler-autobuild download
}
src_install() {