summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2017-06-11 19:51:05 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2017-06-11 19:51:05 +0700
commit1a6728700335798eb4e12dd988fc4685b0cd5c7e (patch)
tree4394c77c85614df795c0718cfbc5bb6c61bdbfa7 /games-rpg/unepic
parentfgrun: not needed anymore (diff)
downloadgamerlay-1a6728700335798eb4e12dd988fc4685b0cd5c7e.tar.gz
gamerlay-1a6728700335798eb4e12dd988fc4685b0cd5c7e.tar.bz2
gamerlay-1a6728700335798eb4e12dd988fc4685b0cd5c7e.zip
unepic: add
Diffstat (limited to 'games-rpg/unepic')
-rw-r--r--games-rpg/unepic/Manifest2
-rw-r--r--games-rpg/unepic/unepic-1.50.05.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/games-rpg/unepic/Manifest b/games-rpg/unepic/Manifest
new file mode 100644
index 0000000..f0a4a37
--- /dev/null
+++ b/games-rpg/unepic/Manifest
@@ -0,0 +1,2 @@
+DIST gog_unepic_2.1.0.4.sh 324964803 SHA256 5781c21967bac142b1518d6ffa000f4d5501c40c60ddfd6d1c3605dec3e63050 SHA512 c8c7b0f2c2bf61c4602721fbfc4e05f61f22e4ad97902b5ecb8aac020cae7d10560bcd874569d7cc68d27e0c7c2a02865e7374a5773902cee4c01b5f34c1628b WHIRLPOOL 2a0c6b075704211b4315b821bdc7eb8d48852065ffcab283ec43f7cc9be4d3df845d0645878e1cdb90675104527d13ac92722f0234fe9ee43d2e7ef36fb5a660
+DIST unepic-15005.run 323583549 SHA256 11866de3bfdcac950c5bc29b6b5ff807e64307afef0b7f642378ccfcf2a073c8 SHA512 1a63273248bfd77763723c8f9c0e6bdef9531b87ffd979eb9e3e7930076c5d2b2d72a1c9a3ef5c12692b8c33ad4eb03b76235bdddf9ceba7970a6e5734f1ba08 WHIRLPOOL 9fdc0727a2764e30f84a9765be6dad311eb1741bdde539a9db130e1180d5040cbc11366e8a70a23c19304409219af3c64ed0674c3c2a1c3d7551849e7b311aa7
diff --git a/games-rpg/unepic/unepic-1.50.05.ebuild b/games-rpg/unepic/unepic-1.50.05.ebuild
new file mode 100644
index 0000000..5eaab4b
--- /dev/null
+++ b/games-rpg/unepic/unepic-1.50.05.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+HB_VERSION="${PV//\.}"
+GOG_VERSION="2.1.0.4"
+
+DESCRIPTION="A combination of platformer and role playing game"
+HOMEPAGE="http://www.unepicgame.com/"
+SRC_URI="
+ hb? ( ${PN}-${HB_VERSION}.run )
+ gog? ( gog_${PN}_${GOG_VERSION}.sh )
+"
+
+RESTRICT="fetch strip"
+LICENSE="EULA"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="hb gog"
+REQUIRED_USE="^^ ( hb gog )"
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ media-libs/libsdl2
+ media-libs/mesa
+ media-libs/sdl2-mixer
+ sys-libs/glibc
+ sys-libs/zlib
+"
+
+
+pkg_setup() {
+ ewarn "Just be noticed, that both variants (GOG and HumbleBundle)"
+ ewarn "have game binaries linked with relative path in DT_RPATH."
+ ewarn "That means that it is pretty easy to preload any badware"
+ ewarn "library to it by just putting in in current working dir,"
+ ewarn "where you run the game from"
+ ewarn ""
+ ewarn "Portage will trigger bold red warnings about that on install phase."
+}
+
+pkg_nofetch() {
+ einfo ""
+ einfo "Please buy and download \"${A}\" from corresponding shop (HumbleBundle or GOG)"
+ einfo "and move/link it to \"${DISTDIR}\""
+ einfo "You can get more info on ${HOMEPAGE}"
+ einfo ""
+}
+
+src_unpack() {
+ einfo "\nUnpacking files. This can take several minutes.\n"
+
+ mkdir "${WORKDIR}/tmp" || die "mkdir 'tmp' failed"
+ cd "${WORKDIR}/tmp" || die "cd 'tmp' failed"
+
+ unzip -q "${DISTDIR}/${A}"
+
+ local gpath;
+ use gog && gpath="data/noarch/game"
+ use hb && gpath="data"
+
+ rm "${gpath}"/lib* -r
+ mv "${gpath}" "${S}"
+
+ cd "${S}" && rm -r "${WORKDIR}/tmp"
+}
+
+src_install() {
+ local dir="/usr/share/${PF}"
+ insinto "${dir}"
+ exeinto "${dir}"
+
+ doins -r .
+ doexe "${PN}"{32,64}* ${PN}.sh || die "Failed to install executables"
+
+ doicon "${PN}.png"
+ make_wrapper "${PN}" "./${PN}.sh" "${dir}"
+ make_desktop_entry "${PN}" "${PN^}" "${PN}" || die "make_desktop_entry failed"
+}
+
+pkg_postinst() {
+ einfo "Just in case: neither of these DRM-free versions sees Steam's savegames."
+ einfo "In case, if you played in Steam and moved to DRM-free version,"
+ einfo "consider copying files from:"
+ einfo "~/.local/share/Steam/userdata/[your_user_id]/233980/remote/save"
+ einfo "to:"
+ einfo "~/.local/share/Unepic/unepic/save"
+ einfo "and vice versa if you want to import DRM-free saves to Steam."
+ einfo "Although, it can cause sudden game freezes..."
+}