aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-02-20 15:54:32 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-02-20 15:54:32 +0000
commit27169ea233d396ef54e3306a6a152e00421e8fc0 (patch)
treeaba0deec0807d4764394d29cf6595282277b018d
parentDon't mark LDFLAGS as an error in make.conf, patch by Erik Hahn in bug 253401 (diff)
downloadgentoo-syntax-27169ea233d396ef54e3306a6a152e00421e8fc0.tar.gz
gentoo-syntax-27169ea233d396ef54e3306a6a152e00421e8fc0.tar.bz2
gentoo-syntax-27169ea233d396ef54e3306a6a152e00421e8fc0.zip
Use svn2cl in make dist now, so remove the changelog portion in doc/ because it is outdated anywaygentoo-syntax-20090220
svn path=/trunk/gentoo-syntax/; revision=59
-rw-r--r--Makefile2
-rw-r--r--doc/gentoo-syntax.txt382
2 files changed, 2 insertions, 382 deletions
diff --git a/Makefile b/Makefile
index bec848e..28542e4 100644
--- a/Makefile
+++ b/Makefile
@@ -82,6 +82,8 @@ uninstall-file-%: $(subst _,/,$*)
dist:
mkdir "$(distpkg)"
$(MAKE) PREFIX="$(distpkg)" install
+ svn2cl
+ mv ChangeLog "$(distpkg)/"
cp README "$(distpkg)/"
tar jcf "$(distpkg).tar.bz2" "$(distpkg)"
rm -fr "$(distpkg)/"
diff --git a/doc/gentoo-syntax.txt b/doc/gentoo-syntax.txt
index 2748c0f..0435a4c 100644
--- a/doc/gentoo-syntax.txt
+++ b/doc/gentoo-syntax.txt
@@ -38,8 +38,6 @@ Authors: Ciaran McCreesh <ciaranm at gentoo dot org>
New init.d Files |new-init.d|
New Metadata |new-metadata|
- 3. ChangeLog |gentoo-syntax-changelog|
-
==============================================================================
2. Plugin Information *gentoo-syntax-overview*
@@ -270,384 +268,4 @@ Authors: Ciaran McCreesh <ciaranm at gentoo dot org>
Note: metadata.xml files may not be detected automatically. The
|:NewMetadata| command will still work in these situations.
-==============================================================================
-3. ChangeLog *gentoo-syntax-changelog*
-
- 20070514 pioto
- * Add VIM_PLUGIN_VIM_VERSION to the app-vim/ ebuild template.
- * Add g:loaded_* guard variables to plugin/* to prevent loading
- them more than once. This makes it easier to test them by adding
- them to your ~/.vim/ directory w/o having to remove the
- system-wide ones.
-
- 20070506 pioto
- * Eclasses don't need to specify ECLASS or INHERITED anymore. See
- Bug #175135.
- * Split off eselect-specific stuff into the eselect-syntax
- package, and portage configuration stuff into portage-syntax.
- * Don't use GNU-specific date --iso in the Makefile, and be sure
- that the version stamp is always from UTC.
- * Hilight usage of the `which` command as an error. People should
- use the bash builtin type -P instead. See Bug #176218.
- * Release new version.
-
- 20070212 pioto
- * Release new version.
-
- 20070212 pioto
- * Make gentoo-use-desc.vim accept USE flags as specified by PMS.
-
- 20070212 pioto
- * Make gentoo-use-desc.vim accept qualified package names
- according to the upcoming PMS standard (allow + in PN, for
- example).
-
- 20070212 pioto
- * Patch to hilight on USE_EXPAND variables in make.conf. See
- Bug #164588.
-
- 20070212 pioto
- * Patch to update java ebuild template to use the new generation 2
- java eclasses. See Bug #164953.
-
- 20070130 pioto
- * Patch to add hilighting for elog and the autotools.eclass. See
- Bug #164312.
-
- 20061106 pioto
- * Release new version.
-
- 20061105 pioto
- * Update GuideXML support. See Bug #145999
-
- 20061105 pioto
- * Make package.* files' syntax accept category names without a '-'
- in them. See Bug #122890
-
- 20061105 pioto
- * Apply patch from tupone to fix newmetadata (Formerly known as
- the 20051221-r1 release).
-
- 20051221 ciaranm (Release)
- * INSTALL_MASK in make.conf.
-
- 20051016 ciaranm
- * Fix package.use flags that start with a number.
-
- 20050622 rphillips
- * added g:ebuild_create_on_empty option to toggle new ebuild
- creation on/off. Fixes #96659
- * have newebuild.vim check to see if vimdiff is the program name
- and automatically disable new ebuild creation
-
- 20050618 ka0ttic (Release)
- * Updated eutils, multilib, flag-o-matic, webapp, games eclass
- functions.
- * Added pam, virtualx, gnome2 eclass functions.
- * Fixed MakeNewEselectModule() to a) not print the errant
- '@gentoo.org' and b) to only use the maintainer's email address,
- not all of ECHANGELOG_USER.
-
- 20050615 beu
- * s/eclectic/eselect/g
- * Use GentooGetUser() function for the local-part of MAINTAINER
- when creating a boiler-plate eselect module.
- * Use the 'Id' keyword instead of 'Header' in eselect module
- headers.
-
- 20050515 beu
- * Testing, testing .. Fix a 'few' typo's in syntax/eclectic.vim.
-
- 20050515 ciaranm (Release)
- * Better indenting for eclectic modules.
-
- 20050514 beu
- * Add dev-perl specific inherit of perl-module.
-
- 20050514 ciaranm
- * Highlighting in make.conf for ccache and distcc variables.
- Gentoo bug 92238 <http://bugs.gentoo.org/show_bug.cgi?id=92238>
-
- 20050511 beu
- * Add minimal support for eclectic-module filetype and syntax
- highlighting.
- * Add goodness to create boiler-plate eclectic modules on a new
- buffer ('*.eclectic').
- * add in support for SVN_DATE
-
- 20050510 ciaranm
- * ${PN}-${PV} in ebuilds is an error, should be ${P} (requested by
- seemant).
- * Better heading highlighting for GLEPs.
- * Much smarter cat/pkg detection.
-
- 20050415 beu
- * Add support for apache-module and depend.apache eclass functions.
- * Add a default setup for apache-module ebuilds (ebuilds in
- www-apache/mod_name).
-
- 20050326 ciaranm
- * Add PORTAGE_TMPFS to make.conf highlighting.
-
- 20050325 ciaranm
- * Add ALSA_CARDS to make.conf highlighting.
-
- 20050325 ciaranm (Release)
- * Make this lot work properly with vim 6.3 again. Oops.
-
- 20050323 ciaranm
- * Better category / package distinction in new metadata creation
- plugin.
-
- 20050318 ciaranm (Release)
- * USERLAND in make.conf is an error. Recognise EXTRA_ECONF.
-
- 20050317 ciaranm
- * catmetadata support
- * Add in sanity checking. Check version and &compatible. Thanks to
- Rob Henderson in Gentoo bug #85425
- <http://bugs.gentoo.org/show_bug.cgi?id=85425>.
-
- 20050316 ka0ttic
- * Updated cron eclass functions.
- * Added support for distutils and perl-module eclasses.
-
- 20050305 ciaranm
- * x86-64, x86_64 in CFLAGS are errors.
- * -mvis in CFLAGS is an error.
- * on amd64, -Os -fPIC -fpic -DPIC in CFLAGS are errors.
-
- 20050303 ciaranm
- * dev.g.o in SRC_URI is wrong.
-
- 20050226 ciaranm
- * Make USE flags with _ in the name work properly.
-
- 20050221 ka0ttic
- * Removed useless newconfd plugin.
- * Fixed missing endif in ftdetect/gentoo.vim that caused some XML
- ftdetect funkyness.
-
- 20050216 ka0ttic
- * Updated cron and eutils eclass functions.
-
- 20050211 ciaranm (Release)
-
- 20050210 ciaranm
- * Move arch guessing code into gentoo-common.vim. Cache the
- results, since portageq is very slow. Changed the logic so that
- it should (probably) generate the correct values on non-Linux
- systems.
- * Fix detection of thirdpartymirrors file
-
- 20050207 ciaranm
- * Added ASFLAGS and ARCH to the make.conf error list.
-
- 20050202 ka0ttic
- * Added missing runscript shebang to init.d plugin.
-
- 20050201 ka0ttic
- * Updated bash-completion eclass functions.
-
- 20050130 ciaranm (Release)
- * Rewrite Makefile.
- * Update docs.
- * Improved init.d syntax highlighting.
- * Add in EXPORT_FUNCTIONS eclass highlighting.
-
- 20050128 ciaranm
- * Restructure plugins. Add in a gentoo-common.vim to reduce
- code duplication, and switch to using put ='' to insert text.
- * Updated years.
-
- 20050128 ka0ttic
- * Updated webapp eclass functions.
- * Added init.d/conf.d creation plugin.
-
- 20050125 ciaranm
- * Update versionator eclass functions.
- * Update eutils eclass functions.
- * Update flag-o-matic eclass functions.
-
- 20050125 ka0ttic
- * Added subversion eclass support.
- * Added alternatives eclass support.
- * Added rpm eclass support.
- * Added python eclass support.
- * Added check-kernel eclass support.
-
- 20050123 ciaranm
- * Add LINGUAS, INPUT_DEVICES, VIDEO_CARDS to make.conf
- highlighting.
-
- 20050122 ka0ttic
- * Added toolchain-funcs eclass support.
- * Added games eclass support.
- * Added cron eclass support.
-
- 20050122 tmartin
- * Added 64-bit eclass support.
- * Added multilib eclass support.
-
- 20050122 ciaranm
- * Added fdo-mime eclass support.
-
- 20050105 ciaranm
- * Add sandbox functions (addwrite etc) to the highlight list.
-
- 20041227 ciaranm (Release)
- * Make the arch detecting code work again with the new
- make.defaults setup.
-
- 20041220 ciaranm
- * An empty value for SLOT is an error in ebuilds. A * inside
- KEYWORDS is an error unless it is a -*.
- * -Wno* in CFLAGS is evil.
- * Initial attempt at folding for GLEPs.
-
- 20041218 ciaranm
- * Added games-* ebuild creation rules (requested by Michael
- Sterrett, dev-python (Bryan Oestergaard), dev-java (Thomas
- Matthijs).
- * Added 'set paste' whilst creating content, thanks to Thomas
- Matthijs for the bug report.
- * Make metadata syntax matching use the contained option, so that
- recognised words are only highlighted in the correct places.
- * Added guidexml syntax, thanks to Sven Vermeulen and Xavier Neys
- for information.
-
- 20041216 ciaranm
- * Improved glep syntax handling
-
- 20041205 ciaranm
- * metadata.xml support: recognise metadata.xml, set filetype
- settings, fancy syntax highlighting based upon xml.vim, auto
- create metadata.xml content for new files based upon context.
-
- 20041202 ciaranm (Release)
- * Make newebuild also support eclass creation.
-
- 20041130 ciaranm
- * Fix menu handler. Thanks to Georgi Georgiev in Gentoo bug 72888
- <http://bugs.gentoo.org/show_bug.cgi?id=72888>.
-
- 20041127 ciaranm
- * Add in newebuild plugin which intelligently creates template
- content for new ebuilds based upon context.
-
- 20041127 ciaranm (Release)
- * BugSummary now provides :BugSummary and :BugDetails, with the
- <Leader>bug nmap mapped to :BugDetails.
- * Override sh.vim's handling of function names to include extra
- characters. Thanks to Thomas Kirchner in Gentoo bug 72469
- <http://bugs.gentoo.org/show_bug.cgi?id=72469>.
-
- 20041125 ciaranm
- * BugSummary plugin: massively faster parsing, recognise double
- quotes in bug text properly, display a menu thing allowing the
- user to open the bug in a browser / insert bug details, coloured
- display.
- * Use g: variables for settings
-
- 20041124 ciaranm
- * Add in bash-completion, vim-plugin, vim-doc eclasses.
- * Use "hi def link" rather than "hi link".
-
- 20041123 ciaranm
- * Recognise /etc/portage/mirrors as a mirrors file. Thanks to
- Georgi Georgiev in Gentoo bug 72228
- <http://bugs.gentoo.org/show_bug.cgi?id=72228>.
- * Syntax highlighting for use.desc, use.local.desc
- * Handle fancy characters in BugSummary better
-
- 20041122 ciaranm
- * Add in -s and -DNDEBUG to the bad CFLAGS list at solar's
- request.
- * :BugSummary, not :ShowBugSummary. Thanks to TGL in Gentoo bug
- 72001 <http://bugs.gentoo.org/show_bug.cgi?id=72001>.
- * LDFLAGS in make.conf is an error at vapier's request.
-
- 20041121 ciaranm (Release)
- * Handle * ~* in package.keywords
- * make.conf highlighting
- * Highlight stupid cat usage in ebuilds
- * Added bugsummary plugin -- either :BugSummary 12345 or move over
- a bug number and hit <Leader>bug in normal mode. Currently the
- code is rather messy and tied to Gentoo bugzilla.
-
- 20041114 ciaranm
- * Make ChangeLog highlighting less picky about entries where the
- developer hasn't quite got their ECHANGELOG_USER right (for
- example, if they just have an email address without the angle
- brackets). Thanks to Thomas Matthijs in Gentoo bug 71164
- <http://bugs.gentoo.org/show_bug.cgi?id=71164>.
- * Make ChangeLog highlighting recognise dates which don't have a
- leading zero.
- * Ebuilds shouldn't be touching EXTRA_ECONF, make this show up as
- an error.
-
- 20041113 ciaranm (Release)
- * As per GLEP 31, fileencoding should be utf-8 for ebuilds and
- ChangeLogs.
- * Highlight as errors functions declared as "foo () {" (extra
- space, should be "foo() {". Similarly, "foo(){" needs a space
- before the curly bracket, "foo() {". Requested by Michael
- Sterrett.
- * Added in some new keywords. Thanks to Tom Martin in Gentoo bug
- 71065 <http://bugs.gentoo.org/show_bug.cgi?id=71065>.
- * Added in quiet and verbose variants for 'has' and 'use'.
-
- 20041107 ciaranm
- * Highlight TODO and FIXME items in GLEPs.
-
- 20041016 ciaranm
- * config is now called pkg_config. Thanks to Tom Martin in Gentoo
- bug 67807 <http://bugs.gentoo.org/show_bug.cgi?id=67807>.
-
- 20041009 ciaranm (Release)
- * Highlight src_unpack and similar recognised function names
- differently in ebuilds. Requested by Thomas Matthijs.
-
- 20041004 ciaranm
- * Better 'bug 1234' highlighting
-
- 20040919 ciaranm
- * Error on non GLEP 23 compliant LICENSEs
- * cvs.eclass support
-
- 20040911 ciaranm (Release)
- * Added versionator.eclass
-
- 20040908 ciaranm
- * Inherit from sh.vim in ftplugin/ebuild.vim
-
- 20040906 ciaranm (Release)
- * Update for recent eutils additions
- * Indenting for ebuilds / eclasses
- * Updated error highlighting
-
- 20040902 ciaranm
- * init.d, env.d, cron.d, conf.d highlighting.
- * package.mask, package.unmask, package.keywords, package.use,
- thirdpartymirrors highlighting.
-
- 20040901 ciaranm (Release)
- * ChangeLog support.
- * Use rst for GLEPs.
- * Added webapp.eclass, webapp-apache.eclass and fixheadtails.eclass
- syntax.
-
- 20040826 ciaranm
- * HOMEPAGE containing $ expressions is an error.
-
- 20040826 ciaranm (Release)
- * Massive rework. Far better file layouts, keyword support,
- filetype settings. Added a help doc.
- * Highlighting for errors in ebuilds.
- * Added gcc and libtool eclass support.
-
- 20040820 ciaranm
- * First usable release
-
-==============================================================================
vim:tw=78:ts=8:ft=help