summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek.chauhan@gmail.com>2008-09-25 09:51:15 +0530
committerNirbheek Chauhan <nirbheek.chauhan@gmail.com>2008-09-25 09:51:15 +0530
commitcc0f93f86f045aa9bc5ccd1bf126657e630ca9cb (patch)
tree4c18f683d0c561cfea9dcca64626875174d77c17 /x11-libs
parentAdd net-libs/libsoup-9999 (diff)
downloadgnome-live-cc0f93f86f045aa9bc5ccd1bf126657e630ca9cb.tar.gz
gnome-live-cc0f93f86f045aa9bc5ccd1bf126657e630ca9cb.tar.bz2
gnome-live-cc0f93f86f045aa9bc5ccd1bf126657e630ca9cb.zip
Add x11-libs/gtk+-9999
Arch-specific stuff and patches not added on purpose. Live ebuilds should be as vanilla as possible and fixes should be sent upstream. Only gentoo-specific build fixes can be added.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/Manifest1
-rw-r--r--x11-libs/gtk+/gtk+-9999.ebuild158
2 files changed, 159 insertions, 0 deletions
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
new file mode 100644
index 0000000..0410679
--- /dev/null
+++ b/x11-libs/gtk+/Manifest
@@ -0,0 +1 @@
+EBUILD gtk+-9999.ebuild 4084 RMD160 e624e458fab5fb22bbf78e8c8c74cc3d2743085d SHA1 192d8c1159f781fb4308f74de5b7ea5a0c2d3336 SHA256 e84c1a10ffdf92fe42d7d610ac379f9e2422cbe8415f4c49e0a70a1e8bf644ae
diff --git a/x11-libs/gtk+/gtk+-9999.ebuild b/x11-libs/gtk+/gtk+-9999.ebuild
new file mode 100644
index 0000000..9027ff6
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-9999.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnome2-live flag-o-matic virtualx
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="X cups debug doc jpeg tiff vim-syntax xinerama jasper"
+
+RDEPEND=">=dev-libs/glib-2.17.6
+ >=x11-libs/pango-1.20
+ >=dev-libs/atk-1.13
+ >=x11-libs/cairo-1.6
+ media-libs/fontconfig
+ x11-misc/shared-mime-info
+ >=media-libs/libpng-1.2.1
+ X? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ xinerama? ( x11-libs/libXinerama )
+ )
+ !X? ( dev-libs/DirectFB )
+ cups? ( net-print/cups )
+ jpeg? ( >=media-libs/jpeg-6b-r2 media-libs/jasper )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ !<gnome-base/gail-1000"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ X? (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/damageproto
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ doc? (
+ >=dev-util/gtk-doc-1.8
+ ~app-text/docbook-xml-dtd-4.1.2
+ )"
+PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
+
+pkg_setup() {
+ if use X ; then
+ if ! built_with_use x11-libs/cairo X; then
+ eerror "Please re-emerge x11-libs/cairo with the X USE flag set"
+ die "cairo needs the X flag set"
+ fi
+ else
+ if ! built_with_use x11-libs/cairo directfb ; then
+ eerror "Please re-emerge x11-libs/cairo with the directfb USE flag set"
+ die "cairo needs the directfb flag set"
+ fi
+ fi
+}
+
+set_gtk2_confdir() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0}
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # -O3 and company cause random crashes in applications. Bug #133469
+ replace-flags -O3 -O2
+ strip-flags
+
+ use ppc64 && append-flags -mminimal-toc
+}
+
+src_compile() {
+ local myconf= gdk_target=
+
+ if use X ; then
+ gdk_target=x11
+ else
+ gdk_target=directfb
+ fi
+
+ # png always on to display icons (foser)
+ myconf="$(use_enable doc gtk-doc)
+ $(use_with jpeg libjpeg)
+ $(use_with jpeg libjasper)
+ $(use_with tiff libtiff)
+ $(use_enable xinerama)
+ --with-libpng
+ --with-gdktarget=${gdk_target}
+ --with-xinput"
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_test() {
+ Xemake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ set_gtk2_confdir
+ dodir ${GTK2_CONFDIR}
+ keepdir ${GTK2_CONFDIR}
+
+ # see bug #133241
+ echo 'gtk-fallback-icon-theme = "gnome"' > "${D}/${GTK2_CONFDIR}/gtkrc"
+
+ # Enable xft in environment as suggested by <utx@gentoo.org>
+ dodir /etc/env.d
+ echo "GDK_USE_XFT=1" > "${D}/etc/env.d/50gtk2"
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+
+ # This has to be removed, because it's multilib specific; generated in
+ # postinst
+ rm "${D}/etc/gtk-2.0/gtk.immodules"
+}
+
+pkg_postinst() {
+ set_gtk2_confdir
+
+ if [ -d "${ROOT}${GTK2_CONFDIR}" ]; then
+ gtk-query-immodules-2.0 > "${ROOT}${GTK2_CONFDIR}/gtk.immodules"
+ gdk-pixbuf-query-loaders > "${ROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders"
+ else
+ ewarn "The destination path ${ROOT}${GTK2_CONFDIR} doesn't exist;"
+ ewarn "to complete the installation of GTK+, please create the"
+ ewarn "directory and then manually run:"
+ ewarn " cd ${ROOT}${GTK2_CONFDIR}"
+ ewarn " gtk-query-immodules-2.0 > gtk.immodules"
+ ewarn " gdk-pixbuf-query-loaders > gdk-pixbuf.loaders"
+ fi
+
+ if [ -e /usr/lib/gtk-2.0/2.[^1]* ]; then
+ elog "You need to rebuild ebuilds that installed into" /usr/lib/gtk-2.0/2.[^1]*
+ elog "to do that you can use qfile from portage-utils:"
+ elog "emerge -va1 \$(qfile -qC /usr/lib/gtk-2.0/2.[^1]*)"
+ fi
+
+ elog "Please install app-text/evince for print preview functionality"
+}