summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-03-26 12:36:45 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-03-26 13:49:39 +0530
commit4876bc6549c7bb8ee379c32b74310cd30ca95eca (patch)
tree800a20bf47c79904bdfc62f7f37111b2df03dafd
parentgnome-extra/gnome-boxes: 3.3.90 → 3.3.92 (diff)
downloadgnome-4876bc6549c7bb8ee379c32b74310cd30ca95eca.tar.gz
gnome-4876bc6549c7bb8ee379c32b74310cd30ca95eca.tar.bz2
gnome-4876bc6549c7bb8ee379c32b74310cd30ca95eca.zip
Add media-video/totem-3.3.92
-rw-r--r--media-video/totem/Manifest4
-rw-r--r--media-video/totem/totem-3.3.92.ebuild185
-rw-r--r--media-video/totem/totem-9999.ebuild53
3 files changed, 216 insertions, 26 deletions
diff --git a/media-video/totem/Manifest b/media-video/totem/Manifest
index 2015c856..02f3dd30 100644
--- a/media-video/totem/Manifest
+++ b/media-video/totem/Manifest
@@ -1 +1,3 @@
-EBUILD totem-9999.ebuild 5224 RMD160 26dfd296fba68c59de3663089482c57541c9e06c SHA1 3dc1d8f0798f9068321e5435ffcf4903fec1f5d2 SHA256 c261052cbf2e972264d2f897f5807817f249aca75d9418ad4a331ae84dd0b9cb
+DIST totem-3.3.92.tar.xz 3150836 RMD160 2b41cc70553cb2b001673b2be9eb714482c63925 SHA1 ace8e00539aacd4d2db8cf358f493e6fa0587e14 SHA256 d76180ddb0309ffff60a50b3df36ff3ba015380ae43b47748ed7c2d184a42382
+EBUILD totem-3.3.92.ebuild 5187 RMD160 47235fd8aafb8e82aa2d2e561fb1ad3c274616c0 SHA1 63da08628759e4e44f6c907556a8faff7eed51bb SHA256 a269e6ab2b379df92480ec39f56658712e4b2e3776b7f8fbe7a15f021822a635
+EBUILD totem-9999.ebuild 5187 RMD160 47235fd8aafb8e82aa2d2e561fb1ad3c274616c0 SHA1 63da08628759e4e44f6c907556a8faff7eed51bb SHA256 a269e6ab2b379df92480ec39f56658712e4b2e3776b7f8fbe7a15f021822a635
diff --git a/media-video/totem/totem-3.3.92.ebuild b/media-video/totem/totem-3.3.92.ebuild
new file mode 100644
index 00000000..f30d37ee
--- /dev/null
+++ b/media-video/totem/totem-3.3.92.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-3.2.2.ebuild,v 1.2 2012/02/20 08:18:35 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+WANT_AUTOMAKE="1.11"
+PYTHON_DEPEND="python? 2:2.5"
+PYTHON_USE_WITH="threads"
+PYTHON_USE_WITH_OPT="python"
+
+inherit gnome2 multilib python
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Media player for GNOME"
+HOMEPAGE="http://projects.gnome.org/totem/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+IUSE="doc grilo +introspection iplayer lirc nautilus nsplugin +python test vala
+zeitgeist zeroconf"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+fi
+
+# TODO:
+# Cone (VLC) plugin needs someone with the right setup (remi ?)
+# coherence plugin broken upstream
+#
+# FIXME: Automagic tracker-0.9.0
+# Runtime dependency on gnome-session-2.91
+RDEPEND=">=dev-libs/glib-2.27.92:2
+ >=x11-libs/gdk-pixbuf-2.23.0:2
+ >=x11-libs/gtk+-3.3.6:3[introspection?]
+ >=dev-libs/totem-pl-parser-2.32.4[introspection?]
+ >=dev-libs/libpeas-1.1.0[gtk]
+ >=x11-themes/gnome-icon-theme-2.16
+ x11-libs/cairo
+ >=dev-libs/libxml2-2.6:2
+ >=media-libs/clutter-1.6.8:1.0
+ >=media-libs/clutter-gst-1.3.9:1.0
+ >=media-libs/clutter-gtk-1.0.2:1.0
+ >=media-libs/gstreamer-0.10.30:0.10
+ >=media-libs/gst-plugins-base-0.10.30:0.10
+ x11-libs/mx:1.0
+
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-taglib:0.10
+ media-plugins/gst-plugins-gio:0.10
+ media-plugins/gst-plugins-pango:0.10
+ media-plugins/gst-plugins-x:0.10
+ media-plugins/gst-plugins-meta:0.10
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXtst
+ >=x11-libs/libXxf86vm-1.0.1
+ x11-themes/gnome-icon-theme-symbolic
+
+ grilo? ( >=media-libs/grilo-0.1.16 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+ lirc? ( app-misc/lirc )
+ nautilus? ( >=gnome-base/nautilus-2.91.3 )
+ nsplugin? (
+ >=dev-libs/dbus-glib-0.82
+ >=x11-misc/shared-mime-info-0.22 )
+ python? (
+ >=dev-libs/gobject-introspection-0.6.7
+ >=dev-python/pygobject-2.90.3:3
+ >=x11-libs/gtk+-2.91.7:3[introspection]
+ dev-python/pyxdg
+ dev-python/gst-python:0.10
+ dev-python/dbus-python
+ iplayer? (
+ dev-python/httplib2
+ dev-python/feedparser
+ dev-python/beautifulsoup ) )
+ vala? ( >=dev-lang/vala-0.14.2-r1:0.14 )
+ zeitgeist? ( dev-libs/libzeitgeist )
+ zeroconf? ( >net-libs/libepc-0.4.0 )"
+# XXX: zeroconf requires unreleased version of libepc
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ x11-proto/xproto
+ x11-proto/xextproto
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.20.3
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.20
+ app-text/docbook-xml-dtd:4.5
+ gnome-base/gnome-common
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.14 )
+ test? ( python? ( dev-python/pylint ) )"
+# docbook-xml-dtd is needed for user doc
+
+# see bug #359379
+REQUIRED_USE="python? ( introspection )
+ zeitgeist? ( vala )"
+
+# XXX: pylint checks fail because of bad code
+RESTRICT="test"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-run-in-source-tree
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --disable-static
+ --with-smclient=auto
+ --enable-easy-codec-installation
+ $(use_enable introspection)
+ $(use_enable nautilus)
+ $(use_enable nsplugin browser-plugins)
+ $(use_enable nsplugin vegas-plugin)
+ $(use_enable python)
+ $(use_enable python introspection)
+ $(use_enable vala)
+ VALAC=$(type -P valac-0.14)
+ BROWSER_PLUGIN_DIR=/usr/$(get_libdir)/nsbrowser/plugins"
+
+ if ! use test; then
+ # pylint is checked unconditionally, but is only used for make check
+ G2CONF="${G2CONF} PYLINT=$(type -P true)"
+ fi
+ #--with-smclient=auto needed to correctly link to libICE and libSM
+
+ # Disabled: sample-python, sample-vala, zeitgeist-dp
+ local plugins="brasero-disc-recorder,chapters,im-status,gromit"
+ plugins="${plugins},media-player-keys,ontop,properties,screensaver"
+ plugins="${plugins},screenshot,sidebar-test,skipto"
+ use grilo && plugins="${plugins},grilo"
+ use iplayer && plugins="${plugins},iplayer"
+ use lirc && plugins="${plugins},lirc"
+ use nautilus && plugins="${plugins},save-file"
+ use python && plugins="${plugins},dbusservice,pythonconsole,opensubtitles"
+ use vala && plugins="${plugins},rotation"
+ use zeitgeist && plugins="${plugins},zeitgeist-dp"
+ use zeroconf && plugins="${plugins},publish"
+
+ G2CONF="${G2CONF} --with-plugins=${plugins}"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # AC_CONFIG_AUX_DIR_DEFAULT doesn't exist, and eautoreconf/aclocal fails
+ mkdir -p m4
+
+ #if [[ ${PV} != 9999 ]]; then
+ # intltoolize --force --copy --automake || die "intltoolize failed"
+ # eautoreconf
+ #fi
+
+ use python && python_clean_py-compile_files
+
+ gnome2_src_prepare
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use python; then
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/totem/plugins
+ fi
+
+ ewarn
+ ewarn "If totem doesn't play some video format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ use python && python_mod_cleanup /usr/$(get_libdir)/totem/plugins
+}
diff --git a/media-video/totem/totem-9999.ebuild b/media-video/totem/totem-9999.ebuild
index cb30a791..f30d37ee 100644
--- a/media-video/totem/totem-9999.ebuild
+++ b/media-video/totem/totem-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-2.30.0-r1.ebuild,v 1.1 2010/06/13 20:36:55 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-3.2.2.ebuild,v 1.2 2012/02/20 08:18:35 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
@@ -20,23 +20,23 @@ HOMEPAGE="http://projects.gnome.org/totem/"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
+IUSE="doc grilo +introspection iplayer lirc nautilus nsplugin +python test vala
+zeitgeist zeroconf"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+ KEYWORDS="~amd64 ~x86 ~x86-fbsd"
fi
-IUSE="bluetooth doc grilo +introspection iplayer lirc nautilus nsplugin +python +youtube vala" # zeroconf
# TODO:
# Cone (VLC) plugin needs someone with the right setup (remi ?)
# coherence plugin broken upstream
#
# FIXME: Automagic tracker-0.9.0
-# XXX: Add Zeitgeist support when it gets added to GNOME 3 (3.2?)
# Runtime dependency on gnome-session-2.91
RDEPEND=">=dev-libs/glib-2.27.92:2
>=x11-libs/gdk-pixbuf-2.23.0:2
- >=x11-libs/gtk+-2.99.3:3[introspection?]
+ >=x11-libs/gtk+-3.3.6:3[introspection?]
>=dev-libs/totem-pl-parser-2.32.4[introspection?]
>=dev-libs/libpeas-1.1.0[gtk]
>=x11-themes/gnome-icon-theme-2.16
@@ -61,8 +61,8 @@ RDEPEND=">=dev-libs/glib-2.27.92:2
x11-libs/libX11
x11-libs/libXtst
>=x11-libs/libXxf86vm-1.0.1
+ x11-themes/gnome-icon-theme-symbolic
- bluetooth? ( net-wireless/bluez )
grilo? ( >=media-libs/grilo-0.1.16 )
introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
lirc? ( app-misc/lirc )
@@ -81,13 +81,9 @@ RDEPEND=">=dev-libs/glib-2.27.92:2
dev-python/httplib2
dev-python/feedparser
dev-python/beautifulsoup ) )
- vala? ( >=dev-lang/vala-0.12.1:0.12 )
- youtube? (
- >=dev-libs/libgdata-0.7.0
- net-libs/libsoup:2.4
- media-plugins/gst-plugins-soup:0.10
- >=dev-libs/totem-pl-parser-2.32.4[quvi] )"
-# zeroconf? ( >=net-libs/libepc-0.5.0 )
+ vala? ( >=dev-lang/vala-0.14.2-r1:0.14 )
+ zeitgeist? ( dev-libs/libzeitgeist )
+ zeroconf? ( >net-libs/libepc-0.4.0 )"
# XXX: zeroconf requires unreleased version of libepc
DEPEND="${RDEPEND}
@@ -101,11 +97,16 @@ DEPEND="${RDEPEND}
app-text/docbook-xml-dtd:4.5
gnome-base/gnome-common
dev-util/gtk-doc-am
- doc? ( >=dev-util/gtk-doc-1.14 )"
+ doc? ( >=dev-util/gtk-doc-1.14 )
+ test? ( python? ( dev-python/pylint ) )"
# docbook-xml-dtd is needed for user doc
# see bug #359379
-REQUIRED_USE="python? ( introspection )"
+REQUIRED_USE="python? ( introspection )
+ zeitgeist? ( vala )"
+
+# XXX: pylint checks fail because of bad code
+RESTRICT="test"
pkg_setup() {
DOCS="AUTHORS ChangeLog NEWS README TODO"
@@ -119,27 +120,31 @@ pkg_setup() {
$(use_enable introspection)
$(use_enable nautilus)
$(use_enable nsplugin browser-plugins)
+ $(use_enable nsplugin vegas-plugin)
$(use_enable python)
$(use_enable python introspection)
$(use_enable vala)
- VALAC=$(type -P valac-0.12)
+ VALAC=$(type -P valac-0.14)
BROWSER_PLUGIN_DIR=/usr/$(get_libdir)/nsbrowser/plugins"
+
+ if ! use test; then
+ # pylint is checked unconditionally, but is only used for make check
+ G2CONF="${G2CONF} PYLINT=$(type -P true)"
+ fi
#--with-smclient=auto needed to correctly link to libICE and libSM
# Disabled: sample-python, sample-vala, zeitgeist-dp
local plugins="brasero-disc-recorder,chapters,im-status,gromit"
plugins="${plugins},media-player-keys,ontop,properties,screensaver"
plugins="${plugins},screenshot,sidebar-test,skipto"
- use bluetooth && plugins="${plugins},bemused"
use grilo && plugins="${plugins},grilo"
use iplayer && plugins="${plugins},iplayer"
use lirc && plugins="${plugins},lirc"
use nautilus && plugins="${plugins},save-file"
use python && plugins="${plugins},dbusservice,pythonconsole,opensubtitles"
use vala && plugins="${plugins},rotation"
- use youtube && plugins="${plugins},youtube"
- # XXX: zeroconf requires unreleased version of libepc
- # use zeroconf && plugins="${plugins},publish"
+ use zeitgeist && plugins="${plugins},zeitgeist-dp"
+ use zeroconf && plugins="${plugins},publish"
G2CONF="${G2CONF} --with-plugins=${plugins}"
@@ -156,9 +161,7 @@ src_prepare() {
# eautoreconf
#fi
- # disable pyc compiling
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
+ use python && python_clean_py-compile_files
gnome2_src_prepare
}
@@ -178,5 +181,5 @@ pkg_postinst() {
pkg_postrm() {
gnome2_pkg_postrm
- python_mod_cleanup /usr/$(get_libdir)/totem/plugins
+ use python && python_mod_cleanup /usr/$(get_libdir)/totem/plugins
}