summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-03-25 11:06:01 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-03-26 13:49:37 +0530
commitc254937bcd719a9a20158952fd3476e9d1264068 (patch)
tree52a879026966b72570f271809ffa4daa7ac0ca83
parentgnome-base/gnome-keyring: 3.3.5 → 3.3.92 (diff)
downloadgnome-c254937bcd719a9a20158952fd3476e9d1264068.tar.gz
gnome-c254937bcd719a9a20158952fd3476e9d1264068.tar.bz2
gnome-c254937bcd719a9a20158952fd3476e9d1264068.zip
Add x11-wm/mutter-3.3.92
-rw-r--r--x11-wm/mutter/Manifest5
-rw-r--r--x11-wm/mutter/files/mutter-3.2.1-ignore-shadow-and-padding.patch91
-rw-r--r--x11-wm/mutter/mutter-3.3.92.ebuild87
-rw-r--r--x11-wm/mutter/mutter-9999.ebuild15
4 files changed, 194 insertions, 4 deletions
diff --git a/x11-wm/mutter/Manifest b/x11-wm/mutter/Manifest
index 13d25654..cbb7d0a7 100644
--- a/x11-wm/mutter/Manifest
+++ b/x11-wm/mutter/Manifest
@@ -1 +1,4 @@
-EBUILD mutter-9999.ebuild 1763 RMD160 24aae8664eea91ee714f819818415c920469537d SHA1 b1671f55af99d68796832930e9eda0cbdf369b8c SHA256 6183718efae5bc8bf516f50665eb8a7c2dda349288ae864194f4c101c3073eae
+AUX mutter-3.2.1-ignore-shadow-and-padding.patch 2640 RMD160 408acd936e0a474714ffaa3c4a0a5c17bcc160ca SHA1 3705a09d1160c6a7ace480c5f51a3c413ac52a0d SHA256 765c04ba4d177789407a25d3cbdf358e3fa125170cfd37c53095372bc4ec883d
+DIST mutter-3.3.92.tar.xz 1640400 RMD160 846b0a5ed2c09eb6a7b31744ccc0e1961249d8cf SHA1 9b94e0da4625b80c7d1a9ca9faaddb7c131bb2eb SHA256 fd31de6084dd5a11cfed5528af679e71f7a195267c5ac7705f2090c990b5c1f7
+EBUILD mutter-3.3.92.ebuild 2016 RMD160 7c77ef6e6732c9af188fd5df966447ca046a1d88 SHA1 1a508f50237ffd40c87292ccba3f740da2608930 SHA256 f6554f2fb33c3960f4460c5a6fd1e4437647727338fdc3196daf47a6fd7f0392
+EBUILD mutter-9999.ebuild 2016 RMD160 7c77ef6e6732c9af188fd5df966447ca046a1d88 SHA1 1a508f50237ffd40c87292ccba3f740da2608930 SHA256 f6554f2fb33c3960f4460c5a6fd1e4437647727338fdc3196daf47a6fd7f0392
diff --git a/x11-wm/mutter/files/mutter-3.2.1-ignore-shadow-and-padding.patch b/x11-wm/mutter/files/mutter-3.2.1-ignore-shadow-and-padding.patch
new file mode 100644
index 00000000..bf4649e7
--- /dev/null
+++ b/x11-wm/mutter/files/mutter-3.2.1-ignore-shadow-and-padding.patch
@@ -0,0 +1,91 @@
+Patch author: Timo Kluck <tkluck@infty.nl> Wed, 21 Sep 2011 17:51:28 +0200
+
+Patch to silently ignore padding and shadow tags in Ubuntu metacity themes.
+
+https://bugs.launchpad.net/bugs/800315
+https://bugs.gentoo.org/show_bug.cgi?id=396673
+
+diff --git a/src/ui/theme-parser.c b/src/ui/theme-parser.c
+index 9063541..63a881f 100644
+--- a/src/ui/theme-parser.c
++++ b/src/ui/theme-parser.c
+@@ -90,7 +90,9 @@ typedef enum
+ STATE_WINDOW,
+ /* things we don't use any more but we can still parse: */
+ STATE_MENU_ICON,
+- STATE_FALLBACK
++ STATE_FALLBACK,
++ /* an ubuntu specific ignore-this-element state */
++ UBUNTU_STATE_IGNORE
+ } ParseState;
+
+ typedef struct
+@@ -1306,7 +1308,19 @@ parse_toplevel_element (GMarkupParseContext *context,
+ */
+ push_state (info, STATE_FALLBACK);
+ }
+- else
++ else if (ELEMENT_IS ("shadow"))
++ {
++ /* ubuntu specific, workaround for light-themes: silently ignore shadow tag.
++ */
++ push_state (info, UBUNTU_STATE_IGNORE);
++ }
++ else if (ELEMENT_IS ("padding"))
++ {
++ /* ubuntu specific, workaround for light-themes: silently ignore padding tag.
++ */
++ push_state (info, UBUNTU_STATE_IGNORE);
++ }
++ else
+ {
+ set_error (error, context,
+ G_MARKUP_ERROR, G_MARKUP_ERROR_PARSE,
+@@ -3027,6 +3041,18 @@ parse_style_element (GMarkupParseContext *context,
+
+ push_state (info, STATE_BUTTON);
+ }
++ else if (ELEMENT_IS ("shadow"))
++ {
++ /* ubuntu specific, workaround for light-themes: silently ignore shadow tag.
++ */
++ push_state (info, UBUNTU_STATE_IGNORE);
++ }
++ else if (ELEMENT_IS ("padding"))
++ {
++ /* ubuntu specific, workaround for light-themes: silently ignore padding tag.
++ */
++ push_state (info, UBUNTU_STATE_IGNORE);
++ }
+ else
+ {
+ set_error (error, context,
+@@ -3671,6 +3697,8 @@ start_element_handler (GMarkupParseContext *context,
+ _("Element <%s> is not allowed inside a <%s> element"),
+ element_name, "fallback");
+ break;
++ case UBUNTU_STATE_IGNORE:
++ break;
+ }
+ }
+
+@@ -3960,6 +3988,9 @@ end_element_handler (GMarkupParseContext *context,
+ pop_state (info);
+ g_assert (peek_state (info) == STATE_THEME);
+ break;
++ case UBUNTU_STATE_IGNORE:
++ pop_state (info);
++ break;
+ }
+
+ pop_required_version (info);
+@@ -4165,6 +4196,9 @@ text_handler (GMarkupParseContext *context,
+ case STATE_FALLBACK:
+ NO_TEXT ("fallback");
+ break;
++ case UBUNTU_STATE_IGNORE:
++ NO_TEXT ("ignored_element");
++ break;
+ }
+ }
+
diff --git a/x11-wm/mutter/mutter-3.3.92.ebuild b/x11-wm/mutter/mutter-3.3.92.ebuild
new file mode 100644
index 00000000..414bbe39
--- /dev/null
+++ b/x11-wm/mutter/mutter-3.3.92.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="GNOME 3 compositing window manager based on Clutter"
+HOMEPAGE="http://git.gnome.org/browse/mutter/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+introspection test xinerama"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+COMMON_DEPEND=">=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.10[X]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.3.7:3[introspection?]
+ >=gnome-base/gconf-2:2
+ >=dev-libs/glib-2.25.11:2
+ >=media-libs/clutter-1.9.10:1.0
+ >=media-libs/cogl-1.9.6:1.0
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+ >=gnome-base/gsettings-desktop-schemas-3.3.0
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+
+ gnome-extra/zenity
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMON_DEPEND}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/expocity"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README *.txt doc/*.txt"
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-gconf
+ --enable-shape
+ --enable-sm
+ --enable-startup-notification
+ --enable-xsync
+ --enable-verbose-mode
+ --enable-compile-warnings=maximum
+ --with-libcanberra
+ $(use_enable introspection)
+ $(use_enable xinerama)"
+}
+
+src_prepare() {
+ # Compat with Ubuntu metacity themes (e.g. x11-themes/light-themes)
+ epatch "${FILESDIR}/${PN}-3.2.1-ignore-shadow-and-padding.patch"
+
+ gnome2_src_prepare
+}
diff --git a/x11-wm/mutter/mutter-9999.ebuild b/x11-wm/mutter/mutter-9999.ebuild
index 143a4235..414bbe39 100644
--- a/x11-wm/mutter/mutter-9999.ebuild
+++ b/x11-wm/mutter/mutter-9999.ebuild
@@ -26,13 +26,15 @@ fi
COMMON_DEPEND=">=x11-libs/pango-1.2[X,introspection?]
>=x11-libs/cairo-1.10[X]
x11-libs/gdk-pixbuf:2
- >=x11-libs/gtk+-2.91.7:3[introspection?]
+ >=x11-libs/gtk+-3.3.7:3[introspection?]
>=gnome-base/gconf-2:2
- >=dev-libs/glib-2.14:2
- >=media-libs/clutter-1.7.5:1.0
+ >=dev-libs/glib-2.25.11:2
+ >=media-libs/clutter-1.9.10:1.0
+ >=media-libs/cogl-1.9.6:1.0
>=media-libs/libcanberra-0.26[gtk3]
>=x11-libs/startup-notification-0.7
>=x11-libs/libXcomposite-0.2
+ >=gnome-base/gsettings-desktop-schemas-3.3.0
x11-libs/libICE
x11-libs/libSM
@@ -76,3 +78,10 @@ pkg_setup() {
$(use_enable introspection)
$(use_enable xinerama)"
}
+
+src_prepare() {
+ # Compat with Ubuntu metacity themes (e.g. x11-themes/light-themes)
+ epatch "${FILESDIR}/${PN}-3.2.1-ignore-shadow-and-padding.patch"
+
+ gnome2_src_prepare
+}