summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-03-26 11:17:46 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-03-26 13:49:38 +0530
commite0ce89576cad5ff9690504223e4f56f7bb2184d1 (patch)
tree05f2cf8e99aeabf54f136aa36221520381c44b75
parentAdd net-im/empathy-3.3.92 (diff)
downloadgnome-e0ce89576cad5ff9690504223e4f56f7bb2184d1.tar.gz
gnome-e0ce89576cad5ff9690504223e4f56f7bb2184d1.tar.bz2
gnome-e0ce89576cad5ff9690504223e4f56f7bb2184d1.zip
Add net-wireless/gnome-bluetooth-3.3.92
-rw-r--r--net-wireless/gnome-bluetooth/Manifest5
-rw-r--r--net-wireless/gnome-bluetooth/files/gnome-bluetooth-3.3.92-fix-makefile.patch25
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.3.92.ebuild95
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-9999.ebuild41
4 files changed, 142 insertions, 24 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index b0ba3cb2..39d9772b 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1,2 +1,5 @@
AUX 80-rfkill.rules 117 RMD160 78e948840a4359344d3bd565300e4432fe43bf91 SHA1 6a6b28aaf852aae9e419963ddbdb92092825f4ee SHA256 81b3a8a3a3639b6d6024043364ad4917b32a85fd7f766e4051211d388e165798
-EBUILD gnome-bluetooth-9999.ebuild 2530 RMD160 eaf6b8ee7b514c720e3b519a01f21c7a1d90894d SHA1 6c6978222f8f04cbefcca41b9f4d1916e9d76252 SHA256 7329b75291a76232e6283481cd8a67eb5ca059b72a98d31486c9bd32eb45bf9a
+AUX gnome-bluetooth-3.3.92-fix-makefile.patch 944 RMD160 e934b80ff46d600854a9c69c1afad4eec443d587 SHA1 cd3ad651ed1e3d8927baee19a8cbba73c1be04a3 SHA256 357f4abfc62da3a7e87bc815daf698f258135707bcf302e46f5b189fbdbeaf95
+DIST gnome-bluetooth-3.3.92.tar.xz 1129544 RMD160 fae16c7fbc66b12da8ff45f8ed92e2d316acbdb0 SHA1 bfcf127853bc357cf4e0b481f21e5141cbb48736 SHA256 081834f33a45829a108dab33e7d6bdeef9efdde9741bb55208327b38f425343c
+EBUILD gnome-bluetooth-3.3.92.ebuild 2340 RMD160 8a46904856d7581a79a1b97369183733aafbe582 SHA1 1ef42f3e4acd75516c9e4fc64a859a00fd807b51 SHA256 9bdfcb1ee2878bd0d90d171f20b3230c542283b2c0414c52d793b6af45a6d888
+EBUILD gnome-bluetooth-9999.ebuild 2340 RMD160 8a46904856d7581a79a1b97369183733aafbe582 SHA1 1ef42f3e4acd75516c9e4fc64a859a00fd807b51 SHA256 9bdfcb1ee2878bd0d90d171f20b3230c542283b2c0414c52d793b6af45a6d888
diff --git a/net-wireless/gnome-bluetooth/files/gnome-bluetooth-3.3.92-fix-makefile.patch b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-3.3.92-fix-makefile.patch
new file mode 100644
index 00000000..7e369e85
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-3.3.92-fix-makefile.patch
@@ -0,0 +1,25 @@
+From 94a23c3a5194d527aae993edbc68a50695a3f93e Mon Sep 17 00:00:00 2001
+From: Colin Walters <walters@verbum.org>
+Date: Tue, 20 Mar 2012 21:32:32 +0000
+Subject: applet: Fix Makefile rule to remove libgnome-bluetooth-applet.la
+
+1) We should be using install-exec-hook, not -data, since it's code
+2) Use -f to avoid erroring out if for some reason it's not found
+---
+diff --git a/applet/Makefile-lib.am b/applet/Makefile-lib.am
+index 375270c..251575d 100644
+--- a/applet/Makefile-lib.am
++++ b/applet/Makefile-lib.am
+@@ -13,8 +13,8 @@ libgnome_bluetooth_applet_la_LDFLAGS = -no-undefined
+
+ AM_CFLAGS = -I$(srcdir) -I$(top_srcdir)/lib $(LIBGNOMEBT_CFLAGS) $(WARN_CFLAGS) $(DISABLE_DEPRECATED)
+
+-install-data-hook:
+- rm $(DESTDIR)$(pkglibdir)/libgnome-bluetooth-applet.la
++install-exec-hook:
++ rm -f $(DESTDIR)$(pkglibdir)/libgnome-bluetooth-applet.la
+ uninstall-hook:
+ rm -f $(DESTDIR)$(pkglibdir)/libgnome-bluetooth-applet.so*
+
+--
+cgit v0.9.0.2
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.3.92.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.3.92.ebuild
new file mode 100644
index 00000000..e3c11030
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.3.92.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/gnome-bluetooth-3.2.2.ebuild,v 1.2 2012/02/14 05:02:43 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2 multilib
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Fork of bluez-gnome focused on integration with GNOME"
+HOMEPAGE="http://live.gnome.org/GnomeBluetooth"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="2"
+IUSE="doc +introspection sendto"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+COMMON_DEPEND=">=dev-libs/glib-2.29.90:2
+ >=x11-libs/gtk+-2.91.3:3[introspection?]
+ >=x11-libs/libnotify-0.7.0
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ sendto? ( >=gnome-extra/nautilus-sendto-2.91 )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=net-wireless/bluez-4.34
+ app-mobilephone/obexd
+ sys-fs/udev
+ x11-themes/gnome-icon-theme-symbolic"
+# To break circular dependencies
+PDEPEND=">=gnome-base/gnome-control-center-2.91"
+DEPEND="${COMMON_DEPEND}
+ !net-wireless/bluez-gnome
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/gnome-doc-utils
+ app-text/scrollkeeper
+ dev-libs/libxml2
+ >=dev-util/intltool-0.40.0
+ dev-util/gdbus-codegen
+ dev-util/pkgconfig
+ >=sys-devel/gettext-0.17
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-proto/xproto
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+# eautoreconf needs:
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am
+
+pkg_setup() {
+ # FIXME: Add geoclue support
+ G2CONF="${G2CONF}
+ $(use_enable introspection)
+ $(use_enable sendto nautilus-sendto)
+ --enable-documentation
+ --disable-maintainer-mode
+ --disable-desktop-update
+ --disable-icon-update
+ --disable-schemas-compile
+ --disable-static"
+ DOCS="AUTHORS README NEWS ChangeLog"
+
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # Fix make install, is in next release
+ epatch "${FILESDIR}/${P}-fix-makefile.patch"
+
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /$(get_libdir)/udev/rules.d
+ doins "${FILESDIR}"/80-rfkill.rules
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ # Notify about old libraries that might still be around
+ preserve_old_lib_notify /usr/$(get_libdir)/libgnome-bluetooth.so.7
+
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+}
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-9999.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-9999.ebuild
index 0cbd7891..e3c11030 100644
--- a/net-wireless/gnome-bluetooth/gnome-bluetooth-9999.ebuild
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-9999.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/gnome-bluetooth-2.32.0.ebuild,v 1.4 2010/12/19 11:51:36 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/gnome-bluetooth-3.2.2.ebuild,v 1.2 2012/02/14 05:02:43 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
-# libgnome-bluetooth-applet.la is needed by gnome-shell during compilation
-GNOME2_LA_PUNT="no"
+GNOME2_LA_PUNT="yes"
-inherit gnome2 multilib
+inherit autotools gnome2 multilib
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -21,13 +20,12 @@ IUSE="doc +introspection sendto"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~amd64 ~ppc ~x86"
+ KEYWORDS="~amd64 ~x86"
fi
-COMMON_DEPEND=">=dev-libs/glib-2.25.7:2
+COMMON_DEPEND=">=dev-libs/glib-2.29.90:2
>=x11-libs/gtk+-2.91.3:3[introspection?]
>=x11-libs/libnotify-0.7.0
- >=dev-libs/dbus-glib-0.74
introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
sendto? ( >=gnome-extra/nautilus-sendto-2.91 )
@@ -35,16 +33,18 @@ COMMON_DEPEND=">=dev-libs/glib-2.25.7:2
RDEPEND="${COMMON_DEPEND}
>=net-wireless/bluez-4.34
app-mobilephone/obexd
- sys-fs/udev"
+ sys-fs/udev
+ x11-themes/gnome-icon-theme-symbolic"
# To break circular dependencies
PDEPEND=">=gnome-base/gnome-control-center-2.91"
DEPEND="${COMMON_DEPEND}
- !!net-wireless/bluez-gnome
+ !net-wireless/bluez-gnome
app-text/docbook-xml-dtd:4.1.2
app-text/gnome-doc-utils
app-text/scrollkeeper
dev-libs/libxml2
>=dev-util/intltool-0.40.0
+ dev-util/gdbus-codegen
dev-util/pkgconfig
>=sys-devel/gettext-0.17
x11-libs/libX11
@@ -60,7 +60,8 @@ pkg_setup() {
G2CONF="${G2CONF}
$(use_enable introspection)
$(use_enable sendto nautilus-sendto)
- --disable-moblin
+ --enable-documentation
+ --disable-maintainer-mode
--disable-desktop-update
--disable-icon-update
--disable-schemas-compile
@@ -71,29 +72,23 @@ pkg_setup() {
}
src_prepare() {
- # Add missing files for intltool checks
- echo "sendto/bluetooth-sendto.desktop.in" >> po/POTFILES.in
- echo "wizard/bluetooth-wizard.desktop.in" >> po/POTFILES.in
+ # Fix make install, is in next release
+ epatch "${FILESDIR}/${P}-fix-makefile.patch"
- gnome2_src_prepare
+ eautoreconf
}
src_install() {
gnome2_src_install
- local la
- for la in gnome-bluetooth/plugins/libgbtgeoclue.la \
- control-center-1/panels/libbluetooth.la \
- libgnome-bluetooth.la; do
- rm -v "${ED}/usr/$(get_libdir)/${la}" || die
- done
-
insinto /$(get_libdir)/udev/rules.d
- doins "${FILESDIR}"/80-rfkill.rules || die "udev rules installation failed"
+ doins "${FILESDIR}"/80-rfkill.rules
}
pkg_postinst() {
gnome2_pkg_postinst
+ # Notify about old libraries that might still be around
+ preserve_old_lib_notify /usr/$(get_libdir)/libgnome-bluetooth.so.7
elog "Don't forget to add yourself to the plugdev group "
elog "if you want to be able to control bluetooth transmitter."