summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-03-25 18:35:49 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2012-03-25 18:36:56 +0200
commite6acd62f03223a48a230416a17b68b600f939409 (patch)
treee4f34188ec4a053b799be8fbfe9e9a5cc3eb9b8b
parentnet-libs/webkit-gtk: deps (diff)
downloadgnome-e6acd62f03223a48a230416a17b68b600f939409.tar.gz
gnome-e6acd62f03223a48a230416a17b68b600f939409.tar.bz2
gnome-e6acd62f03223a48a230416a17b68b600f939409.zip
x11-wm/metacity: 2.34.1 → 2.34.3
-rw-r--r--x11-wm/metacity/Manifest12
-rw-r--r--x11-wm/metacity/metacity-2.34.3.ebuild74
2 files changed, 86 insertions, 0 deletions
diff --git a/x11-wm/metacity/Manifest b/x11-wm/metacity/Manifest
new file mode 100644
index 00000000..99fd84e1
--- /dev/null
+++ b/x11-wm/metacity/Manifest
@@ -0,0 +1,12 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST metacity-2.34.3.tar.xz 1668396 RMD160 11418a7c344bdbaed24978e3f9abefaaf0cffc24 SHA1 bff0aef175a6a32d0ea20e5253bd9ed602db849d SHA256 aeac2548b62a98375fb5c832ee26ab4cb6d59f0dd96edcefb5f7bef2416576e7
+EBUILD metacity-2.34.3.ebuild 1921 RMD160 3d8ae6e13e9c90c6f0508096b50185eded71f5b5 SHA1 2438195f9c234f5d25f37e34eaff1582c60a4d65 SHA256 bbd075aed041b1b9cefaffa020aa38c71dc7ff342f10a3ff3f6b64b0d75fd6d8
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iEYEAREKAAYFAk9vSWUACgkQ1fmVwcYIWAYh8QCgomSsX2vesItKbWVspKGzXW5a
+ChsAnArPrtBVPkdHNMlufteIiMMJP3BO
+=o7vZ
+-----END PGP SIGNATURE-----
diff --git a/x11-wm/metacity/metacity-2.34.3.ebuild b/x11-wm/metacity/metacity-2.34.3.ebuild
new file mode 100644
index 00000000..5e050d41
--- /dev/null
+++ b/x11-wm/metacity/metacity-2.34.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.34.1.ebuild,v 1.1 2011/07/24 13:37:23 eva Exp $
+
+EAPI="4"
+# debug only changes CFLAGS
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME default window manager"
+HOMEPAGE="http://blogs.gnome.org/metacity/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test xinerama"
+
+# XXX: libgtop is automagic, hard-enabled instead
+RDEPEND=">=x11-libs/gtk+-2.24:2
+ >=x11-libs/pango-1.2[X]
+ >=dev-libs/glib-2.25.10:2
+ >=gnome-base/gsettings-desktop-schemas-3.3
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXdamage
+ x11-libs/libXcursor
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libSM
+ x11-libs/libICE
+ media-libs/libcanberra[gtk]
+ gnome-base/libgtop
+ gnome-extra/zenity
+ xinerama? ( x11-libs/libXinerama )
+ !x11-misc/expocity"
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README *.txt doc/*.txt"
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-maintainer-mode
+ --enable-canberra
+ --enable-compositor
+ --enable-render
+ --enable-shape
+ --enable-sm
+ --enable-startup-notification
+ --enable-xsync
+ $(use_enable xinerama)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # WIFEXITED and friends are defined in sys/wait.h
+ # Fixes a build failure on BSD.
+ # https://bugs.gentoo.org/show_bug.cgi?id=309443
+ # https://bugzilla.gnome.org/show_bug.cgi?id=605460
+ epatch "${FILESDIR}/${PN}-2.28.1-wif_macros.patch"
+}