summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek.chauhan@gmail.com>2009-02-07 23:52:56 +0530
committerNirbheek Chauhan <nirbheek.chauhan@gmail.com>2009-02-07 23:52:56 +0530
commit0ea5d6c0614ce4d56ddecab40ba978af380bbe49 (patch)
tree3e3ee455ba91775a0802e3b5f0afe7f08a03217b /gnome-base/gnome-settings-daemon/files
parentAdd gnome-base/gnome-desktop-2.25.90 (diff)
downloadgnome-0ea5d6c0614ce4d56ddecab40ba978af380bbe49.tar.gz
gnome-0ea5d6c0614ce4d56ddecab40ba978af380bbe49.tar.bz2
gnome-0ea5d6c0614ce4d56ddecab40ba978af380bbe49.zip
Add gnome-base/gnome-settings-daemon-2.25.90
Diffstat (limited to 'gnome-base/gnome-settings-daemon/files')
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-2.25.90-background.patch16
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-2.25.90-libnotify-automagic.patch22
2 files changed, 38 insertions, 0 deletions
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-2.25.90-background.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-2.25.90-background.patch
new file mode 100644
index 00000000..a18d73ca
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-2.25.90-background.patch
@@ -0,0 +1,16 @@
+Index: plugins/background/gsd-background-manager.c
+===================================================================
+--- plugins/background/gsd-background-manager.c (revision 639)
++++ plugins/background/gsd-background-manager.c (working copy)
+@@ -161,7 +161,10 @@
+ int n_screens;
+ int i;
+
+- if (nautilus_is_running ()) {
++ if (nautilus_is_running () ||
++ !gconf_client_get_bool (manager->priv->client,
++ "/desktop/gnome/background/draw_background",
++ NULL)) {
+ return;
+ }
+
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-2.25.90-libnotify-automagic.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-2.25.90-libnotify-automagic.patch
new file mode 100644
index 00000000..eee4f65b
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-2.25.90-libnotify-automagic.patch
@@ -0,0 +1,22 @@
+--- configure.ac 2008-10-09 00:03:09.000000000 +0200
++++ configure.ac.new 2008-10-09 00:03:46.000000000 +0200
+@@ -87,9 +87,16 @@
+ dnl - Check for libnotify
+ dnl ---------------------------------------------------------------------------
+
+-PKG_CHECK_MODULES(LIBNOTIFY, libnotify >= $LIBNOTIFY_REQUIRED_VERSION,
+- [AC_DEFINE(HAVE_LIBNOTIFY, 1, [Define if libnotify is available])
+- have_libnotify=yes], [have_libnotify=no])
++have_libnotify=no
++AC_ARG_ENABLE(libnotify,
++ AS_HELP_STRING([--disable-libnotify], [Enable nice notifications]),
++ , enable_libnotify=yes)
++
++if test "x$enable_libnotify" = "xyes"; then
++ have_libnotify=yes
++ PKG_CHECK_MODULES(LIBNOTIFY, libnotify >= $LIBNOTIFY_REQUIRED_VERSION)
++ AC_DEFINE(HAVE_LIBNOTIFY, 1, [Define if libnotify is available])
++fi
+ AC_SUBST(LIBNOTIFY_CFLAGS)
+ AC_SUBST(LIBNOTIFY_LIBS)
+