summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan@gentoo.org>2018-02-14 22:32:40 +0330
committerSobhan Mohammadpour <sobhan@gentoo.org>2018-02-14 22:32:40 +0330
commitc1298d1702e448ba60a6e322967e80af9bb1cfea (patch)
tree4ff325c33f9d7f97436100f14cc3a0287c7897cb /gnome-base/gnome-settings-daemon/files
parentRevert "gnome-base/gnome-settings-daemon: bump" (diff)
downloadgnome-c1298d1702e448ba60a6e322967e80af9bb1cfea.tar.gz
gnome-c1298d1702e448ba60a6e322967e80af9bb1cfea.tar.bz2
gnome-c1298d1702e448ba60a6e322967e80af9bb1cfea.zip
Revert "Revert "gnome-base/gnome-settings-daemon: bump""
This reverts commit 7f482f50c0bbf6485cda4e2e4c94dae2fbd60ccb.
Diffstat (limited to 'gnome-base/gnome-settings-daemon/files')
-rw-r--r--gnome-base/gnome-settings-daemon/files/3.24.2-udevrulesdir-configure.patch48
-rw-r--r--gnome-base/gnome-settings-daemon/files/3.24.3-fix-wayland-build.patch53
-rw-r--r--gnome-base/gnome-settings-daemon/files/3.26.1-optional.patch169
3 files changed, 270 insertions, 0 deletions
diff --git a/gnome-base/gnome-settings-daemon/files/3.24.2-udevrulesdir-configure.patch b/gnome-base/gnome-settings-daemon/files/3.24.2-udevrulesdir-configure.patch
new file mode 100644
index 00000000..16988f94
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/3.24.2-udevrulesdir-configure.patch
@@ -0,0 +1,48 @@
+From 04d399edc26bfa44d6053aba929e0776a193cea8 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Mon, 29 May 2017 00:38:57 +0300
+Subject: [PATCH 1/5] build: Get udevrulesdir from pkg-config
+
+Use the standard way to find the udev rules directory via pkg-config by default,
+and support specifying it, should it be necessary.
+This is the same logic as in colord.
+---
+ configure.ac | 9 +++++++++
+ plugins/rfkill/Makefile.am | 1 -
+ 2 files changed, 9 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1107578..475821d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -104,6 +104,15 @@ fi
+ AM_CONDITIONAL(HAVE_GUDEV, test x$have_gudev = xyes)
+
+ dnl ---------------------------------------------------------------------------
++dnl - Where to install udev rules
++dnl ---------------------------------------------------------------------------
++AC_ARG_WITH([udevrulesdir],
++ AS_HELP_STRING([--with-udevrulesdir=DIR], [Directory for udev rules files]),
++ [],
++ [with_udevrulesdir=$($PKG_CONFIG --variable=udevdir udev)/rules.d])
++AC_SUBST([udevrulesdir], [$with_udevrulesdir])
++
++dnl ---------------------------------------------------------------------------
+ dnl - ALSA integration (default enabled)
+ dnl ---------------------------------------------------------------------------
+ ALSA_PKG=""
+diff --git a/plugins/rfkill/Makefile.am b/plugins/rfkill/Makefile.am
+index 3c5ec47..bfc34c6 100644
+--- a/plugins/rfkill/Makefile.am
++++ b/plugins/rfkill/Makefile.am
+@@ -30,7 +30,6 @@ desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+ org.gnome.SettingsDaemon.Rfkill.desktop: $(desktop_in_files) Makefile
+ $(AM_V_GEN) sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
+
+-udevrulesdir = $(prefix)/lib/udev/rules.d
+ udevrules_DATA = 61-gnome-settings-daemon-rfkill.rules
+
+ EXTRA_DIST = $(udevrules_DATA) $(desktop_in_files)
+--
+2.10.2
+
diff --git a/gnome-base/gnome-settings-daemon/files/3.24.3-fix-wayland-build.patch b/gnome-base/gnome-settings-daemon/files/3.24.3-fix-wayland-build.patch
new file mode 100644
index 00000000..4a06889a
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/3.24.3-fix-wayland-build.patch
@@ -0,0 +1,53 @@
+From 58403ad7677d98fbb14b020dc4d15c52a695496e Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Fri, 18 Aug 2017 09:42:56 +0200
+Subject: [PATCH] Fix build issue when gudev is detected in the absence of
+ wayland
+
+See https://bugs.gentoo.org/show_bug.cgi?id=627966
+---
+ configure.ac | 5 +++++
+ plugins/common/Makefile.am | 2 +-
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 908b3a3a..c89d5e2d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -140,15 +140,20 @@ AC_ARG_ENABLE(wayland,
+ AS_HELP_STRING([--disable-wayland],[Disable wayland support (default: auto)]),
+ enable_wayland=$enableval, enable_wayland=auto)
+ if test x$enable_wayland != xno; then
++ AS_IF([test "$have_udev" = no],
++ [AC_MSG_ERROR([udev is required for Wayland support])])
++
+ PKG_CHECK_MODULES(WAYLAND, wayland-client, have_wayland=yes, have_wayland=no)
+ if test x$have_wayland = xyes; then
+ AC_DEFINE(HAVE_WAYLAND, 1, [Define if libwayland-client is available])
++ GUDEV_PKG="$GUDEV_PKG gdk-wayland-3.0"
+ else
+ if test x$enable_wayland = xyes; then
+ AC_MSG_ERROR([Wayland enabled but not found])
+ fi
+ fi
+ fi
++AM_CONDITIONAL(HAVE_WAYLAND, test x$have_wayland = xyes)
+
+ dnl ================================================================
+ dnl Plugins
+diff --git a/plugins/common/Makefile.am b/plugins/common/Makefile.am
+index 107e4d3b..760f3198 100644
+--- a/plugins/common/Makefile.am
++++ b/plugins/common/Makefile.am
+@@ -40,7 +40,7 @@ libcommon_la_SOURCES = \
+ gsd-shell-helper.c \
+ gsd-shell-helper.h
+
+-if HAVE_GUDEV
++if HAVE_WAYLAND
+ libcommon_la_SOURCES += \
+ gsd-device-manager-udev.c \
+ gsd-device-manager-udev.h
+--
+2.14.1
+
diff --git a/gnome-base/gnome-settings-daemon/files/3.26.1-optional.patch b/gnome-base/gnome-settings-daemon/files/3.26.1-optional.patch
new file mode 100644
index 00000000..608784c4
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/3.26.1-optional.patch
@@ -0,0 +1,169 @@
+From 9116667b39f7a3ef622b0fd4e09ffa77718fa5c2 Mon Sep 17 00:00:00 2001
+From: Ole Reifschneider <mail@ole-reifschneider.de>
+Date: Tue, 15 Aug 2017 18:51:42 +0200
+Subject: [PATCH 1/6] Make colord and wacom support optional
+
+Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
+Signed-off-by: Timo Tambet <ttambet@gmail.com>
+Signed-off-by: Yuh-Horng Chen <yhchens@gmail.com>
+---
+ configure.ac | 54 ++++++++++++++++++++++++++++++----------------
+ plugins/Makefile.am | 9 ++++++--
+ plugins/common/Makefile.am | 7 ++++--
+ plugins/dummy/Makefile.am | 5 ++++-
+ 4 files changed, 52 insertions(+), 23 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 73fe91e6..d8778c93 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -158,13 +158,23 @@ PKG_CHECK_MODULES(CLIPBOARD,
+ gtk+-x11-3.0
+ x11)
+
+-PKG_CHECK_MODULES(COLOR,
+- colord >= 1.0.2
+- gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
+- libcanberra-gtk3
+- libgeoclue-2.0 >= $GEOCLUE_REQUIRED_VERSION
+- lcms2 >= $LCMS_REQUIRED_VERSION
+- libnotify)
++AC_ARG_ENABLE([color],
++ AS_HELP_STRING([--disable-color],
++ [turn off color plugin]),
++ [],
++ [enable_color=yes])
++
++AS_IF([test "$enable_color" = "yes"],
++ [PKG_CHECK_MODULES(COLOR,
++ colord >= 1.0.2
++ gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
++ libcanberra-gtk3
++ libgeoclue-2.0 >= $GEOCLUE_REQUIRED_VERSION
++ lcms2 >= $LCMS_REQUIRED_VERSION
++ libnotify)
++ AC_DEFINE(HAVE_COLOR, 1, [Define if color plugin is enabled])
++ ])
++AM_CONDITIONAL(BUILD_COLOR, test "x$enable_color" = "xyes")
+
+ PKG_CHECK_MODULES(DATETIME,
+ libnotify >= $LIBNOTIFY_REQUIRED_VERSION
+@@ -268,23 +278,31 @@ case $host_os in
+ if test "$host_cpu" = s390 -o "$host_cpu" = s390x; then
+ have_wacom=no
+ else
+- if test x$enable_gudev != xno; then
+- LIBWACOM_PKG="libwacom >= $LIBWACOM_REQUIRED_VERSION"
+- PKG_CHECK_MODULES(LIBWACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION])
+- PKG_CHECK_MODULES(WACOM, [gtk+-3.0 pango >= $PANGO_REQUIRED_VERSION])
+- PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0])
+- else
+- AC_MSG_ERROR([GUdev is necessary to compile Wacom support])
+- fi
+- AC_DEFINE_UNQUOTED(HAVE_WACOM, 1, [Define to 1 if wacom support is available])
+- have_wacom=yes
++ have_wacom=no
++ AS_IF([test "$enable_gudev" != "no"],
++ [AC_ARG_ENABLE([wacom],
++ AS_HELP_STRING([--disable-wacom],
++ [turn off wacom plugin]),
++ [],
++ [enable_wacom=no]) dnl Default value
++ AS_IF([test "$enable_wacom" = "yes"],
++ [
++ PKG_CHECK_MODULES(LIBWACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION])
++ PKG_CHECK_MODULES(WACOM, [gtk+-3.0 pango >= $PANGO_REQUIRED_VERSION])
++ PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0])
++ have_wacom=yes
++ AC_DEFINE_UNQUOTED(HAVE_WACOM, 1, [Define to 1 if wacom support is available])
++ ])
++ ], [
++ AC_MSG_ERROR([GUdev is necessary to compile Wacom support])
++ ])
+ fi
+ ;;
+ *)
+ have_wacom=no
+ ;;
+ esac
+-AM_CONDITIONAL(HAVE_WACOM, test x$have_wacom = xyes)
++AM_CONDITIONAL(BUILD_WACOM, test x$have_wacom = xyes)
+
+ dnl ---------------------------------------------------------------------------
+ dnl - common
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index 9324b406..ee78d6d0 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -4,7 +4,6 @@ enabled_plugins = \
+ a11y-keyboard \
+ a11y-settings \
+ clipboard \
+- color \
+ datetime \
+ dummy \
+ power \
+@@ -22,13 +21,19 @@ enabled_plugins = \
+
+ disabled_plugins = $(NULL)
+
++if BUILD_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if SMARTCARD_SUPPORT
+ enabled_plugins += smartcard
+ else
+ disabled_plugins += smartcard
+ endif
+
+-if HAVE_WACOM
++if BUILD_WACOM
+ enabled_plugins += wacom
+ else
+ disabled_plugins += wacom
+diff --git a/plugins/common/Makefile.am b/plugins/common/Makefile.am
+index 239c6015..65de4007 100644
+--- a/plugins/common/Makefile.am
++++ b/plugins/common/Makefile.am
+@@ -49,14 +49,17 @@ libcommon_la_CPPFLAGS = \
+ -I$(top_builddir)/gnome-settings-daemon \
+ -I$(top_srcdir)/data/
+
+-libcommon_la_CFLAGS = $(COMMON_CFLAGS)
++libcommon_la_CFLAGS = \
++ $(COMMON_CFLAGS) \
++ $(LIBWACOM_CFLAGS)
+
+ libcommon_la_LDFLAGS = \
+ $(GSD_PLUGIN_LDFLAGS)
+
+ libcommon_la_LIBADD = \
+ $(top_builddir)/gnome-settings-daemon/libgsd.la \
+- $(COMMON_LIBS)
++ $(COMMON_LIBS) \
++ $(LIBWACOM_LIBS)
+
+ libexec_PROGRAMS = gsd-test-input-helper
+
+diff --git a/plugins/dummy/Makefile.am b/plugins/dummy/Makefile.am
+index cb5856cf..d8e8bc4e 100644
+--- a/plugins/dummy/Makefile.am
++++ b/plugins/dummy/Makefile.am
+@@ -25,7 +25,10 @@ desktop_DATA =
+ if !SMARTCARD_SUPPORT
+ desktop_DATA += org.gnome.SettingsDaemon.Smartcard.desktop
+ endif
+-if !HAVE_WACOM
++if !BUILD_COLOR
++desktop_DATA += org.gnome.SettingsDaemon.Color.desktop
++endif
++if !BUILD_WACOM
+ desktop_DATA += org.gnome.SettingsDaemon.Wacom.desktop
+ endif
+ if !BUILD_PRINT_NOTIFICATIONS
+--
+2.14.1
+